Reg Wrench

My feedback

  1. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Premiere Pro » Editing  ·  Flag idea as inappropriate…  ·  Admin →
    Reg Wrench shared this idea  · 
  2. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Premiere Pro » Editing  ·  Flag idea as inappropriate…  ·  Admin →
    Reg Wrench shared this idea  · 
  3. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Premiere Pro » User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
    Reg Wrench shared this idea  · 
  4. 4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Premiere Pro » Editing  ·  Flag idea as inappropriate…  ·  Admin →
    Reg Wrench shared this idea  · 
  5. 6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Premiere Pro » Performance  ·  Flag idea as inappropriate…  ·  Admin →
    Reg Wrench shared this idea  · 
  6. 12 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Premiere Pro » User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
    An error occurred while saving the comment
    Reg Wrench commented  · 

    Agree, new release is terrible. Massive performance hit particularly with Multicam - I created a multi group of 6 cameras in new version and it wouldn't play well at all. I exported an xml of the sync sequence and imported that into 2017 where it played really smoothly. Opening the 2017 project in 2018 (it gets converted) made the multi group choppy and unplayable again.

    Performance hit also makes the essential graphics title tool unusable.

    Also when you open a project you often have to solo and unsolo an audio track to hear anything, it often crashes on renders and the video/audio usage drop down menus no longer work.

    Is this a general thing, a mac thing or should I try re-installing?

  7. 37 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    74 comments  ·  Premiere Pro » Audio  ·  Flag idea as inappropriate…  ·  Admin →
    An error occurred while saving the comment
    Reg Wrench commented  · 

    For me it only happens when opening a project. Toggling the solo on and off fixes it until the project is opened again.

  8. 5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Premiere Pro » Stability  ·  Flag idea as inappropriate…  ·  Admin →
    Reg Wrench shared this idea  · 
  9. 7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Premiere Pro » Stability  ·  Flag idea as inappropriate…  ·  Admin →
    Reg Wrench shared this idea  · 

Feedback and Knowledge Base