After Effects

ANNOUNCEMENT - This forum has been moved


In an effort to improve communications between you and the After Effects team, we are moving this feedback forum to the After Effects page on the Adobe Support Community. As requested, bugs and feature requests will be able to live separately in that forum.

This move is happening in part to acknowledge that we haven't been responsive enough here, and are combining our forums to help remedy that. All ideas and their attached comments from this UserVoice forum will be migrated based on how many voted for them. Check your profile on the Adobe Support Community to see any migrated posts that you've created or commented on. If you have an item here that did not make the migration, please bring it over to our new home.

See you soon on the Adobe Support Forum!
  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. BUG: Right click on image in library closes entire library window

    When I right click on an image in the library the entire libraries window closes randomly.

    I have testing with adobe stock v non stock, tested in various libraries and there does not seem to be any rhyme or reason. Sometimes I can get the pop up with additional options, such as find similar etc, but about 70% of the time the entire Libraries window completely closes and I have to re-open, resize etc

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  2. Fix audio playback using period (.) key

    When using the period (.) key on the numpad to play audio only, it doesn't play the audio from the start but cuts off the first second or so. This has been a bug for a while now and I'm surprised it's still in there and noone reported it before.

    8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    We need more information in order to investigate this problem.

    - What version of After Effects are you using? From the About After Effects screen, ex. After Effects 16.0
    - What OS and version are you using? ex., Windows 10 or macOS 10.14
    - What type of audio files are you using in your composition?

  3. Cineware fix on first start

    A lot of time, when I open an .aep file with a .c4d in the project, the cineware plugin have an error. I have to restart AE to work fine.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  4. Adob CC After effects 2019 keeps crashing

    So since last week im not sure if this is due to a windows update or something else. But i have been having glitches and crashes in after effects 2019.
    The frist thing is, an imported video turns purple and green, i have tried purging cache, cleaning up the pc, reinstalling after effects, this did not help with it, i have tried changing the renderers. Nothing helps.
    The second thing is, moving a frame or previewing it, leads to crashing after effects. Even making a new composition has the same effect.
    I have no idea what to do, and no…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  5. CC2019 Expression controls don't work in Motion graphics templates exported to Premiere Pro

    Very annoying bug : I cannot use any of the expression controls added to the Essential Graphics Panel when using the template in Premiere Pro CC 2019. The controls are there but nothing happens when I change their value.
    The attached projects shows a very simple case. The template just generates a solid overlay with a simple control to adjust its position.
    When the position is controlled by an expression control, it does not work in Premiere.
    When the position is controlled by anything else (the anchor point of a Null, for example), it works correctly.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    There was no file attached to the report. Can you please post a link to a download of the After Effects project or a screenshot of the project that identifies that properties and expressions in use? Since UserVoice does not allow attachments in comments, post either a link to a file share (Dropbox, etc.) or re-file the bug with an attachment to the original post.

  6. Time Reverse layer

    There is a persisting bug with the 'Time reverse layer' command - often drops first frame, sometimes drops or displays random wrong frame elsewhere in the reversed layer.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Can you please post a project file with footage that demonstrates this issue? Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  7. motion blur and continuously rasterize - Bug

    On After Effects CC 2019: When I hit the motion blur button and the continuously rasterize button on a composition, After Effects crashes down or the composition get double and changes its place.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    We need more information to be able to investigate this problem.

    Can you post a project that experiences this problem? And/or a screen recording of the problem in action.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  8. Bug Report: masks in AE 2019

    Whenever I edit a mask, the mode goes from add, subtract et al to none. This happens with every project and is massively frustrating. I'm using the latest version of AE on Windows 10, i9 9900k, 64GB RAM and a 980ti. Here's a link to a screen recording of the glitch https://www.csmotion.co.uk/wp-content/uploads/2018/12/2018-12-06_10-57-18.gif

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report, and for providing a screen recording of the problem in action.

    I do not reproduce this problem on my computer, so I suspect this problem is configuration-specific.

    Have you tried resetting the preferences for After Effects? To reset the preferences for After Effects, do either of the following:
    - (Preferred) Choose Preferences > General > and click on Reveal Preferences in Finder (macOS) or Explorer (Windows). Then quit After Effects and move the parent folder of these files (the version number, ex. 16.0 or 15.1) to your desktop. If this step helps, you can try moving your individual preference files back one at a time, or if does not resolve the problem, you can move the entire folder back.
    - Hold the Option (macOS) or Alt (Windows) key while launching After Effects.

    One thought that occurs to me: when modifying a mask in…

  9. Automatic Instanced effects

    Example : I copy a blur, or a curve, i paste it on another layer, at this moment, i would want to have a choice betwen "copy" or "intanced" copy.
    Instanced is a automatic link betxen the affects, and of course any modification on my curve will bereported to all instanced copy of it.(like in 3ds max , for example).
    Of cource, a right clic on it can un link it from the others.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for submitting this suggestion.

    Similar functionality exists in After Effects. The Edit > Copy with Property Links (and Copy with Relative Property Links) command will do as you describe.

    The Copy with Property Links commands link the pasted effect using expressions. You can use the commands on effects, or just single properties (including transform properties), or even a whole layer.

    If there is additional functionality you still desire in After Effects, please elaborate.

  10. Late to the party, updated to 16.1

    Late to the party, updated to 16.1 and I'm having all sorts of issues with text layers (sometimes they crash it completely, other times if it's a text layer on top of another layer, the text layer disappears.) Also, any project from a previous version crashes when I try to update it so I have to import it into a new project and pray the comp I open doesn't crash.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    A bug where After Effects may crash when opening a project if there are missing fonts was fixed in the April 2019 bug-fix patch for After Effects (version 16.1.1). You can install this patch via the Creative Cloud desktop application.

    If the 16.1.1 update does not resolve the problem you’re experiencing, it would be helpful if you could provide us with one or more project files that demonstrate the issues you’ve described.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  11. Some conflict between cuda and AE 2018/2019 and transform effect

    Error GPU out of memory appears when I use "transform" effect on a solid layer, if I disable GPU acceleration or work in AE CC 2017 all is fine.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    We need more information about the conditions you experience the problem.

    • What OS and version are you using? i.e., Windows 10 or macOS 10.14
    • What graphics card is installed? What driver version?
    • Does the this problem only happen in your existing projects, or does it occur if you create a new comp and a new solid, and apply only the Transform effect?

    Update 26 Nov 2018:
    Could you share a project with us that exhibits the problem? I think we need to inspect the specific conditions of the comp that you’re using. We’re not able to reproduce the problem with a simple comp + solid.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked;…

  12. Any 29.97 fps footage crashes AE 16.1

    Hi After Effects 16.1 crashes continuously while adding any 29.98 fps footage to the comp.
    It imports to the project ok, opens in the footage window, allows to trim but Ae immediately freezes as I insert -edit it to the composition.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  13. Bug Report: AE 2019 Write-On Effect not working.

    I am unable to get the write-on effect to work with any stability. I noticed this in a 2018 file I was editing. It seems I can set up the keyframes, but then after scrubbing the timeline or working on other write-on reveals, it fails. See attached file.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Update 14 Nov 2018 – I received the files, thank you.

    After playing with the project for a little bit, I see how the Write-on effect is not behaving correctly. But I’m not able to deduce what the cause of the problem is. I’m not able to reproduce the problem from scratch, and if I make modifications to your project, it starts to render correctly.

    My best guess is that the keyframe data of the Write-on effect in your project became corrupted somehow. It’s relatively easy to fix, although a bit tedious:

    1. On each keyframe, modify the property value. (I made small adjustments, like rounding fractional X or Y values up to the nearest integer, or increasing the brush size by 1. Any change to the keyframe’s value should work here.)
    2. Edit > Purge > All Memory & Disk Cache.

    If…

  14. 16.1 update rendering bug : 1000% speedup on rendered output

    idea? NO. this is a bug report.
    a SHOW STOPPER BUG.

    renders are now outputting at 1000% percent of the speed of the comps.

    for example: a 5 minute output now comes in around 5 seconds.

    PULL 16.1 TILL YOU GET THIS FIXED

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for this bug report.

    Can you share a project file that demonstrates the problem? Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

    Also, what OS and version are you using? (ex., Windows 10 or macOS 10.14.3) What is your hardware configuration?

    This is the first report we’ve heard of this problem, so we need to understand your project and configuration in order to investigate.

  15. ADD LEFT-TO-RIGHT-SUPPORT

    Just do it already! Many of us been waiting patiently for for this feature that takes just about F-O-R-E-V-E-R. Don't search what to add on to any of your software's until you give users basic-typing-capabilities within your software.

    1.It hinders productive time when having to use 3rd party tools to convert text to the right direction.

    1. any mistake in the text, just takes, you've got it! MORE TIME TO CORRECT.

    2. It's basic. L-a-n-g-u-a-g-e. make every ADOBE software COMPATIBLE!

    3. Year 2020. We've waited long ENOUGH from October 1995.

    Just do it already!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this request.

    Right-to-left text support was added to After Effects 14.2 (June 2017 release; current version is 16.0.1).

    Details on how to change text direction is here:
    https://helpx.adobe.com/after-effects/using/creating-editing-text-layers.html#change_the_direction_of_text

    If there is additional functionality for text direction support that you’re looking for, please provide specifics.

  16. AE 2019 master properties (with keyframes) causes random glitch

    I have builded a template project with the AE 2018 that involves expressions and master properties to animate the properties of the multiple templates in the same comp. It works fine in the 2018.
    When I've imported it in the the AE 2019 it start to glitch and doesn't recognise some keyframe in random way, purge the cash works just temporarily, I have also tried to collapse the properties, but does't work.
    I have had to downgrade the project and to the 2018, but all the comps reset to the default I have to re keyframe all the master properties…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  17. Motion Blur Bug: Motion Blur is randomly on when switches are off

    In a large animation project, I have all motion blur switches turned off for all individual layers, sub comps, and master switches within them. When ram previewing, it plays just fine, but when I go to render it puts motion blur on random layers, not all. I have triple checked all layers and effects, adjustment layers, there is nothing that has motion blur turned on, built in, or is forcing it. The only way around it has been to turn off motion blur for all layers in the render settings above the output module.

    This is in CC 2019, on…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this report.

    When exporting via the Render Queue, there is an option in the Render Settings dialog which determines whether or not motion blur will be rendered. By default, the Motion Blur control defaults to On For Checked Layers, which will render motion blur for any layer on which the layer’s motion blur switch is enabled, regardless of the state of the comp’s “master” motion blur switch.

    Are you changing this setting in the Render Settings? Does its behavior otherwise align with your experience of which layers do or don’t render motion blur when exported via the Render Queue?

  18. Enable After Effects to run in a Windows Service Enviroment

    Enables you to start After Effects in Render Engine Mode as a Windows Service or in a Windows Service environment without Windows login. This allows After Effects to be used with render management programs such as AWS Deadline in a render farm. We also comply with the European DSGVO, as After Effects starts without logging on to Windows and the computer itself can therefore remain password-protected.

    Currently, After Effects crashes when, for example, it is executed using the Windows Task Scheduler directly after system start, but without physical user logon.

    Informations about RE Mode: https://blogs.adobe.com/creativecloud/installing-after-effects-cc-render-engines-with-adobe-creative-cloud/

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  19. AE 2019 unable to allocate ram error popup then crash

    Getting a lot of this error with AE 2019. No issues previously. Not great for a machine with 128GB ram. Usually happens when I open a project with an existing project open already.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this report.

    We need more information before this report can be investigated.

    If the problem occurs when you open a project, can you send us the project? It would also be helpful to get an After Effects Log file.

    To generate After Effects Log.txt, choose Help > Enable Logging. Restart After Effects, then choose Help > Reveal Logging File. Cause the problem to happen, then retrieve After Effects Log.txt from the folder. Note that logging will automatically disable after 24 hours.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

    Also, do you get…

  20. Top/First Text Layer Acts as a Mask

    When creating multiple text layers, randomly, the first text layer creates starts acting as a weird mask layer that makes all the rest of the independent text layers disappear. Turning off this first layer will make the second layer in the index appear, yet the other ones will remain "masked out".

    Interestingly, if you move this aforementioned text layer to the top, all text layers merge and After Effects crashes.

    Please look at the screenshots to understand progression to replicate this bug.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Can you share the project file with us that causes this problem? Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

Feedback and Knowledge Base