After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Expressions with posterizeTime fail to posterize if expression returns a property directly

    AE Version: 17.6.0 (Build 46)

    Reproduction Steps:
    - Create a New Project
    - Add a new layer
    - Animate the position property with keyframes
    - Apply the following expression to position:
    posterizeTime(6); transform.position

    Expected Behavior:
    Position animation is posterized.

    Actual Behavior:
    Position animation is not posterized.

    Additional Notes:
    The failure to posterize only occurs in cases where the expression returns a property directly. For instance, the following expression...

    posterizeTime(6); transform.position + [0, 0]

    ... does correctly posterize the position animation, despite the fact that it should be returning an identical result. This can be seen in my first example AEP…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  2. align 3D layers

    Align 3D layers. Distribute them, etc. That's it really.

    133 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  3. DE: Wrong UI translation for “tab”

    In the After Effects UI, the German tool tip string for the Mini Flow Chart reads as „Kompositions-Mini-Flussdiagramm (Registerkarte)“.

    The German noun „Registerkarte“ is the right translation for the English term “tab” when it means a tab of a folder or a row of tabs in the UI, not when referring to the tab key. In the latter case the correct translation is „Tabulator“.

    The value of $$$/AE/Timeline/Tooltip/OpenMiniFlowchart in Support Files/Dictionaries/de_DE/after_effects_de_DE.dat needs to be changed accordingly.

    Best regards

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  4. Hide Layer controls while scrubbing

    Simple option in preferences to Hide Layer controls while scrubbing.
    Why, because it improves performance by order of magnitude!

    Also, Hide Layer controls while handling layers in timeline, same reason!

    Or rewrite layer controls overlay.

    We all know that AE became browser engine, but please don`t be internet explorer!

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. BUG: White dot/blob appears in 8bpc project

    I have encountered a weird bug. First, I thought it was a fault in the project, but today I created a new, blank one, added an empty comp and the white blob is back. It looks the same and its on the same position.
    Since its repeating in a brandnew project, this is likely a bug.

    Its only visible in 8bpc projects, all higher bpc, this blob is gone.
    I haven't re-installed AE yet, since its a workplace station and the IT has to do this and also reinstall all plugins. During a working day, thats almost impossible.

    Do you…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  5 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  6. 4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  7. Introduce glyph and variable font use

    A lot of fonts nowadays have a wide range of glyphs or are variable fonts. These are features which we use in indesign and illustrator a lot when working with text and it would be a lot of help if we could use it directly on after effects without having to export illustrator assets for every single line of text.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  8. Magenta Color Shift when exporting ProRes4444 with AE2020 on Windows

    In AE2020 Exporting a clip as ProRes4444 Millions of Colors on Windows results in an Output with a color shift towards Magenta. This can only be resolved by changing the codec to Trillions of colors.

    Also when Using ProRes 4444 XQ with the same color settings the color shift gets an additions Gamma shift problem.

    On AE 2019 this issue was not there. Also on Mac this issue can not be seen.

    We tested it on multiple Windows machines and on all of them the problem appears with AE 2020 v.17.1.4

    Please fix this problem

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  9. Corner pin handles not showing up on pre-comp

    BUG When adding a corner pin effect, or CC power pin, the handles for the corner pin don't show up. Also the null object doesn't show up either. When you toggle the hide mask button a bunch of times and re-add the corner pin it finally shows up.

    8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  10. Playback won't stop playing back

    Bug Report:

    When doing a RAM preview, After Effects will cache and play like normal, but won't stop. The interface will hang and AE will continue to play back indefinitely. This issue occurs seemingly randomly several times throughout the day.

    This is occurring on several computers running Windows 10 and AE 17.0.4.

    31 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    10 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  11. Ridiculously slow and laggy interface

    I almost can't work in it. Third party effects are useless and the overall responsiveness of After Effects 202 is terrible. If I didn't keep getting the ridiculous drawing error in the 2019 version, I'd be using it. You HAVE to fix this issue fast. Your application is almost useless right now. People are going to switch. Right now, I totally regret upgrading to CC 2020.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  12. Multi-core processing

    My company is working on the cutting edge of 6K+ stereoscopic 360 VR. We have gone through great lengths to purchase the most powerful PCs available on the market for the sake of faster performance. Unfortunately we're faced with the bottleneck of your software not utilizing this modern technology. Simple tasks are literally taking days, and at times weeks because of this. At all times, Windows Task Manager is showing After Effects utilizing less than 10% of both CPU and GPU. We have spoken at length with multiple reps from Adobe, Mocha, After Effects and Microsoft to confirm our settings…

    132 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  13. Queue in AME needs to know you've queued to AME!

    Ok, so here's the thing. I have occasion to produce differing versions of graphics on a weekly basis for a regular client. These are all produced in in AE and need outputting as MP4, so my workflow is to make the changes, select the 3 comps that need rendering, add to the render queue then hit Queue in AME. So far, so good. EXCEPT that if I haven't already loaded up AME there's no real signal that you actually DID queue them until AME loads up (you know, 40 years later). More than once, I have to think "did I…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  14. Bug Report: Resizing the composition causes the 3D layer to shift.

    If you resize the composition using the "Crop Comp to Region of Interest" feature in version 17.5.1, there will be a difference in the display between 2D and 3D layers with the same X and Y numbers.
    It didn't happen in versions prior to 17.1.4.

    The following reproduction procedure
    1, Creating a composition
    2, Create a new layer
    3, Resize the composition using "Crop Comp to Region of Interest"
    4, Check the 3D layer.

    Other than "Crop Comp to Region of Interest", the same phenomenon occurs when resizing with "Composition Settings / Advanced / Anchor" selected other than the center. …

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  15. Please bring all OpenType features to After Effects

    Typography is an important part of many animations. With the great amount of options designers have with OpenType-Fonts every aspect of a font should be accessible in a modern animation software.

    Please add all OpenType-Options as seen in the Photoshop Character Panel to be natively accessible in After Effects.

    141 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  16. SIMPLE, EASY = Folder locations always open at current project's folder

    When choosing a folder to Render or Save into, simply open the folder of where the current project has been opened from. That's it. Not the previous project's save location, or previous render location, but always starting from where the current folder has been opened from and let the user decide from there. This simple change would save so many headaches and be greatly appreciated.

    When working on a tv series many project files have been accidentally saved in incorrect locations because AE currently uses the last render or save location, which is often different from the current project.

    A…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  17. Bug: Moving between screens with different scaling

    When click-dragging a property's numerical value (e.g. position or scale), if the mouse cursor crosses onto a screen with a different scaling setting in Windows Display Setttings to the one with AE in it, the value jumps. The bigger the difference in scaling, the bigger the jump.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  18. Ram preview still doesn't work

    Ram preview has been broken since you overhauled it in what 2016? Still doesn't work. Wth?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  19. Export transparent animated GIFs from After Effects/AME

    Currently, if I want to export a “sticker” (Animated GIF with transparency) for social media, I animate the GIF in After Effects, export a MOV with alpha, via the AE renderer, bring that MOV into Photoshop and export a GIF with transparency via the (legacy) web export. This is a lengthy, complicated process that creates a heavy and useless, for the end product, MOV file.

    In my opinion there are multiple things wrong with this workflow and could be improved by allowing direct export of transparent GIFs from AE.


    1. The Adobe export/render preference for most formats is via AME
      Issue:…

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  20. Bug when using layer search bar

    Hi Adobe,

    After Effects keeps deleting multiple layers when I use the layer search bar to search for 'color' and cmd/ctrl+z won't bring them back so I have to close and reopen the program. Any help would be much appreciated!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base