After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Time Ruler Bug

    The Time Ruler bug I read about from 2017 is still happening in my app. I'm unable to see the Time Ruler in seconds. in Ae current version

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  3 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  2. Slow... Laggy... After... Effects... Workflow

    I'm going to type my complaint in the same format that Adobe after effects allows me to work:

    I

    Can't

    Get

    Anything

    Done

    Without

    The

    Application

    Freezing

    Or

    Hanging

    Every

    10

    Or

    So

    Minutes.

    This

    is

    the

    same

    machine

    that

    spat

    out

    4

    simultaneous

    4K

    renders

    from

    After

    Effects

    DaVinci Resolve, Blender and Unreal Engine, last month (these products get their own line because I don't have to wait for them nearly as much as I do for After effects now.
    After Effects started doing this thing today where I can't use the machine or any other apps (including web…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  4 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  3. Camera GUI display does not reflect expression-driven Point of Interest

    When the "Point of interest" of a camera is driven by an expression.
    Something like:
    thisComp.layer("Null 1").transform.position
    The graphical display of the camera wireframe in the interface does not reflect the value of the expression.
    It seems to be "stuck" at the Point of interests native value.

    After Effects 17.6.0
    MacOS 10.14.6

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  4. Please bring back features

    Please bring back features like "select single view" in viewer settings. It is crucial for those, who are working with 2D animations on small screens and need more screen estate. I've uninstalled version 18.0 and using older v17 until the feature returns. Thank you!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Hi Tomas,

    Can you please explain further which option you’re missing? There were a few changes made in After Effects 18.0 that you might be referring to, and I think there might be a translation problem.

    In After Effects 18.0, the toolbar in the Composition pane was updated to reduce clutter and improve 3D workflows. Details are here:
    https://helpx.adobe.com/after-effects/user-guide.html/after-effects/using/whats-new/2021-2.ug.html#ImprovedCompositionToolbar

    One thing that was changed is that 3D controls now only appear if you have a 3D layer in the comp. We’ve heard from a number of folks that the View Layout menu (selecting 1/2/4 views), which is part fo the 3D controls, is being missed. In the latest releases of After Effects Beta, which you can install via the Creative Cloud app, the View Layout controls are now also accessible via the View menu; you can access these options at any time without a 3D layer being present. Please try…

  5. Bug: Moving between screens with different scaling

    When click-dragging a property's numerical value (e.g. position or scale), if the mouse cursor crosses onto a screen with a different scaling setting in Windows Display Setttings to the one with AE in it, the value jumps. The bigger the difference in scaling, the bigger the jump.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  6. Closing one of two (or more) composition panels should make your other composition panels larger.

    Currently when you have two more composition panels open (i.e. one is locked and you are making changes in a precomp and looking at the effects of that change in a different comp), the default behavior when you close one of those composition panels is to collapse any surrounding panels inward, leaving the other composition panels the same size.

    This is annoying, because rarely do you want the effect control panel or your plug-in panel to expand. What you usually want is for the other composition panel to take up the space where the two were.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  7. BUG - Project Panel reset items position

    Every time I do CTRL-C (copy) on a layers in composition panel all items in Project panel resets its position. Often I work on dozens of Compositions and need to go through some and copy some layers from one to other after I hit CTRL-C I have to scroll Project panel to look for my destination composition despite of that it was just in place where I left Project panel before pressing CTRL-C in composition. Its just annoying.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  8. In After Effects 17.7 the mercury transmit does not work ....in Premiere 14.9 instead it works.

    In After Effects 17.7 the mercury transmit does not work ....in Premiere 14.9 instead it works.
    I have MacBook Pro (16 pollici, 2019)
    2,3 GHz Intel Core i9 8 core
    16 GB 2667 MHz DDR4
    AMD Radeon Pro 5500M 4 GB
    Intel UHD Graphics 630 1536 MB

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  9. Black preview

    The preview frame is black. It no longer has a predefined size. When zooming in / out, the frame does not move, nothing happens. As if there is a black composition of infinite size while I have layers.
    I restarted my pc for the first time, everything is back to normal. Then by relaunching the software to continue the project, the bug returned.
    The preview takes into account the sound, but not the image.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  10. Bug Report - AE 16.0.1 - Lumetri Scopes not displaying anything after some use.

    When using the Lumetri Scopes, after having AE open for some time, the scopes themselves disappear and there seems to be no way to get them working again. I can close the scopes panel and reopen it and also try to change what scopes are displaying but nothing works. Must restart AE for them to work again. Problem typically occurs when changing from one composition to another.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for this bug report.

    Are you also using external video preview via Mercury Transmit? (Preferences > Video Preview)

    When the problem starts, try enabling and then disabling Mercury Transmit. You could also try pressing the / key on the numeric keypad.

    (Under the hood, Lumetri Scopes captures the frame using Mercury Transmit. Although Transmit does not need to be enabled in the prefs for Lumetri Scopes to do this, I’m curious if toggling it on/off would help, or maybe there is a conflict with another Transmit device.)

  11. In panel 3 add a video play button

    Yes I am new to After Effects, just loaded it, but 30 years working software, including Light Room and Photo shop, you don't have a play button??
    Add a play button for newbies. And yes, I am off to watch and learn from the tutorials

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thanks for filing this suggestion.

    The play button in After Effects, and other playback controls, are in the Preview panel. In the Default and Standard workspaces, you can find the Preview panel docked in the column of panels along the right side (underneath the Info and Audio panels). You can undock and/or reorganize the panels to your liking.

    I appreciate that you expect the play controls to be in the same window as the video, which is a common convention for video playback applications. And I agree with you that we should move the playback controls in After Effects. The design After Effects is currently using was made before that convention was common, and had solid logic at its time. While we’ve considered changing that UI, changes to an established application like After Effects come with many complications, and we need to be sure that the benefits of such change…

  12. video preview overlapping second monitor

    I have a Windows 10 machine with a 2-monitor setup. Whenever I enable mercury transmit on the second monitor to use it as a client monitor, it creates a preview that's too large for the screen and extends onto the screen I'm working on. (I've attached a file that shows what I mean.)

    I'm working on a Windows 10 Pro machine with 2 Geforce GTX 1080 TIs bridged together. Admittedly, the screens are different resolutions - but that never seemed to affect anything when I used these exact screens with a Mac. Any help would be greatly appreciated.

    Thanks!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  13. phantom time indicator

    When I select a layer and hit "i" or "o," there is a phantom time indicator that appears there, but the physical one stays where it was. I've attached a picture of what it looks like. Thanks.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    To investigate this, it would be most helpful if you could send us a project file that demonstrates the issue. My suspicion is that this only happens when the layers are in a specific state.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  14. Bug Report: File name and Location Template keeps defaulting to non-existing template

    I have found for a few versions of AE that if I make an "Output File Name and Location Template", then delete that template completely and make a new one, that the output will keep using that template that was first made. Even if I just set the most basic "Comp Name" template as the default, it will still go back to using that original template that I made, that I no longer want to use. So each time I go to render, I need to choose a template to get rid of what it defaults to.

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  5 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  15. AE 2018 Keyboard lag on Mojave

    Just bought a new iMac - AE 2018 has a really frustrating keyboard input lag. Even if you type slowly it misses characters as you type (adding text or just using the interface i.e. naming folders, changing values, pressing spacebar etc). It's incredibly frustrating.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  16. Render queue multiple frame ranges

    A few versions ago Adobe broke AE's render queue. Now all jobs' frame ranges reflect the current In/Out markers making multiple render jobs useless unless you manually edit the render settings > custom frame range PER queue job. I can't see how this is at all useful in any situation and I would much prefer to be able to queue multiple frame ranges than render the current frames multiple times, making a complete1 mess2 of3 your4 output5 folder6.

    Please revert back to how it worked before it became broken.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this report.

    There were no intentional changes to the behavior of rendering frame ranges in the Render Queue. We need more information to understand the problem you are describing.

    Can you provide us with a project with items set up in the queue that do not render as you expect? It will help to have a clear picture of what you are doing, what you expect the result to be, and what result you are actually getting.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  17. BUG: Right click on image in library closes entire library window

    When I right click on an image in the library the entire libraries window closes randomly.

    I have testing with adobe stock v non stock, tested in various libraries and there does not seem to be any rhyme or reason. Sometimes I can get the pop up with additional options, such as find similar etc, but about 70% of the time the entire Libraries window completely closes and I have to re-open, resize etc

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  18. Expression Shortcut

    Expression Shortcut Idea:

    A shortcut to open the expression would be nice.

    Example:
    If I have a position expression on a layer I would normally use the default expression shortcut (Double E). However, it would be nice to have that shortcut (or a new one created). If I select the layer, then push P (to reveal the position) then push Alt + Ctrl+ A (Which will select all properties that are showing). Then, with that property selected, you could then push the double E shortcut to reveal the expression of that property.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for submitting this idea.

    There is already a shortcut available to add an expression to a selected property: Option + Shift + = (macOS) or Alt + Shift + = (Windows)

    The Add Expression command is also available from the Animation menu. The keyboard shortcut can be customized in Edit > Keyboard Shortcuts.

    Does this do what you are requesting? If not, please clarify what functionality you’d like to see added to After Effects.

  19. Using same variable in two different master properties cause crash CC2019 v16.01

    I have a master comp with to sub comps consisting of three text layers each. The two sub comps are lower thirds left and light aligned, but there are three hidden text layers for input from Essential Graphics and I want to link the content of these to both left and right comps respective Master Properties.
    Once I try to add the variable from the master comp to the second comp's master propert and change the check box value from off to on After Effects crashes.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    It would be helpful if we could inspect your project file to see exactly what is happening. We only need the .aep file, not any source media.

    Post a link to your file here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  20. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1
  • Don't see your idea?

Feedback and Knowledge Base