After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Crash with Big Sur 11.2, unusable software

    Dear Adobe, with After Effects CC2020 17.6 we have been experiencing MAJOR crashes. During rendering and sometimes scrubbing, AE just closes and goes to the desktop. It is a crash and then I have to send a bug report. I am attaching the crash logs to help you determine the issue.

    We are on a Mac Pro with Big Sur 11.2 and we even tried removing ALL plugins and reinstalling all adobe software including reinstalling Big Sur, this issue is still persistent.

    In the mean time we are dual booting into Catalina 10.15.7 to continue working and this is unprecedented.…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  2. Assertion (0) failed (DEBUG)

    I have this error all the time! I can´t work. I did an entire project and now this happens all the time.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thanks for posting this report.

    Our devs looked at your screenshot, and this looks like a case where your GPU is running out of memory. Normally we expect After Effects to self-manage in this situation, or at least to give a better error message, so we do consider this a bug.

    To diagnose this further, we need your help. We need more information about your hardware and how After Effects got into this situation. Could you please tell us:
    - About your GPU. Manufacturer, model, VRAM, and driver version.
    - Does the problem persist if you restart After Effects, or failing that, when you restart the computer?
    - What other apps do you have running at the same time? Does the problem occur if you quit them all? (Including web browsers, which are notorious for consuming VRAM.)

  3. Cannot read utf-8 file name in scripting

    Hey Adobe, I have a script where I'm reading utf-8 file name but I'm always getting this error: "Cannot switch to URL". I remember that it used to work and it still works in AE 2020 (17.0) but in AE 2021 it fails. I'm using decodeURIComponent(escape(filename)) to decode it. Can you help me with that?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  4. [Bug Report] Adding sourceRectAtTime() Expression Crashes AE

    When attempting to add a sourceRectAtTime() expression to a Mask Path property that references a text layer, After Effects will immediately crash upon evaluation.

    Reproduction steps:
    1. Create a new project
    2. Create a new composition (tested with HDTV 1080 29.97 preset for repro purposes)
    3. Add a text layer
    4. Create a comp-size solid
    5. Add a comp-size mask to the solid by double clicking the mask button
    6. On the "Mask Path" property of the mask created in step 5, add the expression: `thisComp.layer(<name_of_text_layer>).sourceRectAtTime()

    After clicking out of the expression editor and allowing AE to evaluate, After Effects…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  5. BUG - Internet connection speed may cause AE to lock up with INVALID MENU OPERATION msg

    BUG - Internet connection speed may cause AE to lock up with INVALID MENU OPERATION msg.

    Title says it all, can reproduced 100% of the time by lowering my internet connection speed (i.e. downloads and/or uploads). This is a critical productivity issue that has started occurring today 2021-02-23 and reproduced on both latest versions of AE (had it occur before and after updating the application).

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  5 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  6. [BUG] Green MP4 in timeline

    When adding an MP4 created in AME CC20, the video is displayed with a green error screen. Basic functionality broken yet again. What can I do?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  7. Add to Adobe Media Encoder not working After Effects Version 18.2.0

    When exporting a project and sending (adding) to Media Encoder it will not work. Encoder will open automatically but it's empty and will not see the After Effects project. So unable to export through Encoder.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  8. AE 18.4.1 When I play or ram preview the video and audio was play but other things are freeze

    When I press space bar or 0 to review. Audio and video was play as usually. But playhead and time indicator was freeze.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  9. Draft 3D Crash on 18.2.0

    New bug on latest update.

    I'll work in Draft 3D for ten minutes or so before suddenly my GPU goes from 0%-12% straight to 100% and locks there. After Effects suddenly throws some kind of task to my GPU that prevents anything else from happening. After this state becomes active, turning off Draft 3D/switching to adaptive res does nothing. No way to break whatever task AE has sent to my GPU without end task'ing AE. AE does not hang, but chuggs along as one would expect when the GPU is maxed out.

    No clear activity causes this. It seems to…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this report.

    To understand how After Effects is getting into this crashing condition, we need to profile what it’s doing when it crashes.

    The easiest way is if you could send us your project so we could attempt to recreate the crash ourselves.

    David, do I have your permission to contact you via the email address provided on this site?

  10. I am trying to use an external client monitor but am getting an "Unable to allocate memory" error. I have 96GB RAM installed and have alloca

    BUG: I am trying to use an external client monitor but am getting an "Unable to allocate memory" error. I have 96GB RAM installed and have allocated 84GB to AE. I have successfully used the monitor (output via a Blackmagic video card) with Avid Media Composer.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  11. After Effects v18.0 stuck at "Initialzing Required Components"

    Running version 18.0.1 on Windows 10 (20H2) OS Build 19042.867

    Any time I attempt to start AE, it fails to start the application getting stuck at "Initialzing Required Components"

    I've tried rolling back by video driver (NVIDIA GeForce GT 740, Driver version 461.40) with no luck.

    I've also tried removing the 18.0 folder located at C:\Users<USER>\AppData\Roaming\Adobe\After Effects\18.0

    Crash report is attached.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  12. AE Crashes for some users during use of the tool FreqReact

    This is a repost. Last time I posted, I was told that the newest update (v18) would fix this problem. I've had multiple users confirm that updating did not fix it. I'm really hoping someone can help.


    I'm pretty desperate for some insight on a problem that's been plaguing my tool FreqReact for a while now. For some users, After Effects fully crashes when they enter in to what I call the 'Spectrum View' (which is where they would select frequencies in the music that they want to react to.) It's been impossible to diagnose as it's a very difficult…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  13. Fix the CC Foam cartoon coffee bug that prevents you from rendering the video with this effect by simply exiting After Effects.

    I've been stuck in a loop of AfterFX closing on its own because I had a CC Foam in Cartoon Coffee for part of the video. I changed Cartoon Coffee to Default Foam, and the bug went away. This was a wasted day that didn't need to happen.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  14. Fix issues of importing PSD as composition (its not working on the actual version).

    After Effects crashes while import PSD file as composition (installed the latest version of 20aug2021) It shows the popup windows to select the layers but after I click ok it simply crashes on the loading (it stays loading forever).I have a highend pc (ryzen 9 5950x, 64gm ram, rtx 3090 and 2 m2 2tb, so its not a slow hardware issue. On After Effects BETA 22.0.0 (build 56) it is working fine.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  15. After Effects 18.2.1 Crashing on Exit?

    For some reason 18.2.1 and 18.2 have been hanging/lagging on exit. I enabled logging and it almost looks like AE is crashing on quit. Rolling back to 18.1 seems to solve the issue.

    Only plugins are up-to-date Red Giant suite.

    System: CPU: 5950x / GPU: 3090FE / MOBO: Asus Dark Hero / RAM: 64GB Crucial 3600CL16

    Crash report attached

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  16. AE Crashes after sending to media encoder 17.7.0

    After installing the latest update (17.7.0) AE started crashing after sending compositions to render in AME.

    See Screen capture of the crash
    + attached crash report

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  17. Memory Leak, Script Crashes, Weird Saving Issues

    I've been having these 3 issues with AE for literally years. I'm assuming that they are all related but I don't know. I've never found any kind of solution for any of them.

    1. New projects work fine but a couple of days in, any use of any script plugin like Motion3 causes AE to drastically slow down and eventually crash. The project then becomes so unstable that I am forced to create multiple tiny projects and attempt to stitch them all together in the end.

    2. On any of these slightly larger projects, it takes up to 5 minutes to save…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  18. 18.2.1 paint bug

    when attempting to paint on a photoshop layer in the layer window of 18.2.1 to quickly patch an image without opening photoshop, paint tool would not allow me to alter the brush. i just wanted to take it down from 115pt to 20pt, but all attributes were grayed out... I haven't painted in ae in years because the tool is in serious need of update, but i opened up AE 17.7 to see if the error was there too. That version not only worked fine but by launching and using that brush tool, the current version became functional. perhaps this…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  19. RAM Preview not working

    RAM preview frequently stops working. I'm using AE 17.6. When I'm working on a project, the RAM preview will often just stop working. It looks like it's caching, but then does nothing.. Purging memory and disc cache does nothing - only quitting and re-opening AE works. This is getting very frustrating.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  20. Comp window 3D settings don't appear

    Bug report. The 3d camera view popups don't seem to appear sometimes. While it's kind of nice that they're contextual and only appear "when needed", they seem buggy.

    I started a new project and was in 4 camera views in my last project, so it appeared in 4 views. Unfortunately, since there were no 3D layers, I couldn't go back to 1 view without first creating layers and making them 3D.

    Also, when changing the view of my Comp in and out of fullscreen using the Tilde key, the 3D camera controls disappear entirely until I click in certain areas…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base