After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Utilize both NUMA nodes.

    So some CPUs, like the AMD Threadripper 3990x are GREAT for rendering in some software, like Fusion 360, Blender, etc.

    Unfortunately, even with multi-frame, only a single NUMA-node is being utilized.

    Now, that being said, I did a performance test using this benchmark:https://community.adobe.com/t5/after-effects-beta/multi-frame-rendering-is-here-aka-the-multithreading-you-ve-been-asking-for/td-p/11885358

    Without Multi-Frame Rendering: 12m:50s
    With Multi-Frame Rendering: 3m:49s

    That's a DRAMATIC improvement. That's wonderful!

    And yet, we are still not utilizing all 64 cores. While watching the render, I observed only 1 NUMA node (64 threads: 32 cores) being utilized, with roughly half of my CPU's power being left not utilized for the render.

    If there…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  2. Saving file while previewing composition

    I hit accidentally space bar and save. And the estimated time for saving 32 MB file was 47 minutes. You can do nothing. When the save window is active you can't stop playing preview. You can't cancel saving. Is that possible to disable playing preview while saving, just until the save is finished

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  3. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  4. eGPU on Mac makes AE extremely sluggish and laggy

    I added a Radeon 5700XT graphics card in a thunderbolt eGPU enclosure to my iMac Pro. This has been supported in macOS since 10.13 High Sierra. I am now running 11.2.2 Big Sur, with the current version of After Effects. We all know it's too much to ask for AE to utilize this extra GPU power, but can I at least run the program normally? I cannot even get a smooth RAM preview while having the eGPU connected. The checkbox to "Prefer External GPU" in the get info dialog does not change anything. In fact it seems worse when I…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. Ram preview still doesn't work

    Ram preview has been broken since you overhauled it in what 2016? Still doesn't work. Wth?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  6. Fix the lags!

    Whenever I precompose, split layer, or move the playhead one frame forward or backward, it takes three seconds from me pressing the hotkey to the command being carried out... and often precomposing will cause After Effects to crash.This happens regardless of if have hardware acceleration turned on or off. It feels like I am using AE on a computer from 10 years ago, even though my machine is overspecced for After Effects.

    I have been through the Adobe Customer Care pipline (where's my purple heart?) and they have determined that it is not an issue on my end, but an…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  7. Hide Layer controls while scrubbing

    Simple option in preferences to Hide Layer controls while scrubbing.
    Why, because it improves performance by order of magnitude!

    Also, Hide Layer controls while handling layers in timeline, same reason!

    Or rewrite layer controls overlay.

    We all know that AE became browser engine, but please don`t be internet explorer!

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  8. On this current version (17.1.4(build 37)), if you don't clear your cache between renders, it will cook the previous version.

    It's left me in an awkward spot with clients a couple time. Fortunately for me, I just talked to them and they're experiencing the same issue

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  9. Crtl + Alt + M

    Shortcut ctrl+alt+m (add to adobe media encoder queue) has not worked since 2018 in Windows. Nothing happens. I test on several different computers

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  10. Ridiculously slow and laggy interface

    I almost can't work in it. Third party effects are useless and the overall responsiveness of After Effects 202 is terrible. If I didn't keep getting the ridiculous drawing error in the 2019 version, I'd be using it. You HAVE to fix this issue fast. Your application is almost useless right now. People are going to switch. Right now, I totally regret upgrading to CC 2020.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  11. Resolver problema Wacom

    Trava ao usar o com a caneta Wacom... mudo para o mouse USB e funciona, com a caneta não consigo nem mexer direito. Estou usando o sistema macOs Big Sur, e o drive da mesa Wacom está atualizado.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  12. Performance for Automation

    Please fix performance for Automations with .csv datasheets.
    It's horrible that you need to save/load for minutes to use it.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  13. offset effect stops alpha matte working in 32 bit AE2020

    working in 4k, 32 bit, full res, and using the offset effect has caused the alpha matte to stop working in this example AE project. the "shadow" layer dissapears entirely instead of being matted, not always, but most of the time. changing to 16 bit fixes the problem. also opening in 2019 fixes the problem.

    AE example here
    https://www.dropbox.com/s/n1gs6lcy3vxj9gq/32bit%20matte%20error%20with%20offset%20effect.aep?dl=1

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  14. time to add items to the render queue from AE to ME takes too long+ freezes

    Items added to the ME queue from AE or PR take a long time, and often freeze one or all adobe programs using the task.

    ME needs to be sped up and sped up to work better with PR and AE, so using it to render is actually faster than just rendering from AE or PR.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  15. Doesn't start rendering

    I press "Render" and it sits at 0% for too long for me to wait. Cores power up though, all of them, to about 50%, but nothing seems to happen.

    After Effects Beta build 23
    iMac Pro
    Big Sur 11.2.2

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  16. Use RAM more efficiently

    Especially since AE 17.5, it has become even more RAM greedy. It doesn't matter if I have 32GB, 64GB or 128GB, once I start a multithreaded render, the memory will always be the bottleneck. There surely must be a way to use memory more efficiently, I can't understand what AE needs all this memory for. Just doesn't make sense to me.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  17. Each Character Animator import into AE splits available RAM memory

    I work on e-learning projects animated in Ae with some scenes using scenes prepared in Character Animator.
    Last project had 14 scenes from Ch imported via Dynamic Link into Ae. The more imports, the shorter preview time was in timeline. With 64 GB of RAM, 56 GB reserved for CC apps, and 6 GB for system and only Ae in memory I had only 12 seconds of preview and RAM for preview finished! On machine with CPU Intel i9 10850K, 64 GB RAM (DDR4 3200), GPU: nVidia RTX 2060 6 GB DDR6, 3 SSD: 2 x very fast M2 PCIE…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  18. project open got a lot slower in AE 2020 17.7.0

    After the update projects open a lot slower than previous versions on the same system.

    macOS Catalina 10.15.7

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  19. Autosave will not turn off & triggers a crash each time it initiates

    After Effects is crashing each time it autosaves. I've reset my preferences, deleted their old files, and turned off all autosave functions multiple times. It continues to override this and launch an autosave anyway, even when the function appears to be turned off, which then causes AE to crash completely. Happening on all projects.

    Here is the message I'm given (minus the first sentence telling me the path to which it has saved my project):

    Last log message was: <123145619922944> <BEEp_CheckoutItemFrameRange> <5> BEEp_CheckoutItemFrameRange elapse time = 5.5982 seconds.
    .

    Generating crash log, which may take a few minutes.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  20. Bug Report: Text and fonts still cripple AE performance, even on high end machines.

    Simple text animations, or even just simple animations with text layers turned on in the scene. I have seen twice in the last 2 days, on different projects, with different fonts. Some text layers just cripple AE viewport performance. From smooth 60fps playback to .5 fps, and not even able to smoothly drag objects around viewport. I have read many posts like this online, please optimize this dino app. Like Winston Wolf says, "Pretty please... with sugar on top.."

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base