After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. BUG: AE 22.5.0 (Build 53) Export Error.

    Camera Lens Blur without a Blur Map layer set up crashes on rendering.

    Reports an Error(Code 19969) quits rendering, viewports dark, have to restart.

    AMD Theadripper, 64GB Ram, 2xRTX2080ti, SSD's etc

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Create alpha channel (mask) from shapes

    It would be cool if masks could be created from a shape layer.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Thank you for filing this request.


    Could you elaborate on how you would like to create a mask or alpha channel from shape layers?


    Using a shape as a mask or an alpha channel is already possible in AE. There are several possible methods, and I'll outline some of them below, but please let us know what you'd like to see that is different.


    Method 1: Copy a Beizer shape path to a mask path

    1. This only works with Bezier shape paths. If you create a parametric shape path (rectangle, ellipse, star, etc.), right click on the path (e.g. Rectangle Path 1) and choose Convert to Bezier Path.
    2. Twirl open the shape's Path group (e.g. Path 1) and select the Path property.
    3. Edit > Copy or Cmd/CTRL + C
    4. Select the layer you want to add a new mask to, and draw a new mask on it. It doesn't matter…
  3. Please make Track Matte (and other basic tools) 32bpc

    When blending between two layers using a track matte (luma) and exporting to full float EXR - from a 32bpc AE setup - then as soon as the part of the shot where the track matte starts to get used, the file sizes drop heavily - indicating loss of information (I'm creating a loop, so it's not like I'm fading from tons of detail to black - I'm fading from tons of detail to tons of detail). All of my layers inside AE have effects on them that should be good for 32bpc (no warning flags in the effects).

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. [BUG] Can't open subcomp

    AE 18.0.1 won't let me enter a subcomp upon doubleclicking it's layer. The error message states "Can't open layers with collapsed transformation. Oh boy 😞

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Render Error: -1609629695 due to Levels Effects on one of the layers.

    I could not render my work in After Effects or in Media Encoder. I get the error message:

    Export Error
    Error compiling movie.

    Render Error

    Render returned error.

    Writing with exporter: H.264
    Writing file type: H264
    Around timecode: 00:00:00:08
    Rendering at offset: 0,000 seconds
    Component: H.264 of type Exporter
    Selector: 9
    Error code: -1609629695

    So I started to disable layer by layer one by one and render again until I narrowed down the problem - This was due to layer that had "Levels" effect. Once I turned off the Effect everything worked fine. Your welcome.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Hi, just seems the layer sequencer isn't working

    See attached photoshop file, I took screenshots and pasted them in with a walkthrough of what I''m doing on.

    I've been a tester on a few softwares so just thought give a brief run down. Wasn't end of world, just had to do a lot of layer duplication.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  4 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. What the h.. The rotoscoop tool is HUGLY buggy

    The rotoschoping tool is aweful
    It disapears, the freezing doesn't actually freeze the selection and the mask remaps
    Aweful, a waste of time. I will look for an other tool I can't believe I pay for this

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. [BUG] Roto-brush freezing errors

    1. Paint Roto-brush to good result
    2. Freeze
    3. Freezing produces different and wrong result
    4. :(
    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Issue: "After Effects has encountered a failure related to GPU-enabled effects on this frame" message

    Issue:

    "After Effects has encountered a failure related to GPU-enabled effects on this frame" message

    Message states "After Effects has encountered a failure related to GPU-enabled effects on this frame. This is likely because your GPU is out of memory."

    Suggestion:

    Decreasing your rendering resolution, close application that may be using GPU resources, or set this project to render effects using "Mercury Software Only" in: File -> Project Settings -> Video Rendering and Effects

    In my case, I opened AE only while working on a project. I couldn't render the clip with mask transition.

    My GPU is GTX1060. "Video Rendering…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Automatic Instanced effects

    Example : I copy a blur, or a curve, i paste it on another layer, at this moment, i would want to have a choice betwen "copy" or "intanced" copy.
    Instanced is a automatic link betxen the affects, and of course any modification on my curve will bereported to all instanced copy of it.(like in 3ds max , for example).
    Of cource, a right clic on it can un link it from the others.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Thank you for submitting this suggestion.

    Similar functionality exists in After Effects. The Edit > Copy with Property Links (and Copy with Relative Property Links) command will do as you describe.

    The Copy with Property Links commands link the pasted effect using expressions. You can use the commands on effects, or just single properties (including transform properties), or even a whole layer.

    If there is additional functionality you still desire in After Effects, please elaborate.

  11. Bug Report: AE 2019 Write-On Effect not working.

    I am unable to get the write-on effect to work with any stability. I noticed this in a 2018 file I was editing. It seems I can set up the keyframes, but then after scrubbing the timeline or working on other write-on reveals, it fails. See attached file.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Thank you for filing this bug report.

    Update 14 Nov 2018 – I received the files, thank you.

    After playing with the project for a little bit, I see how the Write-on effect is not behaving correctly. But I’m not able to deduce what the cause of the problem is. I’m not able to reproduce the problem from scratch, and if I make modifications to your project, it starts to render correctly.

    My best guess is that the keyframe data of the Write-on effect in your project became corrupted somehow. It’s relatively easy to fix, although a bit tedious:

    1. On each keyframe, modify the property value. (I made small adjustments, like rounding fractional X or Y values up to the nearest integer, or increasing the brush size by 1. Any change to the keyframe’s value should work here.)
    2. Edit > Purge > All Memory & Disk Cache.

    If…

  12. BUG: Lumetri Colour

    When I put Lumetri Colour directly on footage it starts to glitch and with every playback in a different way. The problem is that when exporting it also has the glitches and with every export of the same video and the same lumetri settings the glitches are different.

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Thank you for filing this bug report.

    We need more information to understand what is happening. Can you please share:
    - Screenshots of the problem.
    - A project file and/or rendered result that demonstrates the issue.
    - Information about the computer you are using, including OS and video card details.

    Also, is GPU acceleration enabled? Open Project Settings > Video Rendering and Effects. If this is set to Mercury GPU Acceleration, try setting it to Mercury Software Only. Or vice versa. After making the change, make sure to purge cached frames, via Edit > Purge > All Memory & Disk Cache.

  13. Bug - applying Lumetri after Primatte Key causes a slight unexpected scale shift.

    The layer is masked.

    AE CC 2019
    MacBook Pro 15" 2016
    2.9 GHz Intel Core i7
    16 GB 2133 MHz LPDDR3
    Radeon Pro 460 4096 MB
    Intel HD Graphics 530 1536 MB

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Thank you for filing this bug report.

    It would be helpful if we could see screenshots of the problem (with and without the shift) and/or a project that demonstrates the issue.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  • Don't see your idea?

Feedback and Knowledge Base