After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Interface slowdown when using multiple expressions

    Following up on Tim's request to post individual feature requests from Sander's site here....

    http://www.sandervandijk.tv/after-effects-features/expressions#faster-interface

    Expressions and coding are some of the most powerful tools AE animators have at their disposal, so the fact that using them has such a negative impact on performance is truly disappointing and counter-intuitive.

    Sander:
    "The interface slows down drastically when applying lots of Expressions, Code allows us to easily create complex animations and connect values. This is the highest on my list of improvements that After Effects can make."

    95 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  2. Master Properties bug (String Memory Leak)

    If I use Master Properties to edit text inside a pre-comp, I get a "string memory leak" error when I quit After Effects. If I then clear the custom text by clicking the "Pull from Master Comp" icon, and then save and re-open After Effects, I no longer get the error (at least until I edit the text again through Master Properties).

    As an example, I have attached two files. The file with text edited through Master Properties gives me the error upon quitting AE. The other file is identical, except that the text has not been edited through Master…

    19 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  3. Restore the full support of the Animation Codec

    In the 15.1 release After Effects removed the support for the Animation Codec with delta frames. It continues to support the Animation Codec without delta frames. This is an option within the codec window to set keyframes and it is checked by default. I would ask that both the non-keyframe and the keyframe option in the Animation codec be restored. Many of us 3D animators use the codec in it's default mode (delta enabled) and it would be very time consuming to transcode all out work. Thanks

    18 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  Animation  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this request.

    We have logged an internal feature request for adding support to the Animation codec for both encoding and decoding delta frames (a.k.a, the “Key frame every X frames” option). It is currently under review for future updates to the Adobe DVA products. At this time I can not share a timeline for when this might happen.

  4. AE CC 2019 Speed on Mac

    Just updated to After Effects CC 2019 V16.0.0. MacOS High Sierra, latest iMac with enough of RAM and supported GPU. Preferences resetted. CC 2018 works like charm without speed problems.
    Anybody else experiencing a total slowdown of the UI with the new AE version?
    Everything feels like frozen and AE is practically useless.
    Sorry, cannot work with this. Returning back to CC 2018.

    If this is not a general fault, any bright ideas what to do? Please...

    15 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. Invalid JSON Object Error

    Error/Bug Report: When importing a tab delimited file, any quotation marks in data values results in this After Effects alert:

    After Effects warning: Problem encountered with file "FILENAME.tsv". Data File: Parsing error:"dataOutline[0]::children[0]", Invalid JSON Object.

    When I remove the quotation marks from the text/tsv file, After Effects handles it properly.

    Any workarounds for this so I can use data with text values including quotations? Thanks!

    10 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  6. make median and dust and scratches faster in 16bpc

    Median is a very conveniant effect when it comes to removal or retouching works and super fast when your project is set to 8bpc but when you turn it to 16bpc or more it takes forever to render. I would be really thankful if you could do some dev blackmagic to fix that

    9 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  7. HEVC GPU DECODING ON WINDOWS

    Please make HEVC GPU decoding available on windows 10 machines

    8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Under Review  ·  0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  8. 8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  Flag idea as inappropriate…  ·  Admin →
  9. Please implement project cloak!

    Hey guys! Almost a year ago you had Project Cloak in development:
    https://www.engadget.com/2017/10/19/adobe-max-cloak-smart-erase-sneak

    But we haven't heard anything else from this. Will we get it?.
    Content aware removal is really handy.

    8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  10. Exporting pro res 4444 + alpha bug

    Issue when exporting pro res 4444 with alpha directly from AE. When this file is taken into premiere, there are weird purple artefacts, this can be removed by changing the premultiply settings, but this looses some alpha and introduces black fringing. When the same comp is exported via media encoder, using the same settings, no such issue exists.

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for reporting this bug. Our team is investigating the cause of this problem.

    This problem occurs when rendering from the After Effects render queue using premultiplied alpha. If you change the alpha mode to straight (in the Output Module Settings dialog, set the Color option to Straight (Unmatted)), the problem does not occur.

  11. Mesh warp bad parameter bug

    Exporting from premiere I got an "Unable to create frame" error on an AE linked comp (error code -160962695). The comp was an animation of a PNG graphic with some Mesh warp "glitch" effects.

    Tried to render from AE, initially got an error about the memory requirements of the frame while in 32bpc color (error 12804) but after switching to 8bpc I started to get a different error, after that point it was the same error in either 32 or 8pbc.

    The final error was a Bad parameter error (error 516) and I discovered that it was the animated Mesh…

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for sharing the project file. I was able to reproduce the problem, both with your project and by replicating the conditions of the bug from scratch.

    This is a bug which has existed in the Mesh Warp effect for a long time. At this time we do not plan to fix it, because the conditions of the bug are uncommon and easy to work around. But we will leave this bug in “Under Review” state to allow people to continue to vote on it. If this problem is more common that we assume, we can raise the priority and fix this in a future update.

    The problem is a combination of a high-resolution layer and moving the mesh warp points a great distance outside of the bounds of the layer.

    In this case, your layer is greater than 8000×5000 pixels, though scaled down to 10%, and one of…

  12. Master Property Undo and Copy Expression Bug

    If you replace a comp that has a master property with an expression or keys on it, it gets cleared out. That makes sense. But if you undo, expressions and keys on a mastery property don't return.

    Also, the UI lets you "Copy Expression Only" for Master Properties but you can't paste onto duplicates, even of the same precomp with the exact same Master Properties.

    Aside from a few minor issues, I love the world Master Properties opens up for us.

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  13. Bug Report: Resizing the composition causes the 3D layer to shift.

    If you resize the composition using the "Crop Comp to Region of Interest" feature in version 17.5.1, there will be a difference in the display between 2D and 3D layers with the same X and Y numbers.
    It didn't happen in versions prior to 17.1.4.

    The following reproduction procedure
    1, Creating a composition
    2, Create a new layer
    3, Resize the composition using "Crop Comp to Region of Interest"
    4, Check the 3D layer.

    Other than "Crop Comp to Region of Interest", the same phenomenon occurs when resizing with "Composition Settings / Advanced / Anchor" selected other than the center. …

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  14. Pasting from Premiere bug - Duration change and no "Paste At Current Time"

    Being able to paste from Premiere into After Effects is awesome, but there is a bug when pasting footage/audio from the Premiere timeline into an already existing composition in After Effects. The After Effects composition will automatically change duration without your input and it won't respect "Paste At Current Time". Do this to re-create the problem.


    • Create a new After Effects comp, either from Premiere's "Replace With After Effects Composition" feature, or an independent project. Make it something like 10 seconds.

    • Copy any footage or audio clip from a Premiere timeline into an After Effects composition. But make sure the…
    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  15. Characters like á and é and ö can't be text linked with .JSON data driven compositions

    Please fix this!

    Characters like á and é and ö can't be text linked with .JSON data driven compositions. I need this asap!

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Flag idea as inappropriate…  ·  Admin →
  16. BUG: JSON footage files do not auto reload when written by ExtendScript

    If a valid json footage asset is imported into a project and used for Expression data in a layer, and it is subsequently overwritten by an ExtendScript process, After Effects CC 2019 will not auto-refresh the JSON footage item in the project nor in any layer referencing the JSON footage layer. Choosing "Reload Footage" on the json footage item does not seem to do work either — this this did work in CC 2018. However, if focus is removed from AE, and a different process opens and overwrites the source of a JSON footage item, then focus is returned to AE,…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thanks for posting this bug, Arie.

    After an extensive back and forth with our developers, we’ve concluded that yes, there’s a bug here. We’ll need to investigate further what’s going on, but the problem appears to connected to the fact that it’s a script, being run by After Effects, that is updating the JSON file.

    There was some confusion as to whether we’d expect this to work automatically, without manually calling the Reload Footage command (either in the script or via UI), but that the behavior changed between releases of After Effects tells us that something in the code changed and we should understand why.

  17. Ellipse Path Closing with Trim Paths

    There seems to be a bug when working with parametric ellipse paths in tandem with trim paths.

    It only seems to occur when the Start or End properties in the trim path are set to 50%, while the other is set to 0%. I've attached a couple videos for reference.

    When the ellipse path position is adjusted the ellipse path will occasionally close itself, resulting in an unwanted half-circle. The half circle is a result of the Start property set to 0%, and the End property set to 50%. However, when the values are swapped (Start: 50%, End: 0%) it…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Under Review  ·  1 comment  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  18. Opacity not working in Master Properties

    I have a pre-comp that has 2 layers in it. One graphic, the other text. I use OPACITY from both layers as a means to control in the MAIN layer as a Master Property. However, when I attempt to change the OPACITY from the MASTER PROPERTY it does not work, respectively

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  19. [Bug Report] Adding sourceRectAtTime() Expression Crashes AE

    When attempting to add a sourceRectAtTime() expression to a Mask Path property that references a text layer, After Effects will immediately crash upon evaluation.

    Reproduction steps:
    1. Create a new project
    2. Create a new composition (tested with HDTV 1080 29.97 preset for repro purposes)
    3. Add a text layer
    4. Create a comp-size solid
    5. Add a comp-size mask to the solid by double clicking the mask button
    6. On the "Mask Path" property of the mask created in step 5, add the expression: `thisComp.layer(<nameoftext_layer>).sourceRectAtTime()

    After clicking out of the expression editor and allowing AE to evaluate,…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  20. Bug Report - Preview Resolution Changes Raw Images Gamma in "Linear Working Space"

    Since a couple of updates I've had this weirdest glitch.

    On imported RAW images, when the preview resolution is set to anything less than "Full", the layer's gamma suddenly gets waaaaay off.
    This only happens if "Linearize Working Space" is checked in Project Settings.
    I've also reproduced this bug with .dng instead of .RAF, so the RAW image format does not seem to matter.

    Currently using AE 18.1 on windows 10, Camera Raw is up to date and this glitch happens whether GPU acceleration is on or off.
    Unfortunately I can't seem to find on which version thig bug appeared,…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1
  • Don't see your idea?

Feedback and Knowledge Base