After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Fix Mojave compatabily

    Things start to lock up when I go to render.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  2. Create Editable Text Bug

    I've discovered and confirmed a bug with the help of your support team.

    In AE 2019.1, (I tested on Win10, another user was on MacOS with same result) when you right click on a PSD layer that was text and hit convert to editable text, it was crashing for me about half the time, with no indication why since it was working on the same fonts and same projects sometimes.

    When i tested one of the crashing layers INSTEAD of right clicking and going to the MENU Layer>Reveal>Create Editable text, it worked flawlessly.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    In a simple test, I can not reproduce this problem.

    Can you provide us with a PSD and an After Effects project that causes the crash? This will help us investigate.

    Please post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  3. After Effects 2019 won't batch replace retargeted jpgs!!!

    This has been an issue since AE2017 PLEASE FIX THIS! GAWD!@##

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Can you please elaborate on the problem? What specific steps are you taking, and what happens, or does not happen?

    A screen capture video of the problem may be helpful, as would a project file that demonstrates the problem.

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  4. AE 2019 Crashing entire computer on startup

    I don't mean I have to force the software closed. I mean the mouse cursor stops moving and the computer becomes completely unresponsive. This is the only software that manages to crash so hard I have to resort to holding the power button and forcing a shut down. Which could very possibly corrupt anything else that happens to be open at the time.

    I'm on Windows 8.1 with a laptop that is running on Intel graphics (no video card). It often alerts me that the graphics display driver crashed on launch, but recovered. Once in a while the entire computer…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    We really appreciate your post, however, User Voice is primarily for feature requests and bug reports. It appears your issue is more of a troubleshooting problem which could be solved more easily by our support team. You can open a case with them via call or chat at this link: https://helpx.adobe.com/contact.html

    Please note that Windows 8.1 is not supported for the October 2018 update to After Effects CC (version 16.0). The minimum OS requirement for After Effects 16.0 is Windows 10 version 1703, or macOS 10.12, or later. Full system requirements can be found here:
    https://helpx.adobe.com/after-effects/system-requirements.html

  5. Motion Blur Bug: Motion Blur is randomly on when switches are off

    In a large animation project, I have all motion blur switches turned off for all individual layers, sub comps, and master switches within them. When ram previewing, it plays just fine, but when I go to render it puts motion blur on random layers, not all. I have triple checked all layers and effects, adjustment layers, there is nothing that has motion blur turned on, built in, or is forcing it. The only way around it has been to turn off motion blur for all layers in the render settings above the output module.

    This is in CC 2019, on…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this report.

    When exporting via the Render Queue, there is an option in the Render Settings dialog which determines whether or not motion blur will be rendered. By default, the Motion Blur control defaults to On For Checked Layers, which will render motion blur for any layer on which the layer’s motion blur switch is enabled, regardless of the state of the comp’s “master” motion blur switch.

    Are you changing this setting in the Render Settings? Does its behavior otherwise align with your experience of which layers do or don’t render motion blur when exported via the Render Queue?

  6. BUG REPORT - JSON file with Greek Character do not work.

    I’m creating a data driven Graphics in After Effects. I have created a JSON file with excel and I have tested the file if the syntax is OK, and everything is fine. I have all my DATA in the file. If I save the file in ASCI format, the After Effects works fine for the English text, but the Greek Text do not show up. If I save the file in UTF-8 format, I get an error when I import the file in After Affects

    “ After Effects warning: Problem encountered with file “D:Win 10...\Data.json”. Data File: Parsing error:”dataOutline[0]”, Invalid…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Animation  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Which version of After Effects are you using?

    Can you provide us with a sample JSON file that causes this error?

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  7. Render Items all greyed out

    Since the install op 2019, both 2018 and 2019 no longer hilight items to be rendered in the Queue. All is dull and grey...

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  8. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    We need more information to be able to investigate this problem. Can you please provide us with a project file that causes this error, as well as a System Info report? (Apple menu > About This Mac > System Report, then File > Save)

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  9. Export Motion Graphics Template to CC Library without having to have the Libraries panel open

    Reporting a bug. This bug has also been verified by support.

    When you try to export a Motion Graphics Template from the Essential Graphics panel to your CC Library - you have to have your Libraries panel open for it to export properly. If you don't have the Libraries panel open, nothing is exported.

    Solution/Fix: You should not have to have the Libraries panel open to be able to export Motion Graphics Templates to your CC Library.

    CRM:00061001672474
    Case Number: ADB-4379439-Y1M9
    Issue: CC Storage and Sync

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    We reviewed this issue with our support and development teams, but are not able to reproduce this issue After Effects 16.0.

    If you are still able to reproduce this, can you please record a screen capture video of the problem in action and send it to us?

    Post a link to your files here, or if you prefer not to post publicly you can send it to aebugs@adobe.com. (If you send to that address: A) Do not send .zip files, they will be blocked; renaming to .thisisazipfile is OK. B) Post a comment here when you have sent the email. I need to manually check that inbox.)

  10. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    We need more information in order to investigate this problem.

    • What OS and version are you using? i.e., Windows 10 or macOS 10.14
    • Are you able to reproduce this problem, or does it only happen once?
    • Do you get any error messages associated with this crash? If so, what do they say?
    • Do you get the Adobe Crash Reporter dialog? If not, choose Help > Adobe Crash Reporter from inside After Effects. We like receiving crash reports, and prefer that you use the “Always show this dialog” option so that you can fill in the additional information after the crash. When the Adobe Crash Report dialog appears, please always provide notes about what you did before the crash occurred. If you have filed the bug, please include a the bug number in the notes. We also appreciate if you fill in your email…
  11. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Please provide more detail about the problem.
    - What OS and version are you using? ex., Windows 10 or macOS 10.14
    - What exact steps do you take before the problem occurs?
    - Do you get an error dialog or crash report dialog?
    - If you get a crash report dialog, have you submitted the report? If you’re not seeing the crash report dialog, choose Help > Adobe Crash Reporter in After Effects, and choose Always Show. When the crash report dialog appears, we appreciate if you fill in your email address and check the box that allows us to contact you about the crash.
    - What directories are your media and disk cache set to?
    - Have you tried resetting the preferences for After Effects? Hold Cmd/Ctrl + Option/Alt + Shift while After Effects starts.

  12. pre compose

    When pre-composing by going right click > pre-compose, AE crashes.

    AE 16.0.0
    macOS High Sierra 10.13.6

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thanks for filing this bug report.

    We need information about this problem:
    - Does the problem only happen in a specific project, or does it happen in all projects? Does it happen in a new project with a simple comp that only contains a solid or shape layer?
    - If the problem doesn’t happen in a new project, or happens in a specific project, what is in the comp that you are pre-composing? What types of layers or footage are being used? Effects? Expressions? Does the composition have properties in the Essential Graphics panel?
    - Do you choose to Leave All Attributes or Move All Attributes? Does that affect the problem?
    - Is the problem persistent after resetting the preferences for After Effects? Hold Command + Option + Shift while starting After Effects.

  13. AE 2019 Clips with Trillions+ of colors don't properly display alpha.

    Clips with Trillions+ colors will not show alpha even if the file has an alpha.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    We need more detail about the problem you are describing.

    What format and codec are being used by these clips?

    Where is the alpha not visible? Is it in After Effects, or in a different application? If in After Effects, what is the color depth of the project set to? (8-, 16-, or 32-bpc?)

    I suspect that you may be encountering this problem:
    https://adobe-video.uservoice.com/forums/911311-after-effects/suggestions/35769118-bug-report-after-effects-cc-2019-can-t-read-alpha

    Please confirm if that is the case.

  14. Detect incompatible plug-ins that hang loading After Effects and offer to disable them

    Since wasting my time with After Effects 2019 hanging at start-up and recently figuring out that one of the plug-ins must be incompatible, as per the following issue, I wish that After Effects would be smarter and run a watchdog when it enumerates plug-in and offer to disable the loading of plug-ins that appear to have hung.

    https://adobe-video.uservoice.com/forums/911311-after-effects/suggestions/35855626-critical-cannot-launch-after-effects-since-update

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Can you give us more detail on specifically which plug-ins were causing After Effects to hang during launch?

    After Effects already does this when it can, but detecting the cause of crashes is not as simple as it seems as first. The cause of the crash may not always be clear, and may not necessarily be the plug-in itself but After Effects crashing due to a bad (or valid) request.

    For example (theoretically; this is a simplified example, not a real-world case), using the After Effects API, a plug-in may request After Effects to allocate some memory that is more than is available on the system. The bug is clearly the bad request from the plug-in, but if After Effects doesn’t trap that request and reject it, After Effects could end up in a bad state and crashing.

    That’s why we need to know what specific plug-in is causing…

  15. Fix GPU errors with curves & mask composites.

    Since AE 2019 using curves along with composite masks occasionally (and quite often) causes GPU errors which brings up a pop telling me to use software rendering. I'm using a 1080Ti so have plenty of spare memory. I believe curves has just moved to GPU since the 2019 update so it make sense that this bug has only just surfaced.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Is this on Windows or Mac? Which version of the OS?

    Can you provide us with specific steps that cause the crash? ex., Apply Curves with X settings and add X number of masks. Or whatever steps lead to the crash.

    Or, could you send us a project file that demonstrates the problem? You can post a link here, or if you prefer you can send it to aebugs@adobe.com. Please post back if you send an email, as we need to check that inbox manually.

    A crash log would also be helpful. Do you get the Adobe Crash Reporter dialog? If not, please choose Help > Adobe Crash Reporter, and set it to always show the dialog. When you get the crash, make sure to add a comment. We also like it (but it is not required) when you include your email…

  16. NEW EXPRESSIONS VISUALIZATION BUG

    The new expressions visualization should show you the whole expression when you hit it once in the timeline.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Can you please clarify the problem? Screenshots would be helpful.

    In the October 2018 release of After Effects CC (version 16.0), clicking into the expression field will expand the height of the expression field to fit as much of the expression as possible, but will not expand past the bottom of the Timeline panel. (In other words, it will show the whole expression if the expression is short, but it if it’s longer than can be viewed in the Timeline panel, the expression field will only be expanded to the bottom of the Timeline.)

    If this is not functioning for you, please provide more detail. Or if you desire different behavior than described above, please tell us what you’d like to see changed.

  17. please add GPU and CPU both work at a time for preview render specially and final render time . not after preview Render create work GPu.

    please add GPU and CPU both work at a time for preview render specially and final render time . not after preview Render create work GPu.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this request.

    Can you please elaborate on what behavior you’d like to see changed in After Effects?

    After Effects uses a mix of CPU and GPU rendering, when the Project is set to use Mercury GPU acceleration (Project Settings > Video Rendering & Effects). Use of the GPU is dependent on whether or not your composition uses GPU-accelerated features of After Effects, such as GPU-accelerated effects, layer motion blur, or R3D raw debayering. Features that are not GPU-accelerated are rendered using the CPU, for both rendering previews and for export renders.

    With that understanding, what would you like to see changed in After Effects?

  18. AECC2018 on Mac has a problem about mp4& MOV

    AECC2018 on Mac has a problem about the 60fps mp4 & MOV.
    When I imported the 4 60fps mp4 files to new 30fps composition, AE preview screen caused the missing frame (or replace different frame) and insert the green or red screen that I don't add.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug report.

    Can you please post a sample MP4 or MOV that causes this problem? We will need a sample in order to investigate.

    What camera shot this footage? Does this footage use variable frame rate (VFR)?

    You can determine if an MP4 file uses VFR by doing the following:
    1. Select the footage in the Project panel.
    2. In the File menu, choose Interpret Footage > Main.
    3. Click the More Options button at the bottom of the Interpret Footage dialog.

    In this dialog, if the Variable Frame Rate Mode can be changed, then your footage uses VFR. Try changing the VFR mode to Smooth Video Motion, which will preserve the frame rate of the video, but potentially lose audio sync.

    Either way, please let us know if your footage uses VFR.

  19. Big Bug: Expressions on Shape Layer FX (with demo video)

    Here's a two-minute demo of the bug in question: https://www.youtube.com/watch?v=Q_c6XOWOv-w

    ...and here's the same thing in text form:

          Steps:

          1) New Comp ([1000,1000])
          2) New Shape Layer
          3) Effects -> Expression Controls -> Point Control ([100,100])
          4) Change Comp Size ([880, 1230])

          Result:

          The value of the Point Control CHANGES ITSELF from [100,100] to [88, 123].

    As I mention in the video, I'm sure this has something to do with the back-end of how Shape Layers deal with the canvas — and, obviously, Shape Layers aren't meant to have renderable effects applied to them. That said, I can't think of…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for reporting this. At the moment, it’s unclear what you would like to have changed.

    The cause of what you are observing is that shape layers always inherit the dimensions of the composition that contains them. Thus, by changing the dimensions of the composition, you are also changing the dimensions of the shape layer.

    You will get the same result if you apply a Point Control effect to a solid layer, and then change the dimensions of the solid layer. The coordinate values of the Point Control will scale to compensate.

    The result in both cases is that coordinate values are scaled along with the layer so that the any rendered result is proportional to the original. If this wasn’t done, effects wouldn’t appear to scale with the rest of the layer and the result would look “wrong”.

    I can see that may not be the result you…

  20. 14.2.2

    Need to work in 14.2.2 to be compatible with a clients back end. On the CC installer it claims to be 14.2.2 but when opened & running, it states it’s 14.2.1.34. Which is correct?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →

    After Effects 14.2.1.34 was the last release of the 14.x versions of After Effects CC. (That is, it was the last release of After Effects to be branded as “CC 2017”.)

    The version number “14.2.2” was an Adobe-internal label to differentiate a change in the installer package, and was not advertised as a new release.

    > Need to work in 14.2.2 to be compatible with a clients back end.

    Please clarify this. Since 14.2.1 was the last release, this doesn’t make sense to me.

  • Don't see your idea?

Feedback and Knowledge Base