After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. I can't double click and edit key frames anymore.

    I can't double click and edit key frames anymore.

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Resolved  ·  4 comments  ·  Animation  ·  Flag idea as inappropriate…  ·  Admin →
  2. AE always crashes when this process is performed // この工程を行うと必ずAEがクラッシュしてしまう

    AE always crashes if you do the following procedure.


    1. Launch AE

    2. Create New Comp

    3. Creat New Solid

    4. Duplicate the Comp

    5. Open the duplicated composition

    6. Lock the cloned composition viewer

    7. Open the first composition you created in the timeline tab

    8. Center the anchor point with the shortcut

    9. crash.....

    以下の手順を行うと必ずAEがクラッシュします。
    1. AE を立ち上げる
    2. 新規コンポジションを作成
    3. 新規平面を作成
    4. コンポジションを複製
    5. 複製したコンポジションを開く
    6. 複製したコンポジションのビューアをロックする
    7. 最初に作ったコンポジションをタイムラインのタブで開く
    8. ショートカットでアンカーポイントを中央に持ってくる
    9. クラッシュする

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  3. Preview playback is broken. (bug)

    Preview playback is persistently choppy. Audio stutters as does frame rate during playback. This issue is SOLVED by hiding the timeline, which is not a practical solution every time I need to do a RAM preview.

    I'm in CC2018 15.0.1 as suggested by Adobe support on the phone - it behaves exactly the same in 15.1.1.

    CC2014 works absolutely fine in comparison.

    I’ve reset VRAM and PRAM und also upgraded my OS. Nothing fixes it so far. I’ve tried enabling/disabling Mercury Transmit in prefs to no avail.

    I'm on a Mac Pro Tower running High Sierra, 12 core 3.46ghz process…

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  4. [BUG] Master Properties can't be changed with expression

    I put this simple expression on a master property that cycles through some items. It shows 1, 2, 3, 1, 2, 3, etc. on the control, but it only shows the item #1.

    timeToFrames(time/50) % 3 + 1;

    This wasn't working on another master property, but it started to at some point on it's own. I've tried purging, recreating the property. About the only thing I haven't tried so far but sometimes works is recreating it all in a new comp.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  5. Extractor BUG, 2019

    with the new update of AE 2019, whenever we are using extractor on exr passes, extractor is not going away, so at the end of the project we end up having like 55 extractor menus open on the second monitor, which is a bit funny. please fix, thanks.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  6. BUG: Essential Graphics Stalls Timeline Scrubbing

    I have a fairly large project that uses the Essential Graphics panel to control about 20 properties across 10-12 comps. When the EG panel is closed, everything works perfectly. But as soon as I open the EG panel and attempt to scrub in the Timeline AE freezes for about 25-30 seconds.

    One workaround I've discovered is that if I group the properties into folders, as long as the folder is collapsed I can scrub freely. But as soon as I expand the group of properties the problem returns.

    Coworkers with smaller projects and fewer EG properties are experiencing the same…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  7. AE 17.0 RAM Preview unresponsive / stuck

    RAM Preview speed has improved but the entire program becomes unresponsive to clicks, spacebar, Num0, ESC, etc. Playback continues on loop and the only way I've found to regain control is to minimize/maximize AE.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    13 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  8. Comps that are rendered/green in timeline are not playing back in real time

    I always thought a ram preview meant the preview would play back from ram in real time. this is often not the case. Most the time, especially comps with audio, don't play back in real time even if they are committed to ram or disk cache (Which means you either get the warped record slow down, or if that's muted in settings, nothing at all)...why is this, on every machine I've worked on...

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  9. When throwing errors in expressions show the Error message on Windows properly

    Throwing Errors is very helpful when debugging expressions (see https://twitter.com/mamoworld/status/1101168951185289217 )
    However, currently on Windows the thrown error message is not shown in the status bar. On Mac this already works nicely.

    The reason seems to be some subtle differences of how exactly the banner messages are shown on Mac/Win (see https://twitter.com/1ResCreation/status/1117325915007016962)

    Please make Win behave the same as Mac for this and show the message directly in the status bar.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  10. Crash When Editing Text CC2019

    I had written too much text and it went outside of the bounding box, so to fix it I was going to change the font size. So I hit Shift + Up and I got an immediate crash.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  11. There is an issue with Key Cleaner.

    After Effects crashes unexpectedly after applying key cleaner weather you use Keylight or color range without a message or warning.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  12. bug report - playback issue

    Having an issue with the new 2020 update that was not happening with 2019. First off, a lot of things are quite laggy when clicked so take a long time to react. Sometimes it's a second or two, sometimes it's so long I start thinking AE is locked up. I can start playback on a section and then it won't stop (by hitting 0, clicking the playhead, hitting Space). Sometimes it takes a few seconds to respond and sometimes up to a minute. Several times now I actually had to force close AE just to make it stop playback.

    I…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  13. BUG REPORT: preview playback will not stop

    When playing preview by pressing the spacebar or using the preview panel it does not stop by pressing the spacebar again and the interface is unresponsive. (CC 20 - v17.0)

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  14. Bug report: Exposure effect > Gamma Correction control is broken

    The Exposure effect in the latest version gives a different result with the same exposure values as before. For example, in my project I have the Exposure effect with the Exposure value set to 3. If I open the project in the latest AE version it looks so much brighter. To get the same look in CC 2014, I have to set the Exposure value to 15 instead of 3.

    I found that the Gamma Correction slider in the Exposure effect behave inconsistently with the previous versions of AE. If the Exposure value is set to 0 and you drag…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  15. 16.0.1 preview not playing back in real time

    Experienced user.
    iMac Pro (2017)
    Processor 3.2 GHz Intel Xeon W
    Memory 64 GB 2666 MHz DDR4
    Graphics Radeon Pro Vega 64 16368 MB

    After Effects had been working perfectly fine up until today. I cannot get (ram) preview to playback in real-time for the life of me, which is problematic when you're animating to voiceover. "Cache before playback" is checked. "If caching, played cached frames" is unchecked.

    I'm assuming it's just a bug that needs fixed.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  16. AE 2019 Preview Renders Unusably Slow

    For some reason, comps in After Effects are spontaneously vacillating between previewing smoothly with almost no stutters, and suddenly screeching to a crawl, making it impossible to work even at quarter view. The comp is composed of simple 2D layers, and my machine is more than capable of rendering the preview as it's running an i9 9900K, 64Gig of 3200mhz cl15 ram, SSD storage and a 2080ti.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  17. sampleImage script command

    This is both a ExtendScript bug report and a feature request.

    Bug first. This "hack" worked in earlier versions of AE:

    var sliderControl = layer("ADBE Effect Parade").addProperty("ADBE Slider Control");
    sliderControl.name = "temppscontrol";
    sliderControl(1).expression = "thisLayer.sampleImage([300,50], [1,1])[3];";
    var alpha = sliderControl(1).value;
    alert(alpha)

    It would get the sampled alpha from an AVLayer. It doesn't return the correct value any more, because the script moves on before the sampleImage expression has run.

    Feature request: It would be nice if sampleImage was simply included in ExtendScript.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  18. Urgent Bug in 2020 - 3D Reference Axis Causes Instant Crash

    Turning on the 3D Reference Axis in 2020 causes an automatic crash.

    For days I've been trying to figure out why some of my older projects were crashing in 2020 when I opened a comp, and I just realized it's because the 3D Reference Axis was on in those comps.

    To recreate the problem, simply add a Camera layer to any comp, and turn on the 3D Reference Axis.

    I'm on an iMac running Big Sur, but I get the same results on Catalina, and on a PC running Windows 10.

    Please fix ASAP. I have products that clients can't…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  19. AE v17.5 crashing on launch under MacOS 10.13.6 (High Sierra)

    Running MacOS 10.13.6, so I'm currently unable to install a few of the updated apps. That being said, After Effects 17.5 was allowed to be installed. On launch it crashes out every time with the two following errors:

    After Effects error: Couldn't find main entry point for Camera Raw.plugin ( 48::72 )

    After Effects error: unbalanced unprepared. ( 48::30 )

    No way to launch the app without the crash.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →

    Thank you for filing this bug. This problem occurred because the October 2020 release of Adobe Camera Raw is not compatible with macOS 10.13, however the Creative Cloud desktop app did not prevent it from being installed. That has been corrected, however if you’ve already installed v13 of ACR, you will need to uninstall it and reinstall v12.4.

    More information here:
    https://community.adobe.com/t5/after-effects/faq-how-to-solve-after-effects-v-17-5-crash-at-launch/td-p/11522545?page=1

  20. Bug with .setPropertyParameters() for Dropdown Control

    This method seems to generate a "Duplicate item names are not allowed" error when using an array where an index is a substring of another index. This example specifically triggers it: ["HeadTop", "Head", "HeadBottom"]; will not be accepted by the method (the "Head" index seems to throw it off) - But: ["HeadTop", "HeadMiddle", "HeadBottom"] will be accepted.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base