After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. (BUG) Preview in after effects 2020 creates a "new" window.

    When i try to preview my scenes a "new" preview window appears and is "off center" and it plays in real time with out lagging. Sometimes that new "window" is not even visible (depens on how much you have zoomed into the scene) adn the original workspace area is just static. I hope my screenshots makes the matter more clear, since it is hard to explain in words. Also, sliding the current time indicatior manually works - Then the "real" preview window is showing what it should.

    Both screenshots is taken during preview. When preview is stopped everything looks normal

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  2. [BUG] Master Properties can't be changed with expression

    I put this simple expression on a master property that cycles through some items. It shows 1, 2, 3, 1, 2, 3, etc. on the control, but it only shows the item #1.

    timeToFrames(time/50) % 3 + 1;

    This wasn't working on another master property, but it started to at some point on it's own. I've tried purging, recreating the property. About the only thing I haven't tried so far but sometimes works is recreating it all in a new comp.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  3. BUG REPORT: preview playback will not stop

    When playing preview by pressing the spacebar or using the preview panel it does not stop by pressing the spacebar again and the interface is unresponsive. (CC 20 - v17.0)

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  4. [BUG] When a new keyboard shortcut file is generated, i and o for layer in and out points don't work

    When a fresh shortcut text file is made in CC2020, then going to in and out points doesn't work when pressing i and o. Tested by using a previous custom shortcut text file which works fine. Then removed to generate a new fresh one and the buttons don't work

    AE version 17.0.0
    Mac OS 10.14.6

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  5. AE 17.0 ram preview is offset from the comp view

    The ram preview plays but is displayed about 200 pixels right and 200 pixels down in the comp window, you can see the current comp frame behind it. its cut off by the edge of the comp window

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  6. Bug - Roughen Edges doesn't work the same in 2020 as it does in previous versions

    In AE CC 2020, the Roughen Edges effect still shows the original edges of shapes and vectors. It also produces oddly colored edges.

    This wasn't the case before this version. It used to produce nice rough edges.

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    12 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  7. AE 17.0 RAM Preview unresponsive / stuck

    RAM Preview speed has improved but the entire program becomes unresponsive to clicks, spacebar, Num0, ESC, etc. Playback continues on loop and the only way I've found to regain control is to minimize/maximize AE.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    13 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  8. AE 2020 fixed ram preview for me... YAY! However, Numberpad "." no longer previews just the audio

    AE 2020 fixed ram preview for me... YAY! However, Numberpad "." no longer previews just the audio. If I hit the "." key, the play-head moves across the timeline, but there's no audio... and I don't see anything in the audio levels display either. If, however, if I enable video preview in the Numberpad "." preview, I get audio... AND video—which obviously defeats the purpose of an audio-only preview.

    11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    13 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  9. 68 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    36 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  10. Go to layer in-point and out-point (shortcuts I and O on layers panel) on AE 2020 not working.

    Updated to Ae CC 2020 and going to the beginning or end of a layer isn't possible because the shortcuts (keys I or O) are not working.

    19 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    23 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  11. Real-time playback improvement needed

    When I try and load up a section of a composition to preview it doesn't play back smoothly even after it is cached.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  12. RAM preview is not playing at the correct speed anymore.

    In a 1080p comp, a shape layer is animated in position, the RAM preview is slow/laggy and play aorund 19-20 fps instead of 25.
    But if I scrub the timeline, everything is smooth, reactive.
    See the video attached, What can I do ?

    Here is my specs :
    OS Name Microsoft Windows 10 Professionnel
    Version 10.0.18362 Build 18362
    Other OS Description Not Available
    OS Manufacturer Microsoft
    System Type x64-based PC
    System SKU LENOVOMT20M9BUThinkFMThinkPad P52
    Processor Intel(R) Core(TM) i7-8850H CPU @ 2.60GHz, 2592 Mhz, 6 Core(s), 12 Logical Processor(s)
    BaseBoard Manufacturer LENOVO
    BaseBoard Product 20M9001KMB…

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  13. RAM Preview Performance Bug... Again :\

    Since updating to the latest build of AE (16.1.2 Build 55) my ram previews are again unstable at best (a problem I haven't had with a number of previous AE builds).

    If I open a project that has a number of other reduced AE projects that have been imported into that project, my RAM previews stutter like crazy and the feature is basically unusable (again, a problem I haven't had with a number of previous AE builds… I’m so disappointed to see it return).

    If I reduce that project, I can get an almost useable RAM preview, but there’s still…

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  14. CC Vignette bugs

    Found a very easy way to replicate buggy behavior with CC Vignette.
    1.Put any image or media in the timeline
    2.Create an adjustment layer on top of it and add CC Vignette.
    3. set a couple position keys on the adjustment layer and animate it.
    4. You should see lots of strange behavior on the layers beneath the adjustment layer.

    I ran into this issue lots when working with full-screen comps that had to shift over to split-screen.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  15. AE always crashes when this process is performed // この工程を行うと必ずAEがクラッシュしてしまう

    AE always crashes if you do the following procedure.

    1. Launch AE
    2. Create New Comp
    3. Creat New Solid
    4. Duplicate the Comp
    5. Open the duplicated composition
    6. Lock the cloned composition viewer
    7. Open the first composition you created in the timeline tab
    8. Center the anchor point with the shortcut
    9. crash.....

    以下の手順を行うと必ずAEがクラッシュします。
    1. AE を立ち上げる
    2. 新規コンポジションを作成
    3. 新規平面を作成
    4. コンポジションを複製
    5. 複製したコンポジションを開く
    6. 複製したコンポジションのビューアをロックする
    7. 最初に作ったコンポジションをタイムラインのタブで開く
    8. ショートカットでアンカーポイントを中央に持ってくる
    9. クラッシュする

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  16. BUG: localeCompare() immediately crashes After Effects!

    Typing localeCompare() into any expression immediately crashes After Effects!

    This also occurs with the majority of autocomplete options for "locale".

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  17. BUG: TSV data no longer exporting .mogrt / read by Premiere

    I no longer get a pop up warning me that AE is needed to run the .mogrt in Premiere with the TSV data...
    The data is no longer read in Premiere, which it was before the last "upgrade"
    Is there any troubleshooting tipd for TSV based expressions in mogrts?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  18. Comps that are rendered/green in timeline are not playing back in real time

    I always thought a ram preview meant the preview would play back from ram in real time. this is often not the case. Most the time, especially comps with audio, don't play back in real time even if they are committed to ram or disk cache (Which means you either get the warped record slow down, or if that's muted in settings, nothing at all)...why is this, on every machine I've worked on...

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  19. [16.1.1 BUG] Clicking on Expression Editor inside Graph Editor freezes AE

    AE 16.1.1
    macOS Mojave 10.14

    Steps to Reproduce:

    • Apply an expression to a property
    • With that property selected, go to the Graph Editor
    • Right click on the graph and enable "Show Expression Editor"
    • Click on the expression editor Result: AE freezes
    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Resolved  ·  5 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  20. When throwing errors in expressions show the Error message on Windows properly

    Throwing Errors is very helpful when debugging expressions (see https://twitter.com/mamoworld/status/1101168951185289217 )
    However, currently on Windows the thrown error message is not shown in the status bar. On Mac this already works nicely.

    The reason seems to be some subtle differences of how exactly the banner messages are shown on Mac/Win (see https://twitter.com/1ResCreation/status/1117325915007016962)

    Please make Win behave the same as Mac for this and show the message directly in the status bar.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base