After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Bug: Master Properties not displaying property name

    After updating to 17.1.4 everything in Master Properties on the timeline is now displaying as the property type (i.e. "Slider" or "Checkbox") instead of the correct name.

    macOS Catalina 10.15.6

    update: renaming the property in Essential Graphics will rename the property on the timeline (at least temporarily). However, when duplicating the layer, the duplicate will revert to displaying the property type.

    11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  2. BUG: Double clicking keyframe in timeline does not open keyframe properties

    When double clicking a keyframe in the timeline the keyframe properties do not open, only the keyframe is selected. You need to manually right click and edit the keyframe to change values.

    This issue only started when updating to AE Version 17.1.3 (Build 41) on Windows 10.

    20 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    16 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  3. Rotation tool seems broken

    With the latest version (17.1.3) the rotation tool freaks out when using it for the layer transform rotation. Somehow it does work fine for parametic shapes. Just by dragging a little bit, it rotates like 2000 times.

    50 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    27 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  4. Make expression controls inside composition accessible to the layer instance outside

    I have a composition of a keyboard with each key to light up on a note. I make the keyboard and several checkbox controls for the highlight. Now I put the keyboard composition as a layer in a composition that has all the note info.

    Why can't I make the checkboxes inside the composition available to the layer so that I can have multiple note arrangements using the same keyboard composition? I can't make this link without hard-coding the composition name into the keyboard composition. So I have to make a duplicate keyboard for each composition I want to use…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Resolved  ·  3 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  5. Bug with .setPropertyParameters() for Dropdown Control

    This method seems to generate a "Duplicate item names are not allowed" error when using an array where an index is a substring of another index. This example specifically triggers it: ["HeadTop", "Head", "HeadBottom"]; will not be accepted by the method (the "Head" index seems to throw it off) - But: ["HeadTop", "HeadMiddle", "HeadBottom"] will be accepted.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  6. URGENT BUG - Effects on 3D shape layers don't show at all - 2020 17.0.2

    This is a crucial bug that needs to be fixed IMMEDIATELY!

    Any shape layer that's 3D doesn't show any effects. If 3D is disabled on the layer, the effects show.

    This is a crippling bug introduced in the latest update and it needs to be fixed ASAP!!!!

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Resolved  ·  2 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  7. Fix expression editing within graph view

    In both AE 17.0.0 and 17.0.2, I did not test it in 17.0.1. Using Win10 with a Ryzen 3700x and a GTX 1060 6gb

    When editing or writing expressions while in the graph view mode, it is hit or miss whether or not the new code will be commited.

    It was suggested by another user to use the 'enter' key on the numpad to commit changes, but this didn't work every time either, so it doesn't solve the problem.

    When editing expressions in the normal layer view everything works and saves/updates as it should. You just type out the code…

    12 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  8. BUG: Pickwhip in expression editor

    When Pickwipping a slider inside and expression with brackets, the auto expression will miss the closed bracket because of the outside brackets. This means you need to add another bracket on the end which is fine, but some people may not see it get missed until an error spits out.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →

    Hi Josiah,

    Thank you very much for reporting this issue. As of After Effects’ March 2021 release ( version 18.0 ), pick-whipping between brackets properly preserves all existing brackets and no longer results in an expression that needs correcting. Please let us know if you continue to see any issues with pick-whipping in the expression editor after updating to AE 18.0.

    https://helpx.adobe.com/after-effects/user-guide.html/after-effects/kb/fixed-issues.ug.html

    - John, After Effects Engineering Team

  9. Drop shadow/stroke not working when 3D mode is enabled on layers

    I've successfully tracked a video to add text into it.
    Drop shadow and stroke will not show up unless I turn the 3D layer check box off.

    I've added drop shadow as a regular effect and as a layer style.

    This has to be a bug of some sort, I've done this many times before.
    I'm working on After Effects 2020

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  10. AE 2020 - double click on footage opens a blank screen; no roto brush; just a small black frame in the upper corner. Huge issue.

    It's a bug, not a feature request - double clicking on footage in a comp opens to a blank white screen with a small black rectangle border in the top left corner, no footage. OSX 10.14.6, Mac Pro 2013, 64GB RAM

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  11. Output profile bug

    AE 2020. Renders to Prores HQ with a workspace setting of "Rec.709 Gamma 2.4" produce a file with the incorrect profile "HDTV (Rec. 709) 16-235" when read back in, producing a gamma shift with colour management turned on.

    Renders to Prores 4444 seem unaffected.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  12. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  13. Bug - Opening projects that use 2020 drop-down menu expression controls (Pseudo dialog on startup)

    I love the new drop down expression control effect in AE2020. Unfortunately though I have a bug on opening the project file. I get a dialog box similar to the attached screen grab for each instance I've used the drop-down menu as a master property. The code in the dialog changes for each instance.

    For context, my project file features one precomp with a number of properties controlled by 3x dropdown menus on a control layer for colour, text option and positioning. That precomp is used in 5 other compositions, where using Master Properties I have used different drop down…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  14. баги в варп стабилайзере

    на варп стабилайзере не могу выделять мышкой несколько трек поинтов. выделяющая маска рисуется где то в левом верхнем углу. поправьте плиз этот баг. а то очень неудобно по одной точке выделять с зажатым шифтом((

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  15. Compatibility issue - MacBook Pro 16 - AMD Radeon Pro 5300M 4 GB

    I'm using a MacBook Pro 16 with AMD Radeon Pro 5300M 4 GB, and there appears to be a compatibility issue between AE and the graphics card. My composition window is completely distorted with horizontal lines running through it.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  16. BUG - AE 2020 Viewport glitching out at 100% or less zoom.

    The viewport completely glitches out at 100% or less.

    I've tried uninstalling and reinstalling AE 2020.

    Viewport is fine in AE 2019.

    Hardware specs:

    Mac OS Catalina
    Macbook Pro 16" 2019
    AMD Radeon Pro 5500M 8 GB
    Intel UHD Graphics 630 1536 MB
    64GB RAM

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  17. Interpret footage bug

    AE2020, Mac i7:

    1. There is an asset in project encoded with Apple ProRes 422 LT movie with assigned profile HDTV (Rec. 709) 16-235.

    2. This is incorrect so user selects Interpret Footage.

    3. User sets color management to sRGB working space.

    4. Closes and saves file.

    5. Reopens file and the asset has gone back to the old profile again, HDTV (Rec. 709) 16-235!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  18. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Flag idea as inappropriate…  ·  Admin →
  19. scroll through fonts with arrows (v17.0)

    In version 17.0 it seems like the ability to preview fonts with the arrows keys is, once again, broken. It's crazy how much this slows down a workflow. Can we get this fixed please?

    11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  20. bug report - playback issue

    Having an issue with the new 2020 update that was not happening with 2019. First off, a lot of things are quite laggy when clicked so take a long time to react. Sometimes it's a second or two, sometimes it's so long I start thinking AE is locked up. I can start playback on a section and then it won't stop (by hitting 0, clicking the playhead, hitting Space). Sometimes it takes a few seconds to respond and sometimes up to a minute. Several times now I actually had to force close AE just to make it stop playback.

    I…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base