After Effects

Welcome to the Adobe After Effects feedback page. Submit feature requests and bug reports to the After Effects team via this UserVoice site and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the After Effects community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. [BUG] SampleImage() broken and returns wrong values / breaks expression

    https://community.adobe.com/t5/after-effects/problem-with-sampleimage-in-after-effects-cc-2015-extendscript-expressions/td-p/7395353

    SampleImage() works asynchronously and doesn't udpate on time for a script to read.

    There is no way to sample pixel using extendscript, the only workaround is to use SampleImage() using an expression, but this does not return the correct results.

    Please there is a lot of potential to make scripts do more content-related stuff with the ability to sample the image and analyze it, this is not a minor issue.

    Scripting aside, SampleImage() reads as a broken expression sometimes and takes time to refresh, which makes the orange expression error bar go on and off and can break renders.…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  2. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Animation  ·  Flag idea as inappropriate…  ·  Admin →
  3. Scripting Bug - Duplicating layers with layer controls

    I'm using a script I sell to make a grid of layers. For some reason, if there's an expression on the layer that I'm duplicating that points to a layer control on the layer or on another layer, it locks up After Effects completely. I can replicate the issue at will.

    I assume it's because After Effects doesn't know how to reference the expression as it copies? If I disable the expression, it works.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  4. Gaussian Blur (GPU) artifacts and quality issues

    Gaussian Blur (new GPU based one) has unexpected/poor results compared to the legacy one. Visual artifacts occur in 32-bit mode on adjustment layers, and in general it has a less natural, more blocky look than the traditional Gaussian Blur.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  3 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  5. Bug: Moving between screens with different scaling

    When click-dragging a property's numerical value (e.g. position or scale), if the mouse cursor crosses onto a screen with a different scaling setting in Windows Display Setttings to the one with AE in it, the value jumps. The bigger the difference in scaling, the bigger the jump.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  3 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  6. New Update 18.0.1

    You cant click on the footage anymore to scale it directly with your mouse....?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Animation  ·  Flag idea as inappropriate…  ·  Admin →
  7. interpret Footage -> Premultiplied not working

    My Prores 4444 Footage w Alpha that is premultiplied on Black, only acts normal when I am in Half resolution preview. As soon as I switch to Full Res or Render, the Alpha is treated as Straight/Unmatted.

    Interestingly… if I select the interpret footage option "invert Alpha", the Alpha is only inverted when previewed at Full Resolution, not at reduced resolutions.

    When I employ the workaround of adding the effect "Remove Color Matting" (Black) myself manualy, I also get very weird halos and artefacts when previawing at half resolution, which are not a side-effect of simply downscaling.

    This occurs in…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Compositing & effects  ·  Flag idea as inappropriate…  ·  Admin →
  8. Roto Brush crash AE V 17.7.0

    Hi.

    Anybody else noticed this?

    Cannot use Roto Brush effect with UHD Prores 4444 material and colour management. Roto Brush crashes AE almost immediately.

    macOS 10.15.7
    GPU Radeon Pro Vega 48 8 GB

    Metal GPU Acceleration.
    Colour management on.
    32-bit ACES AP1 working space with Arri Log C material.

    When I turn colour management off, I can use Roto Brush.
    Exciting to see what happens when I have to turn colour management back on when compositing 😬

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  9. 5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  10. Camera GUI display does not reflect expression-driven Point of Interest

    When the "Point of interest" of a camera is driven by an expression.
    Something like:
    thisComp.layer("Null 1").transform.position
    The graphical display of the camera wireframe in the interface does not reflect the value of the expression.
    It seems to be "stuck" at the Point of interests native value.

    After Effects 17.6.0
    MacOS 10.14.6

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  11. Fix the **** 17 :: 19 overflow error. No real number should ever be allowed to save where an integer is expected.

    Fix the **** 17 :: 19 overflow error. No real number should ever be allowed to save where an integer is expected.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  4 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  12. When using projectPath render token, existing files are overwritten without warning

    When using the "projectPath" property (render token) to manually set the filepath in the File Name and Location Template, if a file with the same name already exists, it will be overwritten without any warning when the user clicks Render. This should be fixed to prompt the user with a warning before rendering begins.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  13. Please bring back features

    Please bring back features like "select single view" in viewer settings. It is crucial for those, who are working with 2D animations on small screens and need more screen estate. I've uninstalled version 18.0 and using older v17 until the feature returns. Thank you!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →

    Hi Tomas,

    Can you please explain further which option you’re missing? There were a few changes made in After Effects 18.0 that you might be referring to, and I think there might be a translation problem.

    In After Effects 18.0, the toolbar in the Composition pane was updated to reduce clutter and improve 3D workflows. Details are here:
    https://helpx.adobe.com/after-effects/user-guide.html/after-effects/using/whats-new/2021-2.ug.html#ImprovedCompositionToolbar

    One thing that was changed is that 3D controls now only appear if you have a 3D layer in the comp. We’ve heard from a number of folks that the View Layout menu (selecting 1/2/4 views), which is part fo the 3D controls, is being missed. In the latest releases of After Effects Beta, which you can install via the Creative Cloud app, the View Layout controls are now also accessible via the View menu; you can access these options at any time without a 3D layer being present. Please try…

  14. Ram preview still doesn't work

    Ram preview has been broken since you overhauled it in what 2016? Still doesn't work. Wth?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  15. PLEASE FIX the dreaded "unable to obtain dynamiclink project"

    I am getting an “unable to obtain dynamiclink project” error when I try to reapply Warp Stabilizer to a clip that had to be extended in length.

    As Dynamic Link has caused problems for me in the past, my workflow for the past 3+ years is to copy/paste footage from Premiere Pro into a new After Effects timeline, and render a ProRes file. This has worked flawlessly for me, and no need to mess with Dynamic Link once I had the files in AE.

    Today, I opened a project that contained some previously warp stabilized clips, one of which had…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Workflow & interoperability  ·  Flag idea as inappropriate…  ·  Admin →
  16. BUG. Liquify effect in 32bit inverts alpha. Please FIX

    BUG. Liquify effect in 32bit inverts alpha.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  17. After Effects 17.7 crashes when attempting to open preferences.

    After Effects will crash if I attempt to open any preference pane.
    I am using an 27" iMac (late 2013) running Mojave 10.14.6.
    3.5 GHz Intel Core i7
    32 GB 1600 MHz DDR3
    NVIDIA GeForce GTX 780M 4 GB.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  18. BUG: White dot/blob appears in 8bpc project

    I have encountered a weird bug. First, I thought it was a fault in the project, but today I created a new, blank one, added an empty comp and the white blob is back. It looks the same and its on the same position.
    Since its repeating in a brandnew project, this is likely a bug.

    Its only visible in 8bpc projects, all higher bpc, this blob is gone.
    I haven't re-installed AE yet, since its a workplace station and the IT has to do this and also reinstall all plugins. During a working day, thats almost impossible.

    Do you…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  5 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  19. Multi sequence import it broken.

    When I try to import multiple sequences, they will all import however only the last one will have all its frames eg 0-249 the rest will have the frame I selected and say 0-0 or 180-180.

    It would be much more user friendly (and honestly save me a lot of time) if I could just import the folder and it would import the images as a sequence, or in this case multiple sequences

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  20. Ridiculously slow and laggy interface

    I almost can't work in it. Third party effects are useless and the overall responsiveness of After Effects 202 is terrible. If I didn't keep getting the ridiculous drawing error in the 2019 version, I'd be using it. You HAVE to fix this issue fast. Your application is almost useless right now. People are going to switch. Right now, I totally regret upgrading to CC 2020.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base