Skip to content

Premiere Pro

ANNOUNCEMENT - This forum is moving


In an effort to improve communications between you and the Premiere Pro team, we are moving this feedback forum to the Premiere Pro page on the Adobe Support Community. As requested, bugs and feature requests will be able to live separately in that forum.

This move is happening in part to acknowledge that we haven't been responsive enough here, and we are combining our forums to help remedy that. Ideas and their attached comments from this UserVoice forum will be migrated based on how many people voted for them. Check your profile on the Adobe Support Community to see any migrated posts that you've created or commented on. If you have an item here that did not make the migration, please bring it over to our new home.

See you soon on the Adobe Support Forum!

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback

3 results found

  1. Premiere playback laggy with M1 Ultra Mac Studio

    Upgraded to the M1 Ultra Mac Studio(20core CPU, 48core GPU, 32 Neural Engine, 64GB ram running OS 12.5) and am experiencing slow playback performance. The footage is 4k 420 10bit H.265

    I've been working on my 2018 PC (i9, GTX 1080, 32GB ram). I've had the PC for 4 years and am used to the performance it has with this footage. Opened the same project on my new M1 Ultra Mac studio, that's 4 years newer, more than twice the price, and significantly faster/more spec'd out, yet my PC is handling the footage better.

    I've spoken with Adobe Care on…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Hi Tom, 

    I'm sorry to hear that you're not getting the performance you should be. I'm one of Premiere Pro's product managers and a particular area of focus for me is formats and performance.

    Can you tell me a little bit more about the HEVC files you're using (e.g., what camera they are from, what wrapper - .mov, .mxf - they are in)? Even better would be to share a project and its media that you're seeing the issue with. 

    I'd be happy to get on a call with you to discuss the issue you're seeing but let's start with some basics and go from there.

    Regards,

    Fergus

  2. BUG report version 14.4.0

    1. Loose control over playback after playing video clip in reverse.
    2. Premiere "not responding" after adding Red Giant Denoiser III on top of Lumetri
    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Playback  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Premiere Pro 2019 support for Apple Pro Res Codec

    Premiere Pro 2019 does not support Apple Pro Res and cannot play clips in the codec. 2018 Technically doesn't either, but I was told only half the user experience issue with Pro Res.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Playback  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base