Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Interpret footage changes should apply to Proxy files

    At present when we change the frame rate of a file using "Interpret Footage" the change isn't applied to the corresponding proxy file.

    I think this is a ig handicap and the work arounds seem unnecessary and time consuming.

    I would strongly suggest correcting this so when we change a batch of files suing interpret footage it automatically applies to the proxy files.
    Thank you!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  2. Improve playback performance of still images

    Problem: Currently playback lags significantly whenever an JPG image at its full resolution (6000x4000) is added to the timeline despite selecting 1/4 or 1/8 playback quality or changing playback settings. Playback stops completely when motion effects are applied (like scale/position changes).
    Problem occurs even on a computer that handles 100mbit 4K videos at Full playback resolution without problems.

    Expectation: Since an image is just 1 frame, it actually should be easier for computer to handle it and I would expect a smooth playback. It would be fine to also see it at reduced quality, because currently, reducing playback quality does…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  3. Bug in the playback, after loop no sound.

    The new version of Premiere Pro when the playback ends and the loop button is on, the playhead goes to the begining and then the sound stops.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  4. Playback issues using 4k videos

    I'm having issues playing clips that are in 4k formats. I'm able to play the videos on my laptop just fine but once I put them in Premier Pro there's a huge lag. I tried creating Proxies for the videos and it didn't work. I also tried lowering the resolution and that didn't work also. I was able to edit 4k videos on the previous version but ever since I updated the app I have not been able to playback the videos properly.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  5. Footage at different framerates should scrub smoother

    after interpreting footage or any footage that is already converted from a higher frame should playback normal when scrubbing. often footage will playback the wrong point in the footage randomly when scrubbing making it difficult to pull selx

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  6. player instabil. Pr 14.8

    facts:
    win10, radeon card

    error:
    sometimes player works and sometimes not. No playback in resource an record player, no picture in that, no playback in timeline. If I want to exit Pr it freezes. If it works than is an green-frame effect in picture.

    graphic card is up to date.

    in generell I tried to play between software and GPU Player.

    Help. Pr 14.8 is like an errors of labyrinth.

    Thx
    Katja

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  7. background rendering for render and replace and caching for mogrts

    if render and replace could work on the background you could focus on teaking some arameters while you work with mogrts cause they almost never play back smoothly you always have to render them in the first place
    also could use some background caching to disk like after effects does

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  8. AUDIO VIDEO OUT OF SYNC

    Audio and Video out of sync when played back in H264. Tried re installing Premiere Pro, re-installed Video Drivers, created new project with out success. These have synced perfectly for the last 2 years, what is causing this sync problem.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  9. Alexa Mini Log/Rec709 Bug

    I imported several clips from a day of shooting and some are Log C while others have a Rec709 look burnt in. No masterclip effects on any and the disable button is greyed out. In finder they are all Log.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  10. Alexa Mini Log/Rec709 Bug

    I imported several clips from a day of shooting and some are Log C while others have a Rec709 look burnt in. No masterclip effects on any and the disable button is greyed out. In finder they are all Log.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  11. blue tooth

    Some blue tooth head phones don't sync with the timeline.
    This can be improved.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  12. More zoom options in the program monitor.

    We should have the ability to use alt scroll wheel to zoom in and zoom beyond 400%.

    Precise masking is often too hard at 400% and I shouldn't have to rely on the use of an after effects composition to create that required mask that I could otherwise make in the program monitor.

    9 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  13. Full screen viewing not working in Big Sur

    Since updating to Big Sur, one feature I use a lot is the 'Toggle Full Screen' shortcut. this does not function properly in Big Sur. When you toggle full screen, it stops playback in the program monitor, but continues audio playback, metering and timeline scrubbing. Very annoying bug to have when working mobile on a laptop, please patch this!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  14. Playback freezes for H.264 (Long GOP) footage

    I am on a 2020 iMac20,2 with AMD Radeon Pro 5700 XT graphic card.
    This card as all other cards on the 2020 iMac lineup is unsupported.
    Premiere Pro 14.7

    Completely new project, single 5 minutes H.264 compressed mp4 clip, 1080p, no effects.

    Jumping back and forth in time or pressing play/pause causes the the playback the freeze in up to 3-5 seconds.

    Unchecking "Enable hardware accelerated decoding" under "Media" in preferences, causes playback to be much faster.

    I would like the be able to take advantage of hardware accelerated decoding.

    I suspect it's because the graphic card is not…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  15. Enable hardware accelerated decoding for 2020 iMacs

    Enabling hardware accelerated decoding on my 2020 iMac20,2 causes playback to lag and stutter. With a up to 3 seconds lag the program becomes useless.

    This only (mainly) happens with compressed material like H.264 mp4 and mov.

    I suspect its because the graphics cards is not supported.
    I fact the entire 2020 iMac lineup has unsupported graphics cards.

    I would love the see that change for the 2021 programs.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  16. Premiere Pro v14.5 "frame substitution recursion attempt" error

    I kept getting the attached error as seen below on 14.5. This would cause my video to show black freeze frames intermittently and I was told it was my GPU but after rolling back three times to a driver i knew had worked in the past the error persisted. I rolled back premiere to 14.1 and the error dissapeared!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  17. Latest 2020 Update results choppy playback

    Since I updated the latest version, playback has been very choppy even for a 1080p footage and timeline. I'm using a 8 core i9 9900k CPU with 64GB RAM.

    I have never faced this issues even with 4k footages for a 2 hours feature film timeline editing. It's very frustrating that Adobe did not provide 'Save As' to previous versions to at least be able to open the projects and 2019 or other previous versions.

    In addition, the Lumetri Colour panels are also showing errors 'AEFilter:14' very frequently. I have never run to such issues. I am not experiencing this…

    30 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  18. Premiere Pro 14.5.0 Build 51 - Audio Bug

    There is a major audio bug in Premiere Pro 14.5.0 Build 51 with macOS 10.15.7. Editing a sequence with audio only and playback completely freezes.

    Spacebar does not activate playback. Hitting PLAY button in program monitor does not have playback. System does NOT crash or generate a crash report.

    Entire machine needs to be fully shutdown and restarted to fix the problem. Simply restart of software does NOT fix.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  19. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  20. Major Bug With Speed Ramping

    There is a major issue with Speed Ramping in the latest version of Premiere Pro 2020. I am unable to play back a simple clip that has a speed ramp applied to it in real time without pre-rendering it. When trying to playback a clip that is speed ramped, it turns into a glitchy mess, and the remaining clips that follow never start playing as they should unless I pause and restart the playback. This was never an issue in Premiere Pro 2019. I have re-downloaded PP2019 where the issue is no longer present.

    I have found that it seems…

    14 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base