Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Canon XF705 HEVC-MXF 4K files have very choppy unusable playback even at 1/8 resolution

    Thank you for including HEVC-MXF support in your recent update. However at 4K the files are still unusable, even at 1/8 resolution I get choppy playback (works fine at 1080) which means I can't edit. I have a 2 day old iMac Pro with upgraded memory, processors, and video cards.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  2. Playback issues immediately upon update to 13.1.5 v47

    After update, sequence does not follow playback and or program window does not play while sequence plays. Scrubbing does not seem to be an issue. This is not a lag, dropped frame or speed issue. This is a complete break in connection between sequence and program window. It is as if one or the other becomes "disconnected" from the playback functionality. Save is unaffected. I save, close and then reopen Premier and the problem vanishes for about half an hour. The problem then reinstates if I perform rapid/complex sequence, scrub, playback functions. This is brand new behavior. I maintain three…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  3. Creating proxies with the same framerate as original clip easier.

    As the title says... The issue is, let's say you have footage with 25fps and 50 fps. You press "create proxies". Then playing a 50 fps clip set to 50 % in speed it's playing it all laggy. Like the bad slowmotion you get when you slow 25 fps footage with 50% (skips half a frame). Today you have to make a proxy, cancel that transcoding in AME then reset it and interpret it. Then start it again with the interpreted framerate. Attach proxies in Premiere and then you're ready. Which is a huge hassle to me.

    Would be nice…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  4. Toggle "Frame Replacement for Decode Errors" feature off.

    In a QC critical enviroment, the red frame for decode errors was an incredibly helpful warning of potental corrupt frames in a file.
    If this visual warning is replaced with a duplicated frame then the potential file issues become much harder to spot and/or more time-costly to verify.
    If frame replacement is seen as a critically usful feature, please allow users to toggle it off/back to the old way.

    With this new feature, Premiere updates past 13.0.2 become unusable in a QC environment/workflow, and users (us included) will be forced to switch to other software for critical evaluation.

    7 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  5. Bug: Spectacular, flashing graphic faults when .jpg or .png put on video!

    this is caused by putting a 6K or larger image (with less than 100% opacity) onto video which is either
    1. a multicam sequence
    2. the following format video:

    Format : MPEG-4
    Format profile : Base Media / Version 2
    Codec ID : mp42 (isom/mp42)
    File size : 27.3 MiB
    Duration : 13 s 177 ms
    Overall bit rate : 17.4 Mb/s
    Encoded date : UTC 2019-11-01 07:41:47
    Tagged date : UTC 2019-11-01 07:41:47
    com.android.version : 9

    Video
    ID : 1
    Format : AVC
    Format/Info : Advanced Video Codec
    Format profile : High@L4
    Format settings : CABAC / 1 Ref…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  6. A problem with playback settings for 2 and more monitors.

    I have a problem. I use 4 monitors to work in the premiere. (official ofc)
    After upgrading from 2018 to 2019, I cannot select the monitor I need (1).
    The program constantly resets to the same monitor (4).

    If I put a tick in front of the monitor that I need, pressing OK, the monitor does not appear and all empty items are shown in the settings.

    Windows 10
    GeForce 1060

    Everything worked in the previous version 2018 СС.

    Can u help me plz?

    best< regards!

    p.s. i dont want downgrade to 2018

    7 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  7. lock playhead at center, scroll content with consistent zoom

    Like Garageband and other Mac based apps, you should be able to lock the view of any playback area (assembly, editing, color, effects, audio, graphcis) and make the content move behind the playhead, keeping the playhead always in the center. Keeping a consistent zoom and between modes (effects/Audio...) and locked would save time and effort.

    5 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  8. Blackmagic Playback issue

    I've upgraded to Premiere Pro 13.1.4 (build 2) on a Mac Pro (Late 2013) that runs High Sierra 10.13.6. I have an external monitor that plays back my timeline via a Blackmagic Ultrastudio Mini Monitor. When I play the timeline and it gets to where there are no more videoclips (and there is still a clip on an audio track so it runs on) it displays the last frame of the last clip on the external monitor instead of black. The Program panel in the Premiere interface DOES show black when there is no videoclip on the timeline. When I…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  9. NEW UPDATE ISSUE

    The new update i made yesterday on Premiere PRO stopped my playback. Only the audio plays when i hit playback. Video gets stuck and shows MEDIA PENDING but the audio still plays.

    5 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  10. V13.1.4 Video freezes but audio keeps playing

    my MP4 files will randomly freeze, whereas my audio track will continue playing just fine. Really gets on my nerves and wastes too much of my time. looks like plenty others are having this problem too

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  11. 1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  12. Update the click and drag function for the timeline and effect controls on Premiere CC 2019 V 13.1 operating on MacOS Mojave V 10.14.5

    There is a problem with the click and drag function on the timeline when you try to click a spot on the timeline and drag the playhead to a different spot. The playhead will move to the click spot, and if you move it, the playhead will move to that second location but nothing in between. This also occurs when you try to change any effects in the effect control panel. The click will engage the effect, but you have to enter in manually the number. https://youtu.be/waGwsoJHODc This video shows how it functions. I'm on a 2018 Macbook Pro with…

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  13. Issues with Mercury transmit and HD TV

    Ive had my HD TV and 4k desktop monitor set up for a while. I was just using PP CC 2018 with GTX 1080 on a windows 7 system and the Mercury Transmit worked perfectly fine when enabled. I had it set up where the Mercury transmit playback would come on the HD TV. Now i have upgraded to Windows 10 Pro and updated to PP CC 2019 and now everything with the Mercury Transmit is messed up. Every time i enable the Mercury Transmit onto the HD TV it shows the image way bigger than the screen. i only…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  14. Set the default view of a new subsequence to the start of the clip

    After creating sub-sequences, when you re-open them, you are often stuck viewing a blank area, or partial view of the new clip. Rather seeing the beginning of the sub-sequence, the view is set to the end time of where the clip was created.

    Example:
    You create a 10 second subsequence at the 5min mark. Open the subsequence and you'll be the viewing the end of the workarea, at 5:10s, but the clip is actually now located off screen to the left. You may or may not see the clip at all depending how zoomed in you are. You now…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  15. Fix playback choppiness

    The playback functionality is terrible now after upgrading to Premiere Pro CC 2019 - My computer is a brand new iMac Pro with more than enough processing power. The problem started recently. I can't play normal video (without effects) without interruption. The only workaround (which is not an option) is to render everything before even trying to watch it. Full work stoppage.

    17 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  16. Setting to play automatically at 1.5x speed

    When playing interviews, it's time efficient to play them faster than real time, but 2x (keystroke: LL) is too fast. 1.5x speed is a good compromise but is very awkward to get to especially when you have to start and stop a lot. Having a mappable 1.5x playback speed would be very useful.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  17. Issues with the newest update

    Latest update issues: (1) Playback hangs so long it has tripled work time; (2) Legacy titles won't retain arrangement of tool ribbons--must widen tool ribbon on left, narrow the settings ribbon on right, and please make the Legacy Title Styles menu closeable. (3) Enable defaults for transitions like "page peel" (i.e. peel from top-right or reverse). (4) When duplicating a Legacy Title, a title from a sequence is suddenly highlighted causing user to inadvertently change its name--very dangerous issue! thanks in advance for you help.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  18. BUG: Preview problems with Full Screen & Mercury Transmit

    The first bug appears when simply toggling on full screen on my main 4K monitor. The preview which should cover the entire screen only overlays a part of it.
    A workaround is to toggle full screen on and alt+tab to a different application and back to premiere so suddenly the full screen preview covers the screen correctly. The downside to this is that you have to do is every time you toggle to full screen. This is very annoying and time consuming.

    The second problem has to do with the mercury transmit. Even tough I only selected my TV (monitor…

    6 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  19. BUG: Multi Monitor Full Screen Video Broken with Mismatched DPI Monitors.

    If you have two separate monitors in Windows 10 with different DPI settings (say one 2.5k monitor with 100% DPI Scaling, and another 4k monitor with 150% DPI Scaling) and attempt to setup a mutli-monitor workspace, full screen video (mecury transmit/or ctrl+~ for full screen on main monitor) won't display properly.

    Steps...


    1. Have two different DPI settings for multi-monitor on Windows.

    2. Move project panel or any workspace panel onto secondary display.

    3. Use CTRL+~ to "Toggle full screen" or turn on transmit for secondary display.

    4. Video will be over scaled and mis-placed on monitor.

    I get that many people don't have…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  20. BUG:: audio cuts out when changing applications

    Not sure if it's a bug with Premiere or a mac thing but when previewing a sequence and clicking off Premiere to say a browser application, the audio of the preview cuts out for a second or two before continuing playback, slightly annoying if you’re trying to multitask on a project.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base