Skip to content

Premiere Pro

ANNOUNCEMENT - This forum is moving


In an effort to improve communications between you and the Premiere Pro team, we are moving this feedback forum to the Premiere Pro page on the Adobe Support Community. As requested, bugs and feature requests will be able to live separately in that forum.

This move is happening in part to acknowledge that we haven't been responsive enough here, and we are combining our forums to help remedy that. Ideas and their attached comments from this UserVoice forum will be migrated based on how many people voted for them. Check your profile on the Adobe Support Community to see any migrated posts that you've created or commented on. If you have an item here that did not make the migration, please bring it over to our new home.

See you soon on the Adobe Support Forum!

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback

569 results found

  1. Allow playback of a simple 4k clip with no effects on it on an 8 core Mac Pro with 42 gigs of ram

    Can't playback a simple 4k clip with no effects on it on an 8 core Mac Pro with 42 gigs of ram. 2015 worked fine. Take that same clip into 2017 or 2018 and it's unplayable

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. 7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. H264 video playback is green with OpenCL

    When I use Mercury Playback Engine with OpenCL, H264 video playback is green. The Lumetri graph is affected as well. However, when I disable OpenCL and use only Mercury Playback Engine, video playback is alright.
    Such thing does not happen to an HVC1 cideo.
    My CPU is i7-7700k and my GPU is Intel Graphics HD 630.
    Please solve this problem, since OpenCL helps render efficiently. :)

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Please make Sony VX2000 and Sony DCR-TRV38 cameras work properly with premiere pro

    audio sounds very interrupted and scratchy. Please make it work in the next realease.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. The slide control in the control section

    Please bring back the slide control that allows forward and backward play at very slow to very fast speeds. This tool was great for lining up sounds to video motion (very slow playback) and also to quickly scrub through a clip. I came to CC from CS5 and really miss that feature.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Multicam Premiere 2018

    O vídeo trava enquanto o audio continua quando estou o painel de multicam habilitado. Estou usando um imac i7 com 16 de memória e rodando o playback em 1/8. Mesmo assim trava.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Improve scrubbing/fast forwarding performance with these 3 ideas!

    Scrubbing and Fast Forwarding performance is often painfully slow.

    Here's an example by Jayme Cowley Media Co. of scrubbing performance in Pr vs Resolve: https://www.youtube.com/watch?v=ilPUc22itSA. The associated FR he posted mentions the problem but doesn't offer any specific solutions.

    Here are 3 improvements that could greatly enhance scrubbing and fast forwarding in Pr:

    1. SCRUBBING/FF RESOLUTION: In addition to being able to set the Payback and Paused Resolution in the Source/Program Monitor's wrench menus, it would be great to also be able to specify the resolution that's used when scrubbing or Fast Forwarding in the Timeline or Source Monitor. This…

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. 0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Stabilizer must now be rendered to view

    Hi again//

    When using Warp Stabilizer, I apply the effect to the clip. It analyzes, stabilizes. Then when I hit playback, the picture snaps up into the top left quarter of the frame. Only when I render the clip does it play back normally.

    This is fresh to PP2020.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
1 2 25 26 27 29 Next →
  • Don't see your idea?

Feedback and Knowledge Base