Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Bug report: Blackmagic Desktop Video 10.11.4+ break Premiere Pro playback

    I've just recognized an issue we have with Adobe Premiere Pro (tested on all versions from 12.1.2 up to current) where playback in a timeline gets paused randomly after anywhere between 2-5 seconds of playback. I tested with ProRes 422 and 422 HQ files and R3D files.

    We have a Blackmagic Intensity Pro card installed into this Mac Pro. So when I uninstalled the Blackmagic Desktop Video drivers, Premiere Pro ran flawlessly once again. When I reinstalled Desktop Video, I got the following results:

    11.1: issue persists
    11.0: issue persists
    10.11.4: issue persists
    10.11.2: issue FIXED

    So something broke somewhere…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. playback does not work

    Hallo everybody!

    The Playback does not start. I press the Playback button and the Icon changes (please see Attach file)but then nothing happens.

    13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Scroll timeline, not jump

    I think it would be much more useful if the timeline would scroll during playback, keeping the currently displayed frame in the center of the panel rather than having the timeline jump. It becomes very annoying when trying to edit video or audio when zoomed in all the way and the current frame jumps off the screen when you play back. Also the sliders are not very good. I think it would be more useful to have a zoom and a scrub slider. If the timeline is zoomed in all the way, and the project is more than a minute,…

    11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. FIX THE LAG!!

    Since the 2018 update playback has been LAGGING! I'm only editing 1080p files and those same files on this same computer were just fine before this new version. I'm seeing dozens of people online complaining of this same issue. FIX THIS!

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Update damaged playback

    Since update video does not play correctly. Audio plays properly.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Fix variable bitrate vods from audio desync and lag.

    I am a video editor that utilizes vods from websites like Twitch and produces daily video highlights on YouTube. For the past year my vods have had audio desync issues and playback lag consistently.

    The issue is to do with the fact they are in Variable Bitrate and are not Constant. The only workaround is to use a conversion tool such as handbrake to convert them from variable to constant. Given that the vods i use are hours in length this is not feasible.

    I cannot spend hours a day converting vods and i shouldn't have to. This needs to…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Problems with playback of file from Blackmagic Duplicator 4K

    We have stage shows recorded using the Blackmagic Duplicator 4K unit and I edit in Adobe Premiere Pro CC 2019 (13.0.2). The files recorded by the Blackmagic Duplicator are H.264 1080 with a data rate of 7.09 Mbit/s.

    Playback in PP 2019 is glitchy (see screen shot). The file plays back with no problems in QuickTime. I did not have this problem until I upgraded to PP 2019. When I open the exact same files in PP 2018 (still installed on the same system), I have no problem.

    When I open files recorded a year ago on the same Blackmagic…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Timeline Freezes during editing.

    My timeline freezes during editing, I would love a fix!

    8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. move "selection follows playhead" to general preferences

    move "selection follows playhead" to general preferences. That way it can stay on or off from project to project. For some reason it comes back on when using adjustment layers. very frustrating.

    23 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. color shift when paused

    Density shifts when paused vs playing.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. Playback Video out

    Is there a bug in hdmi output for playback. Even if you select mercury transmit, it still does not have the video output. In the 2018 version, also installed on macpro, it works normally.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Scrolling H264 4K (DJI, GH4, etc) in Finder is crazy fast but not in Premiere

    Playback and scrolling a 4K H264 video file in the finder is crazy fast. But import the same clip in Premiere and the scrolling is now painfully slow. Why?

    19 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Full screen bug while using multiple mixed resolution displays

    Address full-screen bug when using multiple displays with mixed resolutions.

    I'm using 3 monitors (two 1080p, one 4k as main) and there is a consistent bug when trying to apply full screen playback, where Premiere either places the image across multiple screens or prompts a n error (error: 76) which then freezes the Program Monitor image, requiring a restart.

    I am NOT using Windows scaling. Current work around is to set the 4k monitor resolution to 1080p. Premiere seems fine with 3 1080p monitors, but obviously the fancy 4k monitor looks terrible displaying a 1080 image.

    Thanks!

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. Panasonic GH5 8-bit 4:2:0 .mp4 footage 100mbps/sec does not play back well at all in the latest version of Adobe Premiere Pro

    Panasonic GH5 8-bit 4:2:0 .mp4 footage 100mbps/sec does not play back well at all in the latest version of Adobe Premiere Pro

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. BUG. Premiere pro showing proxies upside down

    See https://forums.adobe.com/message/10770519#10770519

    Very annoying but. In the latest PP version proxies are showing upside down, but they show the right way in every media player and even when imported as media the proxy show the right way in PP as well.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Preroll/postroll stopped working about 5 days ago. It's really slowing me down. Settings have not changed from default

    Preroll/postroll stopped working about 5 days ago, I'm not sure if CC updated, but it's not working and my settings haven't changed from default. It's really slowing me down.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. Mov Skipping Video

    While editing, the video jumps back to the beginning while the audio keeps playing as normal.

    using .mov shot on iPhone.

    only solution is to convert to mp4 using handbrake

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. Fix Variable Frame Rate Issues in an easy manner to use. Introuce a button.

    I would like Adobe Premiere Pro CC 2018 to have a button that you can press on any imported video from any format that is variable frame rate and lock it to a specific frame rate. I.e 30fps 60fps etc etc. Right now you have addressed it on the master video but sometimes is not there and can be diffcult to find ffmeg setting. Also the way i am suggesting is alot easier and alot of your users and fanbase and professionals would love you. Smartphones are going nowhere and its time this issue is addressed properly once and for…

    8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. In the latest update, 12.1.1, audio playback has become unreliable

    Often, audio tracks will not play as video plays.

    The issue can be solved by muting and then unmuting or soloing and then unsoloing channels. The problem is only present on playback, not on export.

    13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Threadripper + GTX 1080ti = Garbage playback

    Can someone from adobe tell me why I can't playback simple 1080p footage in premiere with a GTX 1080 ti installed but if i swap it for an HD 5870 it can?

    System : 1950x thread ripper , 64gb ram , GTX 1080ti / HD 5870, 2 SSD and network drive,

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base