Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. bug premiere pro 2020

    bug report on premiere pro 2020: playback stop while playing on timeline and then display message: "A low-level excerption occurred in: Adobe Player (Player:11)" - then Premiere crash, and i have to force quit from force quit application. i'm working on a MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports), 3,5 GHz Intel Core i7,

    318 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    240 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    We do monitor User Voice; we share your disappointment that we don’t have a reproducible case, for this issue.

    If you can reliably reproduce the ‘low level exception’ problem, on your system, please contact Support and provide them with any files and source media required for that repro case, as well as (important!) step-by-step instructions on how you can reproduce the issue.

    We’re eager to pursue the issue further.

  2. Bug Report: Speed Issues in Premiere 2020

    Any speed change that brings a clip over 100% speed results in choppy playback.

    79 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    75 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  3. Speedramp in Premiere Pro 2020 is a mess

    Speedramping in Premiere cc 2020 let my eyes bleed like ****.
    No smooth, but cruel lagging while playbacking the speedramped clip.
    The rendered file however is fine.

    Fix that as soon as possible, before I went out of blood.
    Thanks

    65 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    19 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  4. Bug PP 2020 Interpret Frame Rate results in scrubbing errors

    On files where I change frame rate via "modify/interpret footage" resulting clips have errors while scrubbing on the timeline (skipping back and forth in file). If I simply change the speed via the speed setting on the timeline, the file scrubs fine. Any ideas? I made a video where I tried to show this happening:

    https://youtu.be/MjEDyjPbZUg

    Windows 10

    CC2020 14.1.0

    RTX2070 super 442.92 studio driver

    12 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  5. Scrubbing issues - Showing incorrect portion of footage

    I am having series scrubbing issues after interpreting footage.

    When I interpret 8bit .mov 60fps clips to 24fps from the GH5, the footage becomes completely useless. I can no longer scrub the footage and see the actual portion of the clip. The viewfinder shows the incorrect frame. Also, speed ramping interpreted footage completely breaks the clip and it no longer plays back successfully. I have to delete and then reimport the clip.

    11 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  6. Wrong part of clip showing while scrubbing interpreted footage

    While scrubbing through footage in the source panel that I have interpreted from 60fps to 24fps, the preview image on the source panel doesn't align with my actual location in the clip. This makes it virtually impossible to scrub through footage and set in and out points.

    This is version 14.3.2. I don't remember this ever happening with earlier versions.

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  7. Playback issues using 4k videos

    I'm having issues playing clips that are in 4k formats. I'm able to play the videos on my laptop just fine but once I put them in Premier Pro there's a huge lag. I tried creating Proxies for the videos and it didn't work. I also tried lowering the resolution and that didn't work also. I was able to edit 4k videos on the previous version but ever since I updated the app I have not been able to playback the videos properly.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  8. Reverse play keeps playing after I stop it with K key.

    This is a new bug in this version. When using reverse play using the "J" key, playback keeps going for 2-3 seconds after I hit the "K" key to pause it. I have not noticed this before, and I have the same hardware as before.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  9. 2020 scrubbing issues

    bug report on premiere pro 2020 running on Catalina: almost every time I use the J key for reverse playback Premiere freezes or starts scrubbing at random on the timeline.

    12 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  10. Premiere losing renders

    So this has happened about 4 times on a feature concert film for me. I leave the renders going overnight, in this case, 8 lines of video, 5 are .braw. I save and quit. Reopen Premiere Pro. About half of the clips remain green, the others are yellow again. And with the new stabilize bug in 2020, the frame goes all crazy shifted to the upper left until it's rendered. And the .braw raw tab doesn't work with the offical blackmagic plugin and premiere. Hmm. This is 3 bugs in one post.

    Send help.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  11. Latest 2020 Update results choppy playback

    Since I updated the latest version, playback has been very choppy even for a 1080p footage and timeline. I'm using a 8 core i9 9900k CPU with 64GB RAM.

    I have never faced this issues even with 4k footages for a 2 hours feature film timeline editing. It's very frustrating that Adobe did not provide 'Save As' to previous versions to at least be able to open the projects and 2019 or other previous versions.

    In addition, the Lumetri Colour panels are also showing errors 'AEFilter:14' very frequently. I have never run to such issues. I am not experiencing this…

    29 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  12. 3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  13. Return playback head to the point it started when stopping like every other NLE and DAW

    Why is there no simple option to change the playback behaviour to return to the start point in PP? Eg. Play from 1.33, stop, playhead returns to 1.33. This is in every other NLE and DAW and I'm tempted to move to Resolve full time purely for this one feature for my workflow. I don't want to use convoluted preroll options and IN OUT points every single time. PP is still so clunky to edit in even after all these years.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  14. AUDIO VIDEO OUT OF SYNC

    Audio and Video out of sync when played back in H264. Tried re installing Premiere Pro, re-installed Video Drivers, created new project with out success. These have synced perfectly for the last 2 years, what is causing this sync problem.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  15. BUG report version 14.4.0


    1. Loose control over playback after playing video clip in reverse.

    2. Premiere "not responding" after adding Red Giant Denoiser III on top of Lumetri

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Needs More Info  ·  1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  16. Major Bug With Speed Ramping

    There is a major issue with Speed Ramping in the latest version of Premiere Pro 2020. I am unable to play back a simple clip that has a speed ramp applied to it in real time without pre-rendering it. When trying to playback a clip that is speed ramped, it turns into a glitchy mess, and the remaining clips that follow never start playing as they should unless I pause and restart the playback. This was never an issue in Premiere Pro 2019. I have re-downloaded PP2019 where the issue is no longer present.

    I have found that it seems…

    12 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  17. Brand new Premiere Pro stuck at playback stop while playing on timeline and then it need wait for a long time.

    Brand new Premiere Pro stuck at playback stop while playing on timeline and then it need wait for a long time. How come? I cannot edit with Premiere Pro right now. Please help me quickly. I need edit every day. I'm almost crazy to say something bad words.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  18. third party bulk renaming utility

    I've been having problems reconnecting full res to all of my proxy files. I'd like to do it all at once instead of individually (Too many clips).... this is what I've been told, " I'd like to inform you that there's no specific feature in Premiere Pro regarding this yet. There's a workaround, You'd have to keep the folder structure and file locations and structure the same for both proxies and original files. Then you'd have to rename all the proxy files to have the exact same names as the original files though they would be in separate folders. This…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  19. Speed remapping >799% does not work

    Has anyone gotten anywhere on this known glitch? I can't believe we're the majority of the way through 2020 and I still can't update to 2020 because of this one asinine malfunction that they refuse to fix.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  20. Stabilizer must now be rendered to view

    Hi again//

    When using Warp Stabilizer, I apply the effect to the clip. It analyzes, stabilizes. Then when I hit playback, the picture snaps up into the top left quarter of the frame. Only when I render the clip does it play back normally.

    This is fresh to PP2020.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 18 19
  • Don't see your idea?

Feedback and Knowledge Base