Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. BUG: Toggling away from app and back again crashes Premiere / stops preview working first

    Latest Premiere, latest Nvidia Studio drivers 1070Ti founders x2 / Xeon 2867v2 x2
    Decklink 4KExtreme 12G - latest drivers
    Rednet PCIe dante card - ASIO
    Asus Hyperdrive 4x Corsair 960GB MP510 in RAID 0

    Pro Res HD footage, any footage

    Premiere is now unuseable as the monent I switch apps video no longer plays and shortly after the app crashes
    trashing preferences and reinstalling does not help

    Worked fine until yesterday
    Possible causes?
    installed NDI 5?
    removed second monitor>

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. MPEG2 MXF and M2T slow opening

    Whenever I open a project that has any MPEG 2 assets (in the form of HDCAM-type MXF files or M2T files from a Sony camcorder), all the footage sits in a "Media Pending" mode for the same amount of time as it did the first time they were imported. Now on-screen, no status is given about what is happening, but the HDD is quite busy and appears to be re-indexing the footage. Any ideas why this is happening?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Fix Audio Previews/Rendering

    Currently, Premiere Pro has no indicator for audio rendering, and appears to render all audio prior to starting playback, causing lag spikes upwards of 20s with a large multi-track file.

    This would be okay, if somewhat annoying, if Premiere actually cached and retained this audio after this first time. However, that is not the case. Premiere does not cache the audio to disk, and will discard all of it immediately if you so much as click out of the program for half a second, causing another 20s lag spike before you can start playback again.

    Additionally, people have reported related…

    16 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Slow timeline performance with essential graphics

    There seems to be a significant amount of dropped frames when playing back a timeline that has essential graphics overlays. Drops down to maybe 1-5 FPS, and doesn't recover until you pause and play the timeline again (even after the graphics have ended)

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Fix captions! After the recent update captions are now working POORER than before - how is this possible?

    When I put a new caption behind the recent one, the caption I just made disappeares and turns into "New Caption".

    How can this happen??

    This error makes it impossible to work with the captions-flow. It simply does not work anymore. Unless you keep retyping the same text again and again, because the Premiere deletes it.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Fix the issue with Essential graphics please!

    The Adobe Stock 'free' items are returning errors that I don't hold enough licenses, or there is an error while downloading from the adobe stock library. Please fix!! I've been using this on a daily basis.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Slow timeline performance on mismatched frame rate timeline PrPro v22.0.0.44 beta

    When importing H.264 MP4 source media into a sequence that has a different frame rate than the source footage, playback at full resolution slows to a halt. When switching to 1/2 res, the footage plays back fine. When setting the sequence to match the frame rate of the source, the timeline plays back fine even after setting the sequence back to a different frame rate. It seems to me timeline performance will only be acceptable when source media is imported into a sequence that matches the frame rate and played back before changing the frame rate back to another value.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Slow scrolling with project media in Icon View v22.0.0 beta 34

    When scrolling in Icon View in the Project panel with a lot of media loaded, as the thumbnails for each video clip is loaded, scrolling slows to a halt. This seems to occur mainly with inter-frame compresses codecs, but still occurs with codecs like ProRes, only less severe. Any chance this performance issue can be solved or minimized?

    My projects suffer from this the worst on both Windows and Mac with a large amount of H.264 MP4 files while the thumbnails load in for the first time after opening a project. On Windows, sometimes it is so severe that the…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. LUT "Intensity" toggle not working

    About 80% of the time when I make an adjustment layer and add a LUT to it, when I change the intensity from the Creative section, nothing happens. Please fix!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Program not loading past SlicerStutter.prm and stops responding

    Since I updated to Premiere Pro 14.9 and Windows 10 20H2, premiere pro won't load past SlicerStutter.prm and stop responding. I have to end the process.

    I can "fix" the problem when I install Premiere Pro 14.7, but is doesn't work every time and I have to unistall / install several times to make it work.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. DirectX 12 Support

    With windows 11, please add support to directX 12.
    The openCL in AMD GPU is obsolete

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Premiere Pro 2021 taking several minutes to load media

    Prior to the Ver 15 release, my project would load very quickly. After the update, my project takes several minutes to load. I have tried two different iMacs, a brand new Mac Mini, and two different hard drives for the media. I have created a new project from scratch with new media. I suspect the issue involves the closed caption tracks and the new closed caption workflow. I capture my footage live and it has embedded closed captions that I need. Each show is between 1 minute and 5 minutes so nothing huge. After the project loads, it works fine.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Check both Premiere and Media Encoder render times and performance compared to 14.3.2

    Many users realised that render times both in Pemiere and Media encoder changed due to the new render system implemented in versions newer than 14.3.2.

    In fact, this is the version in which everything works fine for me in render times. Even proxies render much slower than before (the format doesn't matter).

    I have tried every new version (even 14.5) and the problem is not solved. I use Premiere for years and I have checked every file in my system, formated, and so on... and nothing!

    It is not a hardware nor drivers issue. It is a new render system…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. my application freeze everytime I scroll in the timeline, and stop to freeze when the little pictures in the timeline appears

    my application freeze everytime I scroll in the timeline, and stop to freeze when the little pictures in the timeline appears.
    It's so hard to find somethink we looking for in the timeline with this issue...

    My PC :
    Ryzen 7 2700
    msi b450 gaming plus max
    32 Go 32000Mhz
    1660 super OC
    W10
    EDIT on CRUXIAL X8 SSD

    Thanks !

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. BUG: Sequence with nested sequence "visible in timeline" gives multiple problems

    Premiere 15.1.0 Windows 10 pro

    Whenever I have a nested sequence visible in my timeline PPro just doesn't react for a while. It seems that it is fully calculating what is in the nested sequence, even if the playhead isn't over the nested sequence.
    When I zoom in far enough in the timeline so the nested sequence is not visible, the problem goes away.
    When the nested sequence is visible in the timeline, scrubbing thumbnails in the project panel is not possible anymore. Also, rearranging clips in the timeline is a horror unless you zoom in really close in the…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Thumbnails glitching in Project Window

    At the moment, creating a new bin while viewing files as large thumbnails I am unable to rename / name the bin at all. Additionally, I cannot re-order them other than clicking them to a grid. It would be nice for them to fill the size of the window in which I'm viewing them. Lastly, files are associating with differently named files and file types. I have deleted a jpeg that has somehow become associated with a mov file.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. Replace with after effects composition issue

    Different final (transparency object) opacity in Premiere Pro, when using "replace with after effects composition" function. e.g. 80% opacity in After Effects looks like 60% or even 40% in Premiere Pro. A bug that has been around for years.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. STATIC AND COLORED GRAIN AFTER 10 MINS

    After a while of running premiere pro my footage in preview when I hit play becomes staticky, grainy and becomes extremely colorful. This started happening as of the new update. After about ten minutes it starts to happen. I simply close the program and re open it and its fixed for a while. But it gets annoying when editing a long video... help or fix this please.. clips attached... just started a stoopid edit, dont judge XD

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Captions improvements

    I like how the captions has its own section, and it has a lot more features that make it easy to adjust and look just they you wanted. It works great when importing SRT files.

    I do however have some issues when do it within premiere pro. When you add captions the playhead moves to the start of the caption, and then you have to move the playhead to create a new caption. When creating 15-20 captions that becomes time consuming.

    There also seem to be some problems when you have the last caption. It is almost impossible to edit.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Renders MIA after 24hrs

    Something always baffles me.
    Why is it I can render something (e.g. Render in to out) and my timeline indicates green. And the payback is fine. And the export is great (and fast). But the next day after I power-up and open the project my timeline is once again dappled with red & yellow sections?

    Why does PP lose track of the renders?
    In an Avid MC system once I render it, it’s done forever - unless I change a parameter or delete the media myself.
    So I find the unprovoked disappearance of rendered files not annoy annoying but terrifying.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base