Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Creating Proxies for 120p footage creates 60p proxies?!

    I have footage filmed at 120p, 60p and 24p in a sequence. They are all HEVC 10 bit 422 so naturally, the computer is having trouble playing them back, so I waited all night for Premiere to create proxies. It worked fine for the 24p, did that automatically. Did fine for the 60p, did that automatically. However, for the 120p footage, it ignored that it's 120p and just created a bunch of 60p footage, so when I turn on the proxy, it jumps to different areas because the actual footage is 120p!!

    Obviously this is a problem since it means…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  2. Possible Bug? - Audio corrupted after auto-converting project file post upgrade v14.x>v15.x - Tested/verified on two machines/OS's

    Issue: Opened original, previously edited/arranged project file (created September 2020, v14.x) to add graphics. Using Mojave on a late-2015 iMac, PrPro is up to date, v15.2 and prompts to auto-convert the project file. Upon completion, the audio tracks for all clips are corrupted, only outputting noise pinned to around -3dB. The audio waveforms looked as expected, however. I tested and verified this issue again on my Win10 machine.

    Workaround: First I attempted a "Save As" and copy over the sequence etc. but no luck. So, I rolled back the install, or rather installed an older version (v14.9 LT Support) alongside…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  3. Bug: Premiere Pro 2020, copy/paste clip from one timeline to another crashes program

    Created new project in 2020 (14.6), imported bins and timelines from 2019 project via Media Browser. Copy paste clip from one timeline into another (with same settings - 1080p 23.976 Pro Res) crashes program. As you might imagine, this renders PP 2020 useless for me. Working in 2019 for now.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  4. Non Responsive App using Dynamic Link

    When I press replace composition with after effects the application will open AE and become non-responsive until forced quit. Even when I created a project in AE premiere pro still stayed non-responsive. Even after I finished my edit, saved, premiere pro is still non-responsive making the dynamic link currently useless.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. Delayed or unresponsive

    Whenever I'm in a project, everything (except the editor and probably the file storage space) will either delay its task(s) or become completely unresponsive.

    Computer: ASUS TUF
    Maximum pixels: 64-bit
    Processor: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx (2.10 GHz)
    RAM: 32 GB

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  6. Fix frame rate drop and lag

    Since the update of 14.7, there has been a significant frame rate drop and lag in the way the program runs, forcing it to be almost impossible to do anything with the program. Tried reverting back to old versions and had the same issue. Never had it come up before the 14.7 update

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  7. You know what would be really nice? A 'SAVE' function that functioned.

    I have auto save triggering every few minutes which reminds me to manually save. I just finished about 30-40 minutes of work using this workflow. Nothing saved. Not the auto save nor the manual saves.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  8. please be better

    learn from Nokia failure

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  9. 4K 32" MONITOR'S, LAZY - PREMIERE PRO

    What a wonderful forum,
    We are glad that Adobe is listening ...
    I'm working on a 2x32"4K monitor and I'm interested in why the GUI of Ppro is so slow and lazy ... I'm watching Davinci resolve ... Avid ... the windows open instantly. .. in Premiere when I click on the "preferences" option for the first time after starting Premiere it takes 5sec for a window to appear - everything is kind of sluggish and it looks like it's not in real time ... whether it's up to win 10 or up to Premiere. .. great program, I've been…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  10. Please improve dual monitor support

    Currently when using two monitors on IOS, clips, titles, and other timeline material will not copy from one project to another. Never had this problem with older versions. Extremely frustrating and time-consuming.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  11. Fix the serious crashing bugs on 14.7 and remove the current version from download access

    Fix the serious crashing bugs on 14.7 and remove the current version from download access

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  12. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  13. AMD Driver hang bug

    Premier, After Effects and Media Encoder are causing driver hangs, either locking up the whole system causing it to crash and reboot, or at the very least causing the export to fail.

    The issue seems to be with H264 encoding / acceleration, as if I export
    to mov, the issue happens considerably less frequently. Whereas it is impossible to export to H624 currently.

    Within the timeline, it seems to be affected most by transparent regions (such as drop shadows etc), and masked sections. It will hang, cause the system to hang too, and then will either return to a non…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  14. scale not working with keyframes

    how are you going to release a new update with a bug that causes scale not to work whilst charging us more and more for your unstable products each year

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  15. In premiere 14.5.0, I'm not able to move items in a floating bin.

    There's a bug that needs fixing. I'm not able to move items in a floating bin in version 14.5.0

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  16. Better optimization for the speeding up of clips

    I think you guys should look into optimization for the speeding up of 4K60 clips. Even with powerhouse machines with top specs over 4x speed up lags badly in playback. Whereas even on an iPad Pro with Luma Fusion or Videoleap, one can speed up clips up to and over 5x with 0 lag, in playback and no issues with the timeline. If this isn't a bug issue, you guys must consider going in an optimizing this.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  17. Automate to Sequence doesn't work with 6 frames or less on still image

    I work in animation and we use automate to sequence a lot. BUT I've discovered that if your still image is 6 frames or less, it leaves a gap of one frame between the markers. So I imported the image at 30 frames BUT in the timeline if the image is only six frames or less, it leaves a one frame gap between markers. PLEASE FIX because I deal with over 1000 images per episode that I work on.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  18. Recieving a message on Mac knocks audio playback offline in latest Adobe update

    When I get an email or message notification on my Mac while I am editing, the audio cuts out in Premiere Pro. Sometimes for like 30 seconds.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  19. My app keeps crashing and not allowing me to edit.

    The only panel that seems to work is where you can watch the video back. I am unable to edit, add new media, etc.

    The only way for me to fix this is by uninstalling and reinstalling. Is there anything i can do to prevent the issues from happening

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  20. HDR Hardware Acceleration

    I chose adobe specifically to import and export HDR content, not knowing that I wouldn't be able to use my 3080 to encode. Should have gotten Resolve apparently. There was no reason for me to subscribe to this software other than HDR encoding, which I can't use as I can't wait twelve hours with maxed out CPU usage to make a video. Ridiculous. Fix it.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base