Skip to content

Premiere Pro

ANNOUNCEMENT - This forum is moving


In an effort to improve communications between you and the Premiere Pro team, we are moving this feedback forum to the Premiere Pro page on the Adobe Support Community. As requested, bugs and feature requests will be able to live separately in that forum.

This move is happening in part to acknowledge that we haven't been responsive enough here, and we are combining our forums to help remedy that. Ideas and their attached comments from this UserVoice forum will be migrated based on how many people voted for them. Check your profile on the Adobe Support Community to see any migrated posts that you've created or commented on. If you have an item here that did not make the migration, please bring it over to our new home.

See you soon on the Adobe Support Forum!

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback

177 results found

  1. Use Discrete instead of Integratde GPUs on prebuilts

    Premiere Pro by default utilizes GPU0 on computers. However, in most prebuilts that include a discrete GPU as an extra, GPU0 is integrated graphics, and there is no way to make Premiere use the discrete graphics short of disabling the integrated graphics in device manager, which means one cannot use the iGPU for a different purpose at the same time.

    21 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Adobe should make its own Video Cards

    Please start to make your own video cards so that those of us who use our computers primarily for work can stop going back and forth with video card issues made by other manufacturers.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Add GeForce GTX 1070 (mobile) to the list of supported cards

    Add GeForce GTX 1070 (mobile) to the list of supported cards, please.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. 16 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Options for which graphics chipset is used for CUDA mercury engine

    Please give an option to chose which graphics chipset is used by premiere as on my laptop it defaults to the Intel integrated rather than the discreet Nvidia GTX1060.

    Please see this thread for further explanations of the issue.

    https://forums.adobe.com/thread/2411343

    Thanks!

    9 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. GPU Bug - This effect requires GPU Acceleration - but it doesn't earlier in the sequence?!

    In follow up to the long standing topic forum at https://forums.adobe.com/thread/2397134 I'm having this as a different error. For some reason I can only use so much GPU time it would seem.
    Can this be investigated please?

    Here's a new angle to this issue. I'm on latest everything BTW. I can use a VR Mobius Zoom at the beginning 30 seconds and VR Plane to Sphere elsewhere in my sequence beautifully. However, for some unknown reason, I can't use any VR effect in the last 10 seconds of the sequence. What?

    I'm getting the Red Band of Death on both…

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. 2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Congratulations on your new update - I cant work anymore!

    Since CUDA support is only granted for High Sierra and I work on a render machine with a Geforce GTX Titan X but the machine is a Mac Pro 2009 and High Sierra is only installable through a workaround its not possible to work anymore. You stealing hours and hours of my time with your updates that are bugging everybody in all the programs you supply and now you make it impossible to do my job! Thank you so much - clients are super happy about that - NO LOVE

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Premiere doesn't gracefully switch from OpenCL to CUDA

    I use a laptop with an iGPU on the go, and an eGPU at the office. On the past few versions, (12.1.2 included), if I open a project that was set as CUDA with no eGPU, it gracefully switches it to OpenCL. But if I save it as OpenCL, and then open it again with my eGPU attached, Premiere instantly crashes. The only solution is to disconnect the eGPU, open the project ans save as software only rendering, and then open it again with the eGPU attached. Then I can switch to CUDA again and carry on editing

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Illustrator accepts the Card for GPU Usage - Indesign does not ????

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Illustrator accepts the Card for GPU Usage - Indesign does not ????

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Premiere Pro and Media Encoder limiting video memory speed on an RTX 2070 card

    I installed a new graphics card recently, an EVGA RTX 2070, and noticed in GPU-Z that the effective memory speed of the card is always 50 MHz lower than it should be (400 MHz effective clock). As soon as I close both programs the speed jumps up to it's regular value. Bug or some unknown feature?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Rendering and Playback setup

    I am using adobe premiere pro cc. At project setting screen it only allow me use mercury playback engine software only. I couldn't select my hardware GPU for rendering and playback. do anyone know the reason?Thank you all in advance!

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. BUG: CUDA

    This was driving me nuts. Premiere throws a "This effect requires GPU acceleration", even though I have a sweet graphics card and Mercury is ON. Turns out it's when you add an effect to an ADJUSTMENT LAYER.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Vega8: GPU not used since GPUSniffer only detects 1GB fixed shared memory

    With AMD's new APUs like the 2500U come quite powerful integrated GPUs like the Vega8. Some OEMs configure a "fixed" shared memory of 1GB, but also allow for 7GB of flexible shared memory on top of this (HP Envy 13 x360). However, Premiere Pro (and AME) only detect the fixed 1GB chunk of memory and decide not to use the GPU for rendering e.g. Lumetri Color, even though Mercury w/ OpenCL is selectable and selected.

    For reference, Intel GPUs like the UHD620 with no "fixed" shared memory and only a flexible 4GB area work fine.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. PPRo and Encore are slow compared to other apps

    We need premier pro and encore to use more than one gpu whole performance has been slowing down the past three years adobe was fastest now not so much need support for multiple Graphics cards

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. 50 fps clips on 25 fps timeline slow motion (CUDA)

    Windows 10 x64. 1607 ltsb.
    Premiere Pro 12.1.2.
    50 fps GH5 clips on 25 fps timeline.

    When I use GPU (CUDA) in project settings and If I change clip speed to 50%, I don't get a slo mo. When I change GPU to Software only everything is fine.

    DNxHR files are fine in both situations. This issue is only with GH5 clips.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. I dont know why Integrated GPU in Macbook pro are not supported as open CL for GPU processing. In high sierra its showing Hardware accelerat

    I don't know why Integrated GPU in Macbook pro(intel hd4000) are not supported for GPU processing. In high sierra Hardware acceleration is being used to export H264. Please help other owners of adobe premiere pro to use intel integrated GPUs.

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Crashes GPU as soon as any footage gets shown

    As soon as I load any footage into the viewer, my GPU crashes (goes black, shows random stuff, then displays an error message from the graphics driver).
    I'm on a windows machine, I have a mobile Quadro P4000.

    There is a "workaround" though. Installing the driver EVERYF***NGTIME before using Premiere (this seems to "reset" something). After a reboot, everything is to "instantly crash" again.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Bug with Intel HD Graphics 520 driver

    Premiere Pro CC 2019 has a bug with Intel HD Graphics 520 driver (v25.20.100.6326). Whether it is the ellipse mask, 4-point polygon mask, or free draw Bezier mask, the path does not show in the Program Monitor Window. Toggling on/off the Mercury Playback Engine will temporary show the path but only once. Then have to toggle again.
    Please fix it.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Hardware  ·  Flag idea as inappropriate…  ·  Admin →
    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base