Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. 7 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  2. MacOS: Improve / FIX Multiple GPU Support in Premiere

    Multiple GPUs in Premiere are technically supported, but they are not utilized properly.

    Need a way to prioritize which GPU should be used "first" or a ranking method where you run an app/command and the software learns which one should be ranked first.

    An iMac 27" (iMac19,1) with AMD Vega 48 dGPU and eGPU connected will utilize the eGPU when it is present.

    However an AMD 5700 XT eGPU should only be a supplement since the internal Vega 48 is much better for hardware encoding on export, but it is barely utilized at all - less than 5-10% on GPU…

    4 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  3. Support ProRes RAW on AMD GPUs

    Hi Team,

    I think it would be fair to all Premiere Pro users (and buyers) whom own AMD graphic cards to get support for ProRes RAW on Windows as it's now supported only on NVIDIA cards in Windows.

    Thanks

    3 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Radeon 5500 XT 8 Go GDDR6 on iMac 27'' 2020

    Hi, could check if the new iMac 27" will work fine with GPU Radeon Pro 5500 XT 8 Go ? It's not in the recommended graphic cards tested by ADOBE, but it's on the latest iMac 27 top level. Thanks.

    3 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  5. Add support for Amd 5000 series GPUs

    The 5700 and 5700xt have been sold well. However there is still no support for in Premiere Pro and After Effects.

    Same counts for the Nvidia 20 Super Series, which has no official support according to the Adobe pages.

    2 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  6. Possible Bug with Exporting Mogrts Using Latest P6000 Video Card Driver

    I’m flagging up a problem with a recent NVIDIA update for anyone that is experiencing export problems.


    1. I’m using PPr/ Me 14.7 and Ae 17.5, running on an Intel Xenon w-2123 (3.60GHz) CPU and a Quadro P6000.


    2. I updated my Quadro driver from 460.89 to v 461.09 at the start of the week. Editing after on PPr was untroubled. I also made a couple of basic new Mogrts in Ae.


    3. All was fine for a day or so until I exported a project via Me that included one of the new mogrts made since updating my Quadro. The export hung…

    1 vote
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  7. GPU Acceleration has a bug

    For unknown reasons, Premiere Pro occasionally drops CUDA GPU acceleration during edit sessions, blacking out video playback. Switching to "software only" is not a fix — just an added inconvenience. The problem can be rectified by restarting Premiere with CUDA acceleration selected. Everything is fine until the next time it happens, once or more times a day, sometimes a few days without incident, regardless of the project. When active, CUDA acceleration works perfectly. Has anyone found a real solution?

    Windows 10 1909, build 18363.1198, 64-bit

    Premiere Pro 14.6

    AMD Ryzen Threadripper 1950X, 16 core, 64GB RAM

    2 x Nvidia GTX…

    2 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  8. AMD Radeon Pro GPU Support

    Hey Adobe team,

    I know you guys use NVIDIA Cards a lot for your GPU optimization, but those of us on the Mac system are really feeling left out. Would be great to have GPU support for AMD as well as NVIDIA. A lot of people use Mac, so I think this would help a great deal of people.

    Would love something along the equivalent of NVIDIA's CUDA support, but for AMD. Even a little love on that front would be great!

    2 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Metal Engine always renders 8 Bit

    have a MacPro 2019 (7,1) with two Vega II graphics with Premiere 14.5 on a Catalina 10.15.7
    I have 10 bit video files and while working with these files I see a lot of banding on the sky.
    I have tried different configs to understand the issue.
    My sequence settings use Maximum Bit Depth.
    When the Metal engine is ON, there is no diffrence with the OFF state at the Program Monitor.
    And when I render with the Maximum Depth / 16bpc the output is same, a lot of banding.
    But When I swicth my project settings to openCL. I…

    2 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Bug: video and audio are not synchronized

    when using AMD GPU with the latest ME & PR version 14.5
    update: the problem is still in the new 14.7 version. plz compare the two videos I uploaded.

    1 vote
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Premiere fill my GPU memory and cause black screen preview

    Premiere fill my GPU memory and cause black screen preview, i see in the task manager, sadly my GPU GTX 750 have only 2GB of RAM.

    1 vote
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  12. Rolling Title GPU Acceleration Broken

    After spending all day testing and troubleshooting I have finally determined that the GPU Acceleration for Rolling titles is broken.

    I have 10 machines with 24 cores, 128GB ram and RTX 2080TI video cards running windows 10, latest premiere version with latest Nvidia studio drivers., SSD drives and 16GB fibre channel storage.

    I finally narrowed things down to a simple test and shot a little video of my screen so there would be no conflict with any screen capture software.

    If you make a 9 line rolling text everything works just fine, but when you add the 10th line the…

    1 vote
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  13. hardware acceleration

    enable hardware acceleration on GTX 1660 or offer another hardware acceleration system than CUDA that doesn't support all graphics cards

    2 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Support MacBook Pro 2020 GPUs

    Why does Premiere Pro not support the actually used GPUs of the 2020 MacBooks like the AMD Radeon 5300M?

    I really don’t get it.
    I mean, the monthly fee for using the program is fair enough, but than I‘d expect to be able to use the full potential of an up to date MacBook Pro.

    For me, if Adobe will not include the actual GPUs, it would be a reason to switch over to Final Cut or Avid.

    3 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  15. CUDA Acceleration Displaying INCORRECT FRAMES

    Hello,

    I've now realized how many problems related to premiere have stemmed from GPU CUDA Acceleration, one of which being premiere displaying incorrect frames with both playback and scrubbing. In fact, it even shows the wrong portion of the entire clip, so all of my masking effects are out of place and make no sense. When I turn on Software Encoding, everything works fine but it's all at a snail-paced editing speed. I'm editing a music video and I have a lot of effects that require GPU Acceleration (along with a lot of speed ramping), so please please PLEASE Adobe…

    2 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  16. Please Improve Metal Support in macOS

    Metal support in Premiere Pro 2020 is currently very bad. On a Radeon VII under macOS Catalina, I'm seeing encode times from a ProRes 4444 timeline to ProRes HQ output taking 45-50 minutes for a 4-minute piece. That same piece encoded in under 10-minutes using OpenCL. Additionally, native Adobe plugins that work fine in OpenCL give a red banner CPU warning under Metal. There is no RED SDK support either. Clearly Metal render support needs work, especially if OpenCL is being deprecated. Please improve Metal support under macOS in Premiere Pro and across all professional media creation applications. Thanks.

    13 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Include GPU in more calculations.

    When cutting videos in 4K, I can't watch the video smoothly because the CPU does all the rendering work and the GPU does nothing. And I want Adobe to improve that the GPU does more with rendering and cutting.

    8 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  18. A low-level exeption occurred in: Adobe Player <Player:5) after todays update in Win 10.

    A low-level exeption occurred in: Adobe Player <Player:5) win10 - now no preview!

    5 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  19. Premiere Lumetri curves is hugely corrupted with new nvidia driver, my gpu is 1070 ti

    pretty much the title, it's not a idea, it's just that when using curves in Lumetri in my footage the result gets fully corrupted and broken, with some weird white squares.

    When rendering only in CPU this is solved, but preview time gets hugeeely slower

    when downgrading the driver the issue is also solved, but this isn't a optimal solution since it's best for every other application and even premiere to have the most updated drives. I attached a image file showing how this glitch looks

    3 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  20. OpenCL mishandles jpg files with embedded ICC profile

    When using OpenCL to help generate video in Premiere Pro and Encoder, jpg images with embedded ICC profiles display distorted, both in preview and in the final render. Generating the same jpg without the ICC profile with Photoshop ensures it's rendered correctly.

    System: AMD Ryzen 3700X, RX 5700 XT (latest drivers as of 26.11.19)
    OS: Windows 10 Pro, 10.0.18.362
    Adobe software: Media Encoder 14.0, Premiere Pro 14.0

    13 votes
    Sign in Sign in with: Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 6 7
  • Don't see your idea?

Feedback and Knowledge Base