Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Put red in the center of Lumetri curves, not cyan. That would make it easier to adjust skin tones.

    For the Lumetri Color Effect’s curves controls (Hue vs Sat, Hue vs Hue, and Hue vs Luma), cyan is in the center, while red is on the far left and right sides. This is inconvenient, because most users will probably want to adjust skin tones more than anything else, and skin tones are almost always somewhere in the reds and yellows. Therefore, I propose that red be in the center by default, while cyan is on the edges.
    NOTE: Because a horizontal scroll bar is already available, it is possible for the user to essentially do this themselves... but because…

    337 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Under Review  ·  25 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  2. BUG* Lumetri curves adjustment causing blocky artifacts with Nvidia studio drivers

    BUG REPORT* White blocky artifacts cover screen when using curves under lumetri panel (Premier and After Effects latest build. (14.3.0 & 17.1.1) This is when utilizing Mercury playback engine. Using 1080 ti and latest several Nividia studio and game ready drivers have caused this issue. Current studio driver I'm using is 451.48. Using an older game ready driver does not cause this issue. I have noticed most of lumetri will process the color fine, but the curves adjustment will not process correctly, resulting in the results you see below.

    45 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    21 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  3. RAW to LOG conversions for ProRes RAW

    ProRes RAW has been implemented inside of Premiere now but it is cumbersome. My workflow remains the same as before support has been added where I need to conform my footage to LOG inside of FCPX and then import that to Premiere. This makes all the work that went into implementing ProRes RAW into Premiere useless to me because I still have the same workflow as before.

    I am suggesting taking an approach like FCPX where in the clip options there be a selector for “RAW to LOG Conversion” that allows you to conform the linear footage that ProRes RAW…

    15 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  4. LUT playback problem

    When i use a 64 grid ponits LUT in versions 14.3.2 and 14.4, the playback is laggy. For a smooth playback in these versions, i must convert all my LUTs from 64 to 32 grid points.

    Please fix this bug.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  5. Masterclip LUTs intermittently stop displaying

    We use a lot of Amira footage and normally the LogC-to-Rec709 camera LUT is automatically applied by Premiere Pro as a masterclip effect by default. Problem is when I reopen the project the LUTs do not show up - I can see them in the masterclip lumetri effect has the embeded Amira LUT in the creative tab , but the effect doesn't do anything if i turn it on or off - and there isnt a way to get access to that embeded LUT any other way.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  6. Visual cue to know which parts of a Lumetri effect have already been modified

    When going back to a clip to adjust its Lumetri settings, there's no way to know which of the 6 categories or 6 subcategories have been previously adjusted, short of twirling them open one by one to see if anything has been changed. The lack of a visual indicator to show which categories have been adjusted is especially frustrating when working on a clip that has several instances of Lumetri. For example, if a user adjusted 'Curves' on a third instance of Lumetri, the user might end up twirling open and visually inspecting the 'Curves' category of all three Lumetri…

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  7. Lumetri Color Wheels, Glitches/Artifacts BUG

    Bug

    I noticed glitches and artifacts after updating to Premiere Pro v14.3.0.
    After disabling Lumetri Color Wheels glitches disappeared.

    Im running Windows 10 Pro 2004
    Ryzen 3900x
    geforce 1080ti (451.48)

    5 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  8. BUG[2020]: Lumetri Scopes panel empty / blank ...

    BUG[2020]: Lumetri Scopes panel empty / blank ...

    https://gyazo.com/c7cbb49ac17ee1b75dfb593395b290ef

    Nothing showing when selecting clips.

    13 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    13 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  9. BUG: Lumetri White Balance Picker is broken

    The Lumetri white balance picker is fundamentally broken. - it doesn't do what it should be doing as far as I can tell.

    When I use it to balance a video to something that should be white in a scene - it completely shifts the color to something that is not white in any way shape or form - it shifts the temperature and tint sliders seemingly at random and makes turns things into colors that clearly aren't white. If I have something that I know is white (like a wall) with a slight tinge of color and I click…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  10. BUG: Lumetri White Balance Picker is broken

    The Lumetri white balance picker is fundamentally broken. - it doesn't do what it should be doing as far as I can tell.

    When I use it to balance a video to something that should be white in a scene - it completely shifts the color to something that is not white in any way shape or form - it shifts the temperature and tint sliders seemingly at random and makes turns things into colors that clearly aren't white. If I have something that I know is white (like a wall) with a slight tinge of color and I click…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  11. White blocky issue with Lumetri on CUDA/GPU

    The issue shows up if I change any setting in Curves, Color Wheels, HSl Secondary, or Vignette.

    Build: After Effects Version 17.0.6 (Build 35)

    OS: Microsoft Windows 10 Home 64-bit 10.0.19041

    CPU: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz
    RAM: 65468MB

    GPU Vendor: NVIDIA Corporation
    GPU: GeForce GTX 980 Ti/PCIe/SSE2
    GPU Driver: 27.21.14.5012
    GPU RAM: 6144MB
    GPU Code: 0

    CL0: GeForce GTX 980 Ti (100.0%) (GL Interop)

    Fast Draft: Available
    Texture Memory: 2438.00 MB
    OpenGL
    Vendor: NVIDIA Corporation
    Device: GeForce GTX 980 Ti/PCIe/SSE2
    Version: 2.1.2 NVIDIA 450.12
    Total Memory: 5.95 GB
    Shader Model: 4.0 or later

    7 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  12. Panasonic S5 Footage colour off in premier pro. Colour fine in other programs and video players

    My files from my Panasonic S5 (Both Mp4 and MOV) come out skewed in colour profile and cannot be recovered. I had to download Davinci Resolve to do my editing because of this problem. There are no problems in playback on VLC, Davinci, etc. Please fix his problem as I use premier pro as my go to for editing and now with my new hardware will have to switch.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  13. Paste Red Source Settings for .R3D Raw to multiple clips

    Hi, I'm working with .R3D files in Premiere (which is great btw thank you for making it so smooth) but would love to request something. When I go into Master Effects for a .R3D clip, I can copy and paste the Red Source Settings to only one clip at a time. It's a bit tedious to have to click into every Master Effects of every clip and paste the source settings to each clip. Are there plans to be able to paste to multiple selected clips OR is there already a way to do this and I'm just a ********…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  14. Bypass Lumetri Color Effect (option to bypass single active instance)

    I often add 3-4 instances of Lumetri to a clip when color grading.

    The 'Bypass Lumetri Color Effects' keyboard shortcut is helpful, but often I just want to bypass the current instance of Lumetri I'm working on to compare before/after. For this, a 'Bypass Lumetri Color Effect' (with 'Effect' being singular rather than plural) would be greatly appreciated.

    NOTE: Both this new keyboard shortcut, and the current one that bypasses all Lumetri instances in a clip, should work no matter which panel or window is active. Limiting the use of a Bypass Lumetri function to when the Lumetri window is…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  15. Lumetri sharpening Bug on "Scale To Frame Size"

    If I put a Lumetri effect with sharpening, and the clip has e.g. UHD 3840x2160, but is in a timeline with FHD 1920x1080 and the option "Scale To Frame Size 100%" (German: "Automatisch auf 100% skalieren") is activated, the sharpening is way too much than it should.
    If I choose the option "Set to Frame Size (Pan and Zoom)" (German: Auf Framegrösse anpassen (Pan und Zoom), everything is fine.

    Please fix this.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  16. Choppy Playback with big LUTs in Lumetri, Premiere 14.5

    On all latest versions of Premiere I have a very strange and specific problem. If in Lumetri I use big (64 size) LUT then playback goes very choppy like 10 fps (regular). If I use normal (32 size) LUT then no problems. On older versions like Premiere 2018 and 2019 I don't had this type of problems and could use any of my 64 size LUTs with fast playback. One other note. If I put this big LUT in Basic Correction - Input LUT, then set it to None, then again select my big LUT then it plays perfect. And…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  17. Automatic Color Correction Similar to Davinci Resolve

    I would love to have a way to do automatic color correction like Davinci Resolve.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  18. Auto WB set on skintone

    add a selector to adjust the white balance automatically based on skin color (same as the WB auto selector on whites). this could be very useful for adjusting shots where there is no white in the image.

    Currently I have to create a mask on part of the face and then align the temperature of the skintones with the line of skintones in the lumetri monitor, it is very long ..

    And in the future you will be able to make automatic adjustments for the skin color (exposure, saturation, ..)

    Thanks

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  19. Auto WB set on skintone

    add a selector to adjust the white balance automatically based on skin color (same as the WB auto selector on whites). this could be very useful for adjusting shots where there is no white in the image.

    Currently I have to create a mask on part of the face and then align the temperature of the skintones with the line of skintones in the lumetri monitor, it is very long ..

    And in the future you will be able to make automatic adjustments for the skin color (exposure, saturation, ..)

    Thanks

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  20. LUT file (HLG->709 conversion) causes awful playback lag in 14.5

    I use a simple LUT to convert HLG-shot footage to 709, and it works perfectly in CC2019 versions of Premiere. In 14.5, playback is awful when the LUT is enabled in Lumetri, whereas the LUTs that ship with Premiere play back fine (and since there's only a handful, they're all useless to me).

    Some basic research online suggests that this is now an issue with any LUT file larger than 1MB. How and why is this an issue, when prior versions of Premiere work absolutely fine?

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 16 17
  • Don't see your idea?

Feedback and Knowledge Base