How can we improve Premiere Pro?

Better Threadripper Support

I have 2 PCs, 1 with an I7 6900x and 1 with the Threadripper 1950x and opening the same project , the Threadripper struggles in playback. Cant play 1080 footage (without effects) without dropping frames. CPU utilization is 30% max and GPU is 5% max. Both machines have a GTX 1080 ti

136 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Peter shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

76 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Gethin Coles commented  ·   ·  Flag as inappropriate

    I suspect that the 3000 series CPUs will see a whole bunch more people jumping up and down on this thread. Me too quite probably. And if I caant get it to work well that might be all the push i need to move to resolve.

  • Nate commented  ·   ·  Flag as inappropriate

    Any update on this? I have a Threadripper 2950X with 64GB RAM, m.2 x 2, RTX 2080 ti. Recently it started struggling to playback. I have tried everything I know to try.

  • Seneca_lives commented  ·   ·  Flag as inappropriate

    AMD GPUs are unfortunately not an option for those of us who rely on CUDA, but older (!) Nvidia cards also work fine. Older AMD CPUs and Intel CPUs in general also work fine with the same new Nvidia cards

    The frustrating thing is, the stuttering is clearly a software issue between a CPU and GPU that are both pretty much overpowered for most regular editing workloads - something to do in the way Premiere interacts with the Nvidia drivers for newer Nvidia cards, because it can and does work flawlessly when properly "prodded".

    All Premiere needs to do is detect this particular hardware combination and engage whatever it is that gets triggered by temporarily lowering the number of cores...

  • Anonymous commented  ·   ·  Flag as inappropriate

    PLEASE READ THIS!!

    I had the exact same issues using my 1950x with a GTX 1080TI. I had choppy playback with random dropped frames regardless of the footage. Last week I purchased a RADEON VII and put it to the test. RESULT = 0 dropped frames, much faster rendering and real time playback in Premiere. The results are much more impressive in DaVinci Resolve 15. Radeon VII is an editing powerhouse!!

  • Seneca_lives commented  ·   ·  Flag as inappropriate

    @Anonymous, thanks for the script, works great!

    Changing affinity while actually playing media seems to be the key.

    Which suggests that this works by "tricking" Premiere into thinking it has a heavier workload than is really the case, causing it to switch to a less aggressive scheduling / threading. Why this is specific to Threadripper and newer Nvidia cards is anyone's guess...

  • Anonymous commented  ·   ·  Flag as inappropriate

    Okay, based off the comments below and some testing, I think I have a script based workaround. It changes the affinity to 2 cores for 10 seconds and then to 24 since I have 24 threads. If you have 32 threads (1950X or the likes) replace 0xFFFFFF in the second command with 1FFFFFFFF. This is simply a HEX number so you can use the windows calculator in programmer mode to calculate the required HEX number.

    1. Create a powershell script (.ps1) in notepad or Powershell ISE with this code:

    $APPCCset = Get-Process -ProcessName "Adobe Premiere Pro"
    foreach ($APPCC in $APPCCset) {$APPCC.ProcessorAffinity=0x3}

    Start-Sleep -s 10

    $APPCCset = Get-Process -ProcessName "Adobe Premiere Pro"
    foreach ($APPCC in $APPCCset) {$APPCC.ProcessorAffinity=0xFFFFFF}

    2. You'll need to change your powershell execution policy to RemoteSigned in Powershell:

    Set-ExecutionPolicy -ExecutionPolicy RemoteSigned

    The important part, Premiere must be playing back some media. If it's paused, changing affinity doesn't affect premiere no matter what you do.

    3. Run the script while playback, may take 1-2 tries. The next time playback is initiated it should work.

    This is what has reliably gotten me by, hope it works for you.

  • Rob commented  ·   ·  Flag as inappropriate

    I'm using an RTX 2080TI, 2990WX, Win 10. I had to go back to CC2018 for both AE and Premiere and both apps are still chugging. Timeline scrubbing is pitiful compared to my 2017 MBP. All sorts of other app lags as well. Sounds like it might be another Geforce driver issue from what I read below. But, who knows... can we get some devs on this new tech asap!?

  • Anonymous commented  ·   ·  Flag as inappropriate

    To the comment below about using Davinci Resolve, you're right. I've even got a copy from buying a camera from BMD. Problem I have with Resolve is that it's not great as a NLE. I hate the locked down UI and there's no full screen output without an add in card. DR makes you adapt to it rather than the other way around. Otherwise I would switch to it in a heartbeat, right now I rather switch to Final Cut Pro on OSX than DR.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Ok enough is enough. This thread has been active for months and Adobe won't fix it. PLEASE ABANDON PREMIERE and switch to Resolve! DaVinci Resolve uses all of your hardware and produces content in 32 bit float color depth by default. It's at least double the speed, contains audio editing, the industry standard for colour grading and a pro VFX suite. All for $400 Canadian FOR LIFE. Please, please just take my advice. You will thank me

  • Brian commented  ·   ·  Flag as inappropriate

    I'm having the same issues here. Why is it still under review, 4 months later?

  • Anonymous commented  ·   ·  Flag as inappropriate

    I have severe dropped frames with a GTX1080, 1920X and 32gb of ram in a clean 1080p timeline, it performs worse than a 4770K with the same gpu and ram. That being said I feel like this is more of a bug than a downright optimization issue as there have been instances where I have opened premiere and playback is flawless with all 24 threads. Not sure how to reproduce it, as changing affinity doesn't have a great effect for me.

  • Mark commented  ·   ·  Flag as inappropriate

    I can't even get the computer to play a bank gap in the timeline without dropping frames. In Australia the monthly subscription is now $75... Not good enough.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Threadripper 1950x and 1080ti dropping frames without any effects!!! Come on adobe this amateur stuff. If you expect me to pay $50 month, I expect you to check compatibility. The fact that the community had to point this out to you, speaks volumes of your company. I hope this gets resolved.

  • SS commented  ·   ·  Flag as inappropriate

    Adobe has been well-known since the beginning for criminally inefficient resource usage, it's their reputation. Even the reader is hogging much more than any similar software, for no reason whatsoever. Maybe they are working hand in hand with hardware manufacturers, driving people to upgrade all the time because even a pdf file takes minutes to open?
    Anyway, they are still making money by the ton, especially after switching to the monthly plan system, so why would they change?

  • Jen commented  ·   ·  Flag as inappropriate

    Please provide better support for the Threadrippers! GTX 1070 + 32 Core Threadripper, 128gb RAM. Still runs like an asthmatic at an athletics carnival. Honestly. Paying hundreds per year, every year for this software and its performance is woeful. Same footage in Davinci Resolve or Red CineX runs smoothly and beautifully. Why does it take years to fully support the top of the market hardware?

  • Peter commented  ·   ·  Flag as inappropriate

    @Seneca_lives thanks for the info! I tried setting affinity to 4 cores and nothing changed and then tried 2 and it triggered. Really annoying but at least it works !

  • Seneca_lives commented  ·   ·  Flag as inappropriate

    @Peter - sorry to hear that; the coreprio and process lasso programs don't do anything for me either.

    After some more playing around, for me it just comes back to "something to do with affinity needs to be triggered", for lack of a better expression. If I set the affinity to a small number of cores (4 or 6), I find I can play a simple timeline without dropped frames, and then I set affinity back to all cores and everything works great. That's the one method that keeps working reliably for me, anyway.

    (working with .mxf files from several sources)

  • Peter commented  ·   ·  Flag as inappropriate

    I tried setting the affinity for premiere, tried the coreprio and the process lasso programs none of which helped the dropped frames in premiere for me. (FS5 footage here)

  • Seneca_lives commented  ·   ·  Flag as inappropriate

    I am 99% certain it is actually related to this issue:

    https://bitsum.com/portfolio/coreprio/#comment-4269175711

    Quote: "The ‘fix’ is also bizarrely imprecise. For affected processes, a call to SetProcessAffinityMask, without even changing the affinity (e.g. all CPUs to all CPUs), resolves it – at least most of the time. Best guess is that the preferred NUMA node for the process is removed and that causes the Windows scheduler to change behavior, as evidenced by the thread ideal processor selections, and more importantly the massive change in performance."

← Previous 1 3 4

Please do not use your Adobe ID and password.

Feedback and Knowledge Base