Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. BUG* Lumetri curves adjustment causing blocky artifacts with Nvidia studio drivers

    BUG REPORT* White blocky artifacts cover screen when using curves under lumetri panel (Premier and After Effects latest build. (14.3.0 & 17.1.1) This is when utilizing Mercury playback engine. Using 1080 ti and latest several Nividia studio and game ready drivers have caused this issue. Current studio driver I'm using is 451.48. Using an older game ready driver does not cause this issue. I have noticed most of lumetri will process the color fine, but the curves adjustment will not process correctly, resulting in the results you see below.

    50 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    21 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  2. Wrong colours with Canon C300 Mark II/III footage

    XF-AVC footage from Canon C300 Mark II & Mark III are displayed with weird colours in the Premiere Pro M1 beta. The specs of the footage are: 2048 x 1080 RGB444 (12 bit/225Mbps Intra).

    The correct colour is the bottom left clip in the Source monitor.

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  3. Premiere Pro Color mangement is needed to fix P3 iMac Pro / 5K monitors export color issues.

    We need P3 monitor color management support. This is a known problem, Everyone who's bought an iMac Pro or iMac with P3 display has run into this issue after export making premiere almost unbearable to grade or even just do basic color correction in. When will Adobe address this issue, with out telling everyone to buy a $6,000 monitor or add an adjustment layer?

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base