Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Timecode and Clip Name effect should be able to reference audio tracks

    I have a timeline with video and audio recorded separately. I have used the Clip Name and Timecode effects to display on the video for exporting rushes. However there is no way to display the timecode/clip name of audio tracks.

    Burning in overlays from the program monitor would work too.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  2. Make export function work correctly in Premiere Pro 2020

    I have a feature film with several open caption subtitle tracks. I want to turn off the subtitle tracks and export the movie along with a rolling credit at the end. Premiere 2020 will NOT do this. It simply refuses to export the the material. It hangs on export and tellingly the Encoding window does not respond to the cancel, but the cancel button on the main export window remains active. This does not happen in Premiere 2019, which works fine. Also, Premiere 2020 refuses to export a movie and an .srt sidecar file. The option is there, it simply…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Export  ·  Flag idea as inappropriate…  ·  Admin →
  3. 3D Basic broke out of nowhere

    title is self explanatory

    doesn't work on a new project
    dosen't work if i reinstall

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Essential Graphics  ·  Flag idea as inappropriate…  ·  Admin →
  4. Please Improve Metal Support in macOS

    Metal support in Premiere Pro 2020 is currently very bad. On a Radeon VII under macOS Catalina, I'm seeing encode times from a ProRes 4444 timeline to ProRes HQ output taking 45-50 minutes for a 4-minute piece. That same piece encoded in under 10-minutes using OpenCL. Additionally, native Adobe plugins that work fine in OpenCL give a red banner CPU warning under Metal. There is no RED SDK support either. Clearly Metal render support needs work, especially if OpenCL is being deprecated. Please improve Metal support under macOS in Premiere Pro and across all professional media creation applications. Thanks.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  5. Problema con videos importados

    Tengo problemas con pasar un video en formato .mov, el cual al importarlo lo deja con el audio y no muestra el video

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Import  ·  Flag idea as inappropriate…  ·  Admin →
  6. Major frustration over reference and playback screen support.

    Yesterday I was using the reference monitor and everything was fine. I had to switch it to composite to get it to work, but whatever it worked. Now today it is not working. All I am getting is the white screen. I have tried both composite and alpha an neither one work!.

    It is the same thing with the dedicated playback screen. It works and then it goes to a white screen and never works again!

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  7. ability to set poster frames on subclips.

    there is an absolute need to be able to set poster frames on subclips. the fact that it doesn't work on subclips is counterproductive, and hinders the workflow. it simply is incomprehensible this is still not possible in Premier Pro 14.01

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Editing  ·  Flag idea as inappropriate…  ·  Admin →
  8. Hardware Encoding to H.264 causing drift to occur in my long sequence on export

    I'm using MacOS 10.13 on a iMac Pro with Vega 64. If I export to H.264 using hardware encoding the audio drifts out of sync for a longer sequence. By about 10 minutes the drift is noticeable. If I chose software In MacOS 10.13.6 on iMac Pro with Vega 64 GPU and lots of RAM. While encoding in the export window the audio stays in sync. In addition, Premiere Pro will hang when exporting H.264 randomly. Very frustrating, the other day I had to try small sections of the sequence to encode, I finally got this working. I feel it…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Export  ·  Flag idea as inappropriate…  ·  Admin →
  9. There is a problem I am having with the legacy title.

    I'm having an issue with the Legacy Title, where it won't always keep the text in the way that I set it up. I will enter the text, position it and choose its font, but half the time when I place it on the timeline, the text will be either not in the position I set it in or not there at all. I have been dealing with this for about a week now and I don't understand what's going on. Please fix this.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Editing  ·  Flag idea as inappropriate…  ·  Admin →
  10. An Autosave countdown warning would be amazing. Autosave is incredibly disruptive and always cuts you off in the middle of something.

    Autosave is incredibly disruptive and always cuts you off in the middle of something. It's really not okay for this to happen and can throw off your cutting groove. It's essential not to be interrupted, especially mid-edit. If the team is not capable of coding a non-interrupting autosave, please allow the option of an autosave warning, or countdown, letting us know the program is about to save and completely stop you from working. If we're deep into an edit and need to focus, we can hit a command/use a mouse click to stop the autosave before it kicks in. Removing…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Preference & Settings  ·  Flag idea as inappropriate…  ·  Admin →
  11. Consolidate not consolidating; excluding not excluding

    Ok…thoroughly confused about Project Management
    as it relates to copying and CONSOLIDATING files.

    Goal: take a sequence of video files, consolidate them
    and export an AAF file for colour correction by a third party elsewhere.
    Should be pretty straightforward, yes?

    Previously I have had problems where I would get an error
    the moment I tried to consolidate a sequence AND check “exclude unused clips”.
    It would give me an error and then stop.
    I attributed this to the weirdness of using Avid media on a system not yet blessed by Avid to use
    and didn’t have Media Composer or its…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Projects  ·  Flag idea as inappropriate…  ·  Admin →
  12. Exportation blocking

    Hi,

    Export did not work on Premiere 14.0.1.
    After removing the comment marks, the export worked again.
    There should be a bug.
    Can you study that, please.

    Thank you.
    Alain.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  13. CC 2020 Timeline Clips Shifts After Moving Project / Relocating / Relinking

    We have several users of BRAW Studio experiencing timeline shift after moving their projects between computers. Sometimes it even goes back to the first frame.

    If this also happens to you please tell your story in Adobe Community Forums : https://community.adobe.com/t5/premiere-pro/cc-2020-timeline-clips-shifts-after-moving-project-relocating-relinking/m-p/10923880

    Happens only with CC 2020 (both 14.0.0 and 14.0.1), both OSX and Windows, all framerate (23.96 fps and 25 fps for example).
    Apparently happens with others formats than .braw : https://community.adobe.com/t5/premiere-pro/linking-media-losing-in-and-out-points/td-p/10922669 "I have this problem on every file type I have tried; R3D, BRAW and CRAW"
    Attached is a zip with the two .prproj from a user editing with…

    11 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Projects  ·  Flag idea as inappropriate…  ·  Admin →
  14. CC 2020 Timeline Clips Shifts After Moving Project / Relocating / Relinking

    We have several users of BRAW Studio experiencing timeline shift after moving their projects between computers.
    Happens only with CC 2020 (both 14.0.0 and 14.0.1), both OSX and Windows, all framerate (23.96 fps and 25 fps for example).
    Apparently happens with others formats than .braw : https://community.adobe.com/t5/premiere-pro/linking-media-losing-in-and-out-points/td-p/10922669 "I have this problem on every file type I have tried; R3D, BRAW and CRAW"
    Attached is a zip with the two .prproj from a user editing with .braw
    We can see that this inside the .prproj XML :

    <ClipLoggingInfo ObjectID="40" ClassID="77ab7fdd-dcdf-465d-9906-7a330ca1e738" Version="8">
    
    <ClipName>A005_01231137_C004.braw</ClipName>
    <MediaInPoint>1577778048000000</MediaInPoint>
    <MediaOutPoint>1621427734080000</MediaOutPoint>
    <MediaFrameRate>10594584000</MediaFrameRate>
    <TimecodeFormat>110</TimecodeFormat>
    </ClipLoggingInfo>

    is changed to this…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Projects  ·  Flag idea as inappropriate…  ·  Admin →
  15. CC 2020 Timeline Clips Shifts After Moving Project / Relocating / Relinking

    We have several users of BRAW Studio experiencing timeline shift after moving their projects between computers.
    Happens only with CC 2020 (both 14.0.0 and 14.0.1), both OSX and Windows, all framerate (23.96 fps and 25 fps for example).
    Apparently happens with others formats than .braw : https://community.adobe.com/t5/premiere-pro/linking-media-losing-in-and-out-points/td-p/10922669 "I have this problem on every file type I have tried; R3D, BRAW and CRAW"
    Attached is a zip with the two .prproj from a user editing with .braw
    We can see that this inside the .prproj XML :

    <ClipLoggingInfo ObjectID="40" ClassID="77ab7fdd-dcdf-465d-9906-7a330ca1e738" Version="8">
    
    <ClipName>A005_01231137_C004.braw</ClipName>
    <MediaInPoint>1577778048000000</MediaInPoint>
    <MediaOutPoint>1621427734080000</MediaOutPoint>
    <MediaFrameRate>10594584000</MediaFrameRate>
    <TimecodeFormat>110</TimecodeFormat>
    </ClipLoggingInfo>

    is changed to this…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Projects  ·  Flag idea as inappropriate…  ·  Admin →
  16. Bug: Clip motion position disobeys keyframes

    Steps to reproduce:


    1. Throw any clip on your timeline

    2. Add 3 Position keyframes. (The bug is more obvious if they're several seconds apart.) Confirm the position values for all are the default 960,540.

    3. Change the position value for the 1st keyframe to 960,0

    4. Change the position value for the 2nd keyframe to 950,540

    Play and behold... between the 2nd and 3rd keyframe, the clip moves in the Y axis!
    And yet the 2nd & 3rd keyframes are from 950,540 to 960,540. So instead of a slow movement to the right, it's adding a down&up movement (my Y value peaks at…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  17. Premier Pro CC 2020 render glitch

    Since upgrading to the latest build of Premier Pro CC 2020, I get random glitchy one-frame lines in my renders from PP (see attached). They appear in different places with each new render, and aren't in the timeline if I go back and check the project... they only appear in the renders. I've tried H264 and ProRes 422 HQ... happens in both codecs. I'm trying to deliver a job today, but I have to re-render multiple times... and then comb through each 8 minute render to see if there's any glitches, which is unnecessarily time-consuming and frustrating. Please fix this!…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  General  ·  Flag idea as inappropriate…  ·  Admin →
  18. Bring back support for multiple project windows

    To be clear, this is all about working in a SINGLE project file.


    1. Add a command in Window > Projects: New Project Window

    2. "Go Back" command ("Up one level") will no longer go back all the way to a project's root level. Bring back this capability.

    Since Premiere's UI has been about dockable pane workspace for ages, I don't just open new bins willy-nilly all over the screen (like the Avid way, until recently). I keep several windows/tabs docked and enjoy access to multiple bins as well as an organized workspace. Well, not anymore.

    It's always been possible to have…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  User experience/interface  ·  Flag idea as inappropriate…  ·  Admin →
  19. CC OP47

    Possibility to choose the teletext page. In Belgium we're using page 889 but export chooses page 801 by default.

    Possibility to choose the VANC Lines.

    and accents are not recognized...

    A complete improvement of CC OP47 for each country using these will be great.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Closed Captions  ·  Flag idea as inappropriate…  ·  Admin →
  20. Ram Memory consumption goes way up when playing or scrubbing a big image inserted on a timeline

    I'm making a video for an artist, so big tiff files are all over. Every time I scrub or work with these big images memory consumption goes to the top of my 24gb ram and eventually crashes if I keep scrubbing to see how a simple movement works.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base