Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. ARRI Amira LUTs No Longer Work

    ARRI Amira LUTs no longer import (as of 14.5 and in 14.6). These should be visible in the new Color Management window on Interpret Footage (as ARRI Alexa Mini is). They aren't and there's no way to toggle on or off. Nor on Master Clip as original implementation. However occasionally on export the LUTs are still loaded.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  2. Premiere Pro 2020 constantly crashing whilst performing basic tasks.

    Premiere Pro 2020 is the most unstable release that our company has every experienced.
    It constantly freezes and crashes whilst performing the most basic of tasks for an NLE. Highlights include:
    - Opening a file in the source monitor
    - Adding a keyframe to an audio clip or track
    - Importing files
    - Adding or deleting tracks
    - Playback
    - Any form of editing in the sequence
    - Adding text

    The list goes on. And on.

    So far, reseting Workspace, reseting preferences, reinstalling the software... Etc... None of this works or helps.

    This is happening across many different types of…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  3. Export window is slow to open and change settings

    There is a delay of around 3-5 seconds when opening the export window (CTRL+M) and when changing any of the export settings. This issue occurs every time the window is opened or a setting is changed.

    I've tried a complete uninstall and reinstall, clearing preferences, etc. and nothing will resolve this issue. The issue occurs on existing and new projects.

    V14.6.0 (Build 51)
    Windows 10 Pro
    i9 9900K
    64GB RAM
    RTX 2080 Super

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  4. Premiere pro crashes when adding or deleting audio or video track

    Premiere pro crashes when adding or deleting audio or video track.

    I've tried a complete uninstall and reinstall, clearing preferences, etc. and nothing will resolve this issue. The issue occurs on existing and new projects.

    V14.6.0 (Build 51)
    Windows 10 Pro
    i9 9900K
    64GB RAM
    RTX 2080 Super

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  5. 1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  6. 14.6 crash deleting clip in bin

    I updated to 14.6 yesterday. I'm on a Windows 10, Intel i9, 56 GB ram, Nvidia 1080ti GPU computer. I have three 4k monitors hooked up to the Nvidia.

    Several times when working with clips in the bin, and pressing the "delete" key on my keyboard, the program would crash. So much so that I downgraded to 14.3.2, which is the last stable version of the software that I could use.

    I've also found that for the past year or so, my custom workspaces are not saved. When I start a new project, bins are combined. When I open old…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  7. Premiere Lagging

    About a few days ago Premiere Pro started lagging in the timeline. I've tried everything. Reinstalling, new projects, different media, different versions of the software, every troubleshooting option I could find on the web.

    I've got a beast of a PC. I just don't know what happened or why.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  8. BUG: If Mac screensaver kicks in, and drives spin down, Premiere will not play

    Premiere 14.6. If I walk away from my (10.15.7) Mac, and the screensaver kicks in and the media drive the project is on spins down, waking the computer and trying to get Premiere to play a sequence or a source piece of media does not work. The video updates to the position bar, but will not play. Restarting Premiere is the only solution.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  9. ☠️Fatal Premiere 14.6.0 Crash when dragging clips up into a new-video-layer in timeline.

    I've had several fatal crashes (on 3 different Premiere projects) -- since updating to the latest 14.6.0 -- It happens every time I drag a clip into a new video layer in the timeline -- only when I'm CREATING a NEW video layer while moving it up.

    🙏🏻Please fix this glitch!!!

    PS, I'm running MacOs 11.0.1 Big Sur

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  10. With version 14.5 and 14.6 of Premiere Pro

    Premiere Pro v14.6
    Windows 10, version build 20H2
    i7 6900K
    Quadro M4000
    64GB memory
    500GB SSD OS/App drive
    Several other drives for storage and work files

    I am having a problem where every time I try to add a new track, either video or audio, in the timeline sequence, Premiere Pro stops responding and I need to use the "end task" in Windows Task Manager to close and restart Premiere. I have rolled back to using 14.4 of Premiere Pro.

    Additionally in v14.6, I am noticing some bugs with the display of menu items, see attached image for example.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  11. Crash on changing sequence settings (resolution)

    When I change my sequence settings from DCI 4k 4096x2160 to 2k 2048x1080, the program locks up and crashes. Using most up to date (v14.6).

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  12. BUG [V14.6]: Adding video tracks on timeline is impossible on older projects

    OLDER PROJECTS: On timeline, if I try to add video track (right click menu), or dragging clip to create new video track > CRASH. Latest version 14.6 on windows 10.

    NEW projects work normally, so it's ALL older projects created with previous premiere versions.

    Nice work updating, again... changing back to previous version.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  13. BUG: Cursor does not refresh

    In 14.5.0, on macOS, I am noticing the cursor and selected items often do not refresh. i.e. switch to pen edit tool (P), pen cursor appears. But then use keyboard to switch back to cursor arrow tool (A) and edit roll tool ® - the cursor remains the pen tool, but does the operations as expected.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  14. "Extract" command crashes Premiere about 1/5th of the time

    I always make sure to save before I use the Extract command—when I use Extract to cut things out of the timeline, I find Premiere permanently hangs about 20% of the time. I have to kill it and go back to the last autosave. It's been that way for quite some time for me, and I haven't noticed any correlation to specific codecs or conditions in my timeline.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  15. Premiere Pro V 14.5 frozen timeline

    iMac Pro 2,3 GHz 18-Core Intel Xeon W / Radeon Pro Vega 64
    timeline is frozen. Clips cannot not be moved or added by dragging. Only copying and pasting works. Playback does not work.

    Had to downgrade version to solve this

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  16. The opacity mask function is unstable

    The effects controls disappear every time I make an adjustment on the 4 point polygon mask. I have to deselect the clip then reselect it for it to appear again. This is an awful experience. It makes using masks in premiere incredibly frustrating. Also, when you put other layers of video or text over layers that have a mask on it, it creates errors, black spots in the footage, or other bad render problems once exported. Please make the mask tool better. I beg you!

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  17. Latest PP multi monitor issues on Win10: Fullscreen capped at 1080 on main 4k monitor + waking issue

    Nothing game breaking, but annoying nontheless:

    I have a two monitor setup connected to a rtx3080. One is an ACER ET322QK 4k 10-bit display over displayport for my playback window and effect/source that is set to be my main display in Windows settings. My second display is a cheapo Sceptre E22" 8bit HD display in verticle orientation that I use for pancake editing two timelines simultaneously. Not sure how much of that info is relevant to my probs.

    The first issue is that I mapped "F" to fullscreen the program monitor. This only works when the entire program is on…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  18. Media Browser Bug?

    The Media Browser and the Link Media Window seem not to work properly when my PC (or any other PC) is connected to our Network.

    If so I am not able to navigate to files I need. Either the Media Browser sticks or it's switching between showing folders or just a grey window. I can try to scroll down to the folder I want to open and with a little bit of luck it works. But the most of the time it resets itself to the beginning.

    If I disconnect the PC from our network it always works as it…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  19. Media Browser Bug?

    The Media Browser and the Link Media Window seem not to work properly when my PC (or any other PC) is connected to our Network.

    If so I am not able to navigate to files I need. Either the Media Browser sticks or it's switching between showing folders or just a grey window. I can try to scroll down to the folder I want to open and with a little bit of luck it works. But the most of the time it resets itself to the beginning.

    If I disconnect the PC from our network it always works as it…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
  20. Bug Premiere Pro 2020 crash when changing sequence settings

    In the latest version I'm able to crash Premiere every time I make changes to a sequences setting - e.g. put in a new frame rate, change field order etc.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Stability  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 29 30
  • Don't see your idea?

Feedback and Knowledge Base