Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Premiere playback laggy with M1 Ultra Mac Studio

    Upgraded to the M1 Ultra Mac Studio(20core CPU, 48core GPU, 32 Neural Engine, 64GB ram running OS 12.5) and am experiencing slow playback performance. The footage is 4k 420 10bit H.265

    I've been working on my 2018 PC (i9, GTX 1080, 32GB ram). I've had the PC for 4 years and am used to the performance it has with this footage. Opened the same project on my new M1 Ultra Mac studio, that's 4 years newer, more than twice the price, and significantly faster/more spec'd out, yet my PC is handling the footage better.

    I've spoken with Adobe Care on…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    Hi Tom, 

    I'm sorry to hear that you're not getting the performance you should be. I'm one of Premiere Pro's product managers and a particular area of focus for me is formats and performance.

    Can you tell me a little bit more about the HEVC files you're using (e.g., what camera they are from, what wrapper - .mov, .mxf - they are in)? Even better would be to share a project and its media that you're seeing the issue with. 

    I'd be happy to get on a call with you to discuss the issue you're seeing but let's start with some basics and go from there.

    Regards,

    Fergus

  2. BUG

    Issue with XDCAMEX footage wrapped in .MOV files. Since version 22.4 reverse playback is jittery with these files. Disabling mercury playback with CUDA lets reverse playback plays smooth but you lose the benefits of GPU. When reverting back to version 22.3.1 the issue is gone & everything is perfect again. Something happened with this starting in version 22.4 onward.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. image scale

    Scaling/moving an image with video render and playback set to use CPU (CUDA) results in a wobbly scale or jerky motion. See this post from 2019 for details.

    Using Premiere Pro 22.5.0 (Build 62) and tried using different Nvidia Studio drivers from current (516.94) to older ones and the issue persists.

    The export appears to be fine when everything is rendered. It appears to just be a playback issue when not rendered.

    https://community.adobe.com/t5/premiere-pro-discussions/png-image-wobbles-during-scaling-only-after-export/m-p/13201798#M430516

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. If I hit play, it takes up to 20 seconds until it actually plays!

    I updated Premiere since the playback was a mess in the previous versions (strange lines and fragments in the images).
    Now its gone but there is one new bug thats even worse.
    If I click on play it takes up to 20 seconds until it finally starts the playback (complete work area -which btw is TRANSPARENT now, why?- is already rendered/green)..
    What about just ONE Premiere version where I can work normally without having all kinds of problems? Its going on for years now. I had many problems with clients and deadlines because of those bugs...

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. "Panasonic Varicam LT" mxf-Footage playback bugged in all the latest Premiere Pro 22.x versions

    Whenever we playback Varicam LT Footage (3840x2160/25p/50p) in Premiere we get weird double exposure scaling bug in source monitor and program monitor.
    There are no effects on the clip, just scaled to fit in a HD timeline. But while playback or scrubbing through the footage (in either source or progam monitor), it is scaled to the top left quarter + overlayed with the top right quarter of the image. As soon as we stop the playback, it is back to the normal frame again.
    Also performace is crazy bad in these projects. Our workstation should be able to handle everything.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Make the source monitor output 16:9 no matter what ratio the clip is

    When you work with opengate formats (not 16:9) with external equipment the source monitor wont output video. I do a lot of commercials that is shot in opengate to get more information for vertical formats later on. sequence is still set up at 16:9 and plays fine on external gear (blackmagic or AJA) but when I watch a clip in source it wont playback as the ratio is not 16:9.. In resolve you can set the source to 16:9 and it will playback on your external monitors with black borders on the side.. as a workaround I transcode all media…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Custom Size Multicam View Grids (3x2, etc.)

    Currently, in Multicam view, cameras are displayed in a grid that can be 2x2, 3x3, 4x4 and so on. This means that if you have 6 cameras, you'll see a 3x3 grid, and the bottom 3 rectangles will be blank.

    This unfortunately wastes screen real estate. For 5 cameras, a 3x2 grid would be more appropriate than 3x3, making each individual camera preview bigger. See the attached screenshot for an illustration of what I mean.

    The multicam preview window ideally shouldn't be locked to the aspect ratio of your sequence. Thanks for your consideration!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Native Sony files (XAVC) should be able to be edited

    Editing native 4k 10bit 422 files from cameras such as the Sony A7siii or fx3 are impossible to edit without making proxies. Adobe should add support for these files, especially on the new M1 macbooks. I have a 2021 16” M1 MacBook Pro and it’s impossible to playback much less edit these files without making proxies. The lag is terrible, and it shouldn’t be that way as these files are not that huge. QuickTime plays them back with no problem. Please add support for at least the H.265 files in Sony’s XAVC-S files.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. There is a random bug where pressing the space bar does not activate the play head in the timeline and occurs on different PCs.

    Latest Premiere Pro Build. With the timeline panel selected (or not selected), there is a random bug that keeps the spacebar (and sometimes even the JKL keys) from starting the play head. Ways to kick out of the bug is to switch to a different app in Windows, then go back to Premiere Pro. Other ways to kick out of the bug is to close the project file, or even close and restart Premiere Pro. The randomness is breath taking, so random, that detecting how to repeat the bug is very difficult to pin down. This same bug also occurs…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Stuttering Playback w/ Graphics on M1 Studio Ultra

    Any timeline with Essential Graphics / mogrts (lower thirds, bug, animations, CG) has extremely laggy and stuttering playback in 22.4 PP / MacOS Monterey 12.5 / M1 Ultra Mac Studio. Also very slow to render / export. Primarily footage is mostly 1080p MXF OP1a / MPEG-2 420 MPHL or transcoded to 1080p ProRes 422. But all video formats are having issues once graphics are added.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. H264 Growing files broken?

    H264 files that are still being recorded (growing) no longer work in Premiere.

    They will import with only 10seconds duration while the file is growing and nothing beyond 10 seconds is playable.

    I have two identical macs but running different versions of Premiere accessing the same media being recorded to a NAS.

    Version 13.1.3 works correctly with growing h264 files.

    Version 22.5.0 does not work with growing h264 files as detailed above. ProRes files do work.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. Control timeline playhead with scroll wheel

    In addition to horizontal and vertical timeline scrolling, there should be an option to use the mouse wheel to control the playhead directly in the timeline pane. Such functionality exists in both the source monitor and the program monitor; it would be lovely to mirror that usability in the main timeline as well.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Mac studio sleep gives premiere pro problems

    On my Mac Studio M1 Max 64GB , every time it goes to sleep upon wake the timeline will not play properly. The audio in the timeline will play but the video will not and the player will not move. This happens consistently every time my Mac goes to sleep and is awakened.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. 'At playback end, return to beginning' not working

    It is just me or the option in Premiere Pro "At playback end, return to beginning when restarting playblack" is not working.

    Being checked or unchecked will always return to the beginning. That need to be fixed.

    I'm using Premiere Pro version 22.5.0

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. Downconvert footage to IO device.

    For users who own an HD monitor connected to an IO device like a decklink card to get true 10 bit signal, anything above HD timelines give no output. Premiere & After Effects need a feature to seperately have a resolution for downconverting footage to the reference monitor. Not having this feature makes owning thousands of dollars in equipment useless. Your stepbrother Davinci Resolve can do this :)

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. Fix start and stop in multicam taking almost 50 secs to stop!

    After hitting play in a multicam seq it takes about 40/50 seconds to stop! This needs to be fixed

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. MXF OP1a Strobing on Sequence in V22.5 Bug

    MXF OP1a clips strobe when played on a suitable sequence in V22.5. The strobing appears to be a grey overlay on 4K clips shot in Rec 709 color space and is very bad. Rolled back to V22.4 and the issue is not present. Please issue a fix to this asap.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Mac M1 Laggy Timeline when using 2 Clips on Video Track on top of each others

    If i put one clip below and another clip cropped on top. It will start to take about 1 second when i press spacebar to playback the timeline. On my windows machine is instant.

    If i have a single clip, playback is instant

    I need to do that all the time, since i do commentary with a webcam on top of what is going on in my screen.

    Footage is h264 or mov recorded from OBS.

    Also on my PC it takes 2 min to export on the mac mini 8 min. Is that normal?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
← Previous 1 3 4 5 28 29
  • Don't see your idea?

Feedback and Knowledge Base