Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Remove the flickering / strobe problem in program monitor

    I have a flickering / strobe problem in program monitor while playing,
    This happens on my two windows machines.
    Not any problem on macbook.
    Windows 10
    RTX 3090
    32gb ram

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  2. preview file ignores playback quality

    I am using preview files (render in to out) to get better playback, and I use high quality prores 422 as my preview format in the sequence settings so I can render previews eventually in the output settings and save time. this works great but one annoying thing - I am working with high resolution, and I set my playback resolution to 1/4 or even 1/8 to get smooth playback and it works, but when it reaches the rendered preview section in the timeline - it's always high quality... meaning I get a jump in resolution, and the playback is…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  3. Timeline lock button for live playouts so stops autosave and background activity

    If there is a function in Premiere already then my apologise but this will be super helpful for short notice hot rolls

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  4. Color shift during playback

    After color correcting, the color shifts during playback unless playback resolution is set to FULL.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  5. multicam playback stops when switching camera

    Bug report: Playback stops when switching camera on a multicam sequence.

    Setup: Windows 10 + Premiere 15.4.1

    Make a sequence with sync-ed footage. Insert this sequence in another 'master' sequence and enable Multicam editing. Enable Multicam view in Program panel.

    Grab a coin and flip it in the air. If it did between 17 and 23 rotations or between 36 and 41 rotations, then you'll encounter the bug.

    Normal workflow would be to start playback and hit the number keys to add an edit and switch to another camera.
    But sometimes, you'll hit a number key and playback stops. The…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  6. Make it function properly with Metal

    Without OpenCL support, and relying on Metal or Software Only rendering, I get no real-time playback whatsoever with .mxf clips with one instance of Red Giant Colorista applied - even at quarter resolution. A massive number of frames are being dropped, with only occasional bursts of real-time performance.

    This is with 4K source footage in an HD Sequence, both at the same frame rate of 23.976. I get better results with 29.97 source footage in a 29.97 sequence.

    IDK if this matters or should matter, but I'm a full-time editing professional who uses the Adobe CC daily to make my…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  7. Fix the glitchy playback issues for sony fx3/ sony a7siii 10 bit 4.2.2 h.264 on PP 15.4 native version for m1

    I have glitchy issue on playback on sony fx3/ sony a7siii 10 bit 4.2.2 h.264 on Premiere pro 15.4 native version for m1..

    somehow glitch issue affect when exporting the final result too..

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  8. Captions in Premiere 2021 timeline is lagging

    I work in a projects with a lot of captions. I have timelines with 30 to 70 minutes with captions.

    Zoomed out to the whole timeline and visible captions my timeline starts to lag BIG time. The timeline zoomed in works just fine. Hiding the captions is also ok.

    Imac Pro 2017

    32 GHz 8-core Xeon W

    64 GB 2666 DDR4

    Radeon Pro Vegas 64X 16GB

    extra monitor Apple 2,5K

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  9. Stuttering Video Playback Due to Incorrect Audio Input Settings

    On Windows 10 PP2021, any video file would stutter in playback.

    Seems to have been due to a mis-configuration between the microphone input capability on my system and the configured of audio sample rate and bit depth on the mic input.

    Originally, on a fresh install, premiere defaulted to:
    Input - 2 ch 32 bit 44.1kHz
    Output - 2 ch 32 bit 48 kHz

    Setting input to "No input" resolved the playback issue with output set to the above 32bit-48kHz setting.

    Matching input and output to:
    2 ch 24 bit 48 kHz

    Resolved the playback issue as well.

    Again, seems…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  10. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  11. play all frames option (don't skip for the rush of real time)

    here is the feature request:
    we increasingly have complex timelines filled with MoGRTS on several tracks and hitting play results that the program monitor just jumps through the time and you must set in outs and set on loop to playback just to see if the animation goes as expected. Why can't we just have an option to set play every frame? Until it's rendered don't go to the next one. So it could be just like in After Effects

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  12. bug fix Unresponsive timeline interface & lagging of mouse and keyboard input

    Nesting videos cause the timeline interface to not respond to my keyboard and mouse inputs.

    nesting 4k .mov footage in a HD sequence causes a periodic error to come up when scrubbing in the timeline where Premiere does not let me click on videos on the timeline and pressing hotkeys or space bar does not do anything.

    I am on 15.2. build 35

    Further discussing about this
    https://community.adobe.com/t5/premiere-pro/unresponsive-timeline-interface-and-lagging-of-mouse-and-keyboard-input/m-p/12183185#M357472

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  13. premiere v15.0 bug report, playback via black magic

    Windows 10

    Premiere v15.0

    32GB Ram

    i7-9700k stock settings

    Asus Prime 2390 with thunderbolt

    GTX 1080 ti

    Thunderbolt ex3 card to UltraStudio Minimonitor via Thunderbolt cable

    Ultrastudio to Flanders Display via SDI

    I'm working in a 1080p timeline with Red 8k footage @ 23.976. I have proxies attached at ProResLT @ 1080p. Proxies are toggled on.

    When I do trimming, i.e. roll, slip, etc. The playback becomes overwhelmed and starts to lag. Overwrite and insert edits are not a problem. If I trim too fast, like lots of trims in a row, premiere eventually crashes, as does the whole system.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  14. You need to add a 1.8x anamorphic option

    1.8x anamorphic is gaining popularity and I'm editing a feature film for a major studio next week that is utilizing it. This feature needs to be added so we don't have to scale the horizontal pixels manually by 1.8x to compensate...

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  15. Showing result of media encoder

    Showing the result of media encoder while rendering. Actually a little preview - would be nice to monitor rendering in fullscreen and/or via mercury playback on the sdi monitor.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  16. Possible bug - Distorted/Rippling effect on Second monitor looking at full screen playback

    I'm using 2 LG 4K monitors. One is my editing desktop for Premiere Pro the other is for monitoring Video output.

    All settings are fine.

    NVidia 2070 Super feeding these two monitors via Display Ports. Nvidia drivers on 471.11 and Intel latest on 27.20.100.9466. Windows 10 all updated.

    I have noticed on PP 15.2 (and 14.9) a slight 'ripple effect' and minor Video break up on the second video monitor output when there are panning shots - up/down & across - ie when video is not static. This is quite subtle but annoying.

    Looking at timeline playback of the Program…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  17. program panel playback flickers.

    when I hit play on video, the playback panel flickers black for a few seconds before playing smoothly, it's really obnoxious combing second by second looking for weird frames when the frames are flickering black. I'm editing 4K file proxied as 1080 at 24 NTSC framerate

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  18. Disappearing BG

    Bug since last patch. Sometimes the background disappears after closing a project. Any fix to this? As you can see on the photo that i have already resized the upper layer to 80* and the BG at 100% yet its still not appearing.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  19. Bug: Previewing a clip where the video is sped up and reversed confuses the real time rendering when it hits a cut in the audio

    How to reproduce:
    1) Ungroup the Audio and Video tracks.
    2) Cut part of the Audio of a source into a small clip (my sample was about 2 seconds long)
    3) Clip a much longer part of video (mine in this case was approximately 5 or 6 times longer)
    4) Use Speed/Duration to set the Video clip's length to match that of the Audio clip, and turn on reverse (note: it's very possible that the bug is simply the speed/duration itself or just reverse, and not both)
    5) Line up the audio and video in the timeline by themselves.
    6)…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  20. Varicam 35 LT

    When you upload footage with recorded audio from the Varicam LT it is very loud static noise. I am currently using version 15.2. When I uninstalled it and returned to version 15.0 the issue was no longer there. I have uploaded a sample of what I am talking about. How can we go forward to fix this issue? May someone follow up with me to address this?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 23 24
  • Don't see your idea?

Feedback and Knowledge Base