Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Performance Issue with RED Files over Network and Mercury with CUDA

    Dear Adobe Community,
    we have a problem in our company with the playback of RED material. In the following I describe the behavior of Premiere Pro when playing back 8K r3d data. But this also affects footage from 5/6K.

    First of all about hardware and infrastructure. We have a server with a raid controller (Adaptec 81605zq) which provides 16x4TB Samsung Evo 860 in RAID6. This is connected to the switch by means of 4x10GbE bundled over fiber optics. From here our workstations are connected via 10GbE copper cable. The server runs with MS Server 2016, the workstations with Win 10…

    6 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  2. Premiere Pro dont start.

    After the new Update 14.5, Premiere dont start.

    I try it twenty times but every time i open it, then premiere stops and the report say no feedback.
    At twenty and one time premiere starts, after ich closed every program on my PC.

    Its absoluty out of the question that this is a joke from adobe!
    Fix it, i need to work and i have not every day a hour time to take this game with premiere pro!

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  3. Creating Proxies for 120p footage creates 60p proxies?!

    I have footage filmed at 120p, 60p and 24p in a sequence. They are all HEVC 10 bit 422 so naturally, the computer is having trouble playing them back, so I waited all night for Premiere to create proxies. It worked fine for the 24p, did that automatically. Did fine for the 60p, did that automatically. However, for the 120p footage, it ignored that it's 120p and just created a bunch of 60p footage, so when I turn on the proxy, it jumps to different areas because the actual footage is 120p!!

    Obviously this is a problem since it means…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  4. Fix Project Load time

    Even for small projects, after this weeks round of updates, it now takes forever for projects to open.
    Stuck waiting for all media to be loaded and often application never loads all the media and I am forced to restart or reboot.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. Bug in Premiere Pro - version 14.5.0

    I updated to the latest version today, Oct. 21, 2020 - - whenever I am working in a project in Premiere, and then close the project to open another project, ALL keyboard shortcuts stop working. I have to completely quit Premiere, and reset preferences (hold "Option/ALT" upon launching) for the shortcuts to be restored.

    And then if I hop to another project, again, the shortcuts stop working.

    I have zero custom keyboard shortcuts; all of the shortcuts that cease to work are the ones native to Premiere.

    Premiere Version: 14.5.0

    Working on an iMac Pro 2017
    macOS Catalina - 10.15.7

    8 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    Sounds scary; we’re not yet able to reproduce that behavior, here.

    Confirming: In Preferences —> General —> Most Recent, is yours set to show the Home screen (the default behavior), or have you changed the pref to “open most recent”?

  6. Mac Pro 2019 / Vega 32GB / 16 Core poor performance with mp4 /h264

    Its a misery / mystery how slow Premiere renders and feels while editing compared to other NLE Editing Softwares like Resolve or FCP X.
    I am using Premiere since + 10 years and it feels outdated to be honest.
    Adobe Please don´t add any more features just clean the code and concentrate on performance.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  7. More Stability for Complicated Nests

    Premiere seems to have stability issues when it comes to playing back a nested sequence containing a lot of footage. Even though all the original footage has proxies (and are enabled), the playback resolution is set down low, and the workspace has been rendered, it will still stagger or stall for a while when I press play/pause, fast forward, or move footage around. It would be nice if this didn't happen.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  8. New sequence dialogue box not fitting on my 14" laptop

    I am a student working on premiere pro from home. I have a 14" laptop and the dialog box for "new sequence" is to big for my screen i cannot click "ok" to confirm my changes.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  9. New sequence dialogue box not fitting on my 14" laptop

    I am a student working on premiere pro from home. I have a 14" laptop and the dialog box for "new sequence" is to big for my screen i cannot click "ok" to confirm my changes.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  10. New sequence dialogue box not fitting on my 14" laptop

    I am a student working on premiere pro from home. I have a 14" laptop and the dialog box for "new sequence" is to big for my screen i cannot click "ok" to confirm my changes.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  11. Fix Audio Previews/Rendering

    Currently, Premiere Pro has no indicator for audio rendering, and appears to render all audio prior to starting playback, causing lag spikes upwards of 20s with a large multi-track file.

    This would be okay, if somewhat annoying, if Premiere actually cached and retained this audio after this first time. However, that is not the case. Premiere does not cache the audio to disk, and will discard all of it immediately if you so much as click out of the program for half a second, causing another 20s lag spike before you can start playback again.

    Additionally, people have reported related…

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  12. Make it work

    Your program used to work well, until yesterday, where I can now barely even play a video at 1/16th of the quality. Not sure what the problem is, hoping someone from adobe can assist with these issues.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  13. Multicam/nested sequence loading times

    Hi!

    I have some issues with loading times on multicam sequences.
    In a timeline I have three camera's. A go pro 7, a sony x70 and a Canon Legria with the original footage.

    Now if a open the sequence containing the multicam nested sequence it has to load every time the whole clips it seems.
    The network is peaking fully for a minute or 2 and then everything runs fine.

    Is this a bug?

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  14. Since receiving my latest update the program no longer works - i am uninstalling it

    Too many times Adobe puts out a product that does not have enough research and expects the users to do all the dirty work. I'm done with Premiere Pro!

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  15. BUG and CULPRIT FOUND

    After Updating from PP 14.3.1 to 14.4.0 an big issue was happening to my system. Premiere pro was not using my graphics card at all. after clearing the cache and uninstalling and reinstalling and of course updating ot the latest studio driver for my 2080ti it still did not fix any of the issues with he sept 2020 update.

    so i downgraded back to 14.3.1 and kept all the other apps up to date and viola! the issue is resoleved!

    Please Adobe fix the issue!

    my render speeds are back to normal

    in my previous post you can see I…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  16. BUG Lumitri Color Causing Lag in Performance and in Rendering

    BUG Lumitri Color Causing Lag in Performance and in Rendering or premiere pro not using full system ability. not using normal 100 percent GPU and 10-20 percent CPU during playback aor rendering

    Please fix the bug! What use to take 10 minutes to render a 15 minute project now takes over 1 hour! And premiere is just going super slow!

    Premiere September 2020 release (14.4)

    All other apps like media encoder and Adobe After effects are also updated.

    Premiere version 14.4.0 (build 38)

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  17. EXTEND TOOL IS CRIPPLED

    This was introduced RECENTLY.

    As of Version 14.3.2.(Build 42), Extend no longer honors a Tail-back-to Playhead Reverse Extend with the tail cut SELECTED. All we get is Extend from the tail of the previous clip overwriting the head of the clip operated on. Unwelcome surprise.

    Please fix!!!!

    Also, a repeated suggestion- make it so Extend draws all clip ends on all selected tracks with media to the Playhead. This is expected behavior in Avid and Final Cut Pro, and until recently right here in Premiere.

    Best, as always,
    Loren

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  18. My premiere is lagging and I am looking for another editor. The only thing I edit is a 1080/1920 video for Instagram, HD, with images that m

    My premiere is lagging and I am looking for another editor. The only thing I edit is a 1080/1920 video for Instagram, HD, with images that move from time to time. Just check @eduinfinitando . So... The exportations are taking MUCH longer than it used to. Normally it took 10 minutes to export something, and now is taking about 2-3 hours, and I am talking about a video without color corretion or something. Just images and some movement... My desktop is a i5, GTx1050, 16gb Ram, SSD... I already recovered my Windows and still it's slow. The lag started before…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  19. Accelerated output HDCAM MXF OP1a files and others

    Can accelerated GPU CODECs be created for all the different flavors of MXF OP1a output files? Most are either MPEG2 or h.264. We have been spoiled by the quick exports to .MP4 files (h.264 and now h.265), and it would be very handy to have that ability to export formats that support more embedded metadata. Most all of our broadcast servers take MPEG2 or h.264 HDCAM OP1a files with embedded Scenarist Closed Captions (608 and 708). It would just be nice to have more efficient renders to those formats.

    Thanks!

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  20. 14.4 OSX - Audio meters lag during playback

    Hi team,

    Just installed 14.4 this morning and started a new project. When playing back the timeline, the audio meters have a severe lag of several seconds. This makes it impossible to monitor properly.

    Roilling back to 14.3.1 - no problems.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 19 20
  • Don't see your idea?

Feedback and Knowledge Base