Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. NVLink causing GPU crashes with Premiere Pro

    Hey,

    I installed an NVLink connector for my 2x 3090s to use in my 3D workloads. I noticed a very consistent GPU crash "only" when using Premiere Pro with the attached setting turned on.

    I now have to disable it each time I'm using Premiere Pro, which is very unintuitive imo since I use it for other work.

    The crash makes my GPU fans stop spinning, and basically shut off my screens for several minutes.... then kicks me back to where I left off with a black preview window in my Premiere Pro.

    I'm not asking for Premiere Pro to…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Hi could you do an update to use all possibilities of 3090 EVGA FTW 24 go graphic card on premier pro? It will be help user to work better

    Hi could you do an update to use all possibilities of 3090 EVGA FTW
    24 go graphic card on premier pro? It will be help user to work better when we use plugs

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  3. BUG: Input LUT Broken on GPU Render

    The input LUT function (interpret footage->color management->input lut dropdown) Doesn't do anything if you have GPU rendering enabled. If you switch to mercury software playback the LUT loads but it is not loading if you use mercury playback GPU.

    Steps for bug:

    1. Input log or really any footage
    2. Set input lut
    3. Footage remains unchanged. ..Tested an XAVC and an h.264 file with no luck. ..
    4. Switch to CPU render and the input lut works!

    It's a bug....

    Specs:

    Latest Stable Premiere Pro (v 22.0.0 build 169)
    Windows 11

    Nvidia GTX 2080ti 11GB Driver 472.39
    3960x Threadripper
    128GB RAM
    RAID storage.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  4. GPU hardware acceleration fix of black source & program viewer.

    For years, there's the issue, of black source and program-monitor, when using CUDA. Mostly with added effecs like lumetri-color or when using a browser at the same time. A second and third screen which is connected to the USB-C output of the nvidia card, could be an issue as well. There is no fix. Updating drivers and Premiere versions won't solve the problem. For years! So please make this a priority. Higher data-rates demand stronger hardware, but it's useless, if the software cannot handle it.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  5. GPU

    Improve GPU Support.

    GPU acceleration randomly disappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  6. GPU

    GPU acceleration randomly disappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  7. GPU

    GPU acceleration randomly diappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  8. GPU

    GPU acceleration randomly diappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  9. GPU

    GPU acceleration randomly diappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  10. black screen preview, from overflown RAM

    so, I know many many many users have the same issue in different variations with different GPU's.
    I have computers with 2080 Ti and RTX 3090. two very capable GPU's. However they both suffer from premiere totally overloading the RAM when working with 8K footage or 4K footage with effects. once the RAM is overflown, the preview image goes black and only a computer reset is fixing it.
    this issue has gone on for YEARS. it simply must be possible to fix this behavior once and for all?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Hardware Acceleration for HDR

    Enable the Hardware acceleration on NVIDIA 3090 cards for HDR/High10.

    Currently Adobe Premiere Pro supporting hardware accelecrtion for SDR contnet only, it's the time to add Hardware also for HDR content.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  12. Fix graphic card support and working with pictures

    When I work with photos playback is horribly choppy, changing graphic cards ruins placement of pretty much every element.
    Fix premier pro! Its unstable and unreliable and honestly a pain to work with. redoing every step takes so much time atm that learning davinci resolve is actually quicker! Thinking about quitting my adobe account all together

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  13. Premiere artifacting possible GPU issue?

    Hello,

    I've been having issues with Premiere for quite some time, that seem related to the GPU. My program monitor keeps glitching and giving me really crazy colours and artifacting. I've attached a few screenshots.

    I'm using a MacBook Pro and have all my software up to date. The problem has shown in both Premiere 2020 and 2021.It also shows on both my external and built in monitor. I've reset PRAM and my SMC.

    Is this a known problem?

    Cheers,

    Ryan

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  14. PLEASE Support the AMD Radeon Pro 5500 XT graphics

    Please fully support the AMD Radeon Pro 5500 XT graphics for Premiere and show some love for your Mac customers. This GPU is found in the latest 2020 iMacs - this is critical for thousands of people. Thanks!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  15. Make all effects including the basic ones support gpu acceleration

    I would like to have all effects including basic ones, because i dont like a that adobe has made lost of marketing on gpu acceleration yet not all of the effects have gpu acceleration support.. particularlly the blur effets like "Bevel Edges" for example. I still think that all effects including the basic ones should take advantage of gpus

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  16. Nvidia quadro K4100M fails - fix it or we are leaving

    Uses that edit on Pr can't get to use the App anymore. My Nvidia Quadro K4100M, fails to be seen.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  17. PROBLEM WITH H.264 MP4 FROM SONY A7SIII

    Some how premiere pro not using gpu when play back h.264 mp4 422 10bit from a7siii but for h.265 mp4 422 10bit is using gpu more than 50%

    so i thing premiere need to use h.264 mp4 422 10bit 4k gpu same as h.265.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  18. GPU acceleration problem

    Before the premierepro ver 14.5, the hardware encoding and decoding option of the media tap is just one.
    At that time, there is no problem with exporting media. the GPU usage was over 90%.
    From the ver 14.5, the hardware encoding and decoding option are splitted.
    If I use the two options are on, premierepro expoting engine couldn't use GPU anymore while the GPU usage is over 90% when the encoding option is on and decoding option is off.

    The same problem goes on at the ver 15.0.
    Anyone experienced same problem?
    I think it is a bug.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  19. GPU Bug on Version 14.7 / 14.8

    Pr Pro running on Windows 10 Pro - Version 14.7 + 14.8
    Ryzen 3600 + GTX 1650 Super 4GB + 64GB 3000MHz + Everything Premiere-related on different Sata SSDs / M2 NVMe SSDs

    Overusage of the GPU: Extending clips or elements on the timeline creates lag of the whole computer due to GPU being used at 100% - Mainly on 14.7, no solution found.
    GPU freezes every now and then during playback (black screen but audio still plays back) - Solution: restart premiere.

    Edit: these problems occur mostly when working with 8bit and 10bit H264 footage. No issue when editing…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Premiere Pro 14 (2020) constant crashes when using GPU, Lumetri Bugs

    Premiere pro 14 (all versions) are unusable when mercury OpenCL acceleration is being used as it crashes the application. I'm stuck with version 2019. HW acceleration works albeit some functions such as applying LUT's and changing highlights, matching colors, contrast are unusable with real-time acceleration, leading to a black screen. I have to switch between software and OpenCL, giving me 7 hours of render times for a 5 minute color correction using Lumetri. Please help.
    GTX 470, High Sierra 10.13.6,

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 6 7 8
  • Don't see your idea?

Feedback and Knowledge Base