Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Bug in Premiere Pro - version 14.5.0

    I updated to the latest version today, Oct. 21, 2020 - - whenever I am working in a project in Premiere, and then close the project to open another project, ALL keyboard shortcuts stop working. I have to completely quit Premiere, and reset preferences (hold "Option/ALT" upon launching) for the shortcuts to be restored.

    And then if I hop to another project, again, the shortcuts stop working.

    I have zero custom keyboard shortcuts; all of the shortcuts that cease to work are the ones native to Premiere.

    Premiere Version: 14.5.0

    Working on an iMac Pro 2017
    macOS Catalina - 10.15.7

    8 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →

    Sounds scary; we’re not yet able to reproduce that behavior, here.

    Confirming: In Preferences —> General —> Most Recent, is yours set to show the Home screen (the default behavior), or have you changed the pref to “open most recent”?

  2. Performance Issue with RED Files over Network and Mercury with CUDA

    Dear Adobe Community,
    we have a problem in our company with the playback of RED material. In the following I describe the behavior of Premiere Pro when playing back 8K r3d data. But this also affects footage from 5/6K.

    First of all about hardware and infrastructure. We have a server with a raid controller (Adaptec 81605zq) which provides 16x4TB Samsung Evo 860 in RAID6. This is connected to the switch by means of 4x10GbE bundled over fiber optics. From here our workstations are connected via 10GbE copper cable. The server runs with MS Server 2016, the workstations with Win 10…

    6 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  3. Fix Audio Previews/Rendering

    Currently, Premiere Pro has no indicator for audio rendering, and appears to render all audio prior to starting playback, causing lag spikes upwards of 20s with a large multi-track file.

    This would be okay, if somewhat annoying, if Premiere actually cached and retained this audio after this first time. However, that is not the case. Premiere does not cache the audio to disk, and will discard all of it immediately if you so much as click out of the program for half a second, causing another 20s lag spike before you can start playback again.

    Additionally, people have reported related…

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  4. Creating Proxies for 120p footage creates 60p proxies?!

    I have footage filmed at 120p, 60p and 24p in a sequence. They are all HEVC 10 bit 422 so naturally, the computer is having trouble playing them back, so I waited all night for Premiere to create proxies. It worked fine for the 24p, did that automatically. Did fine for the 60p, did that automatically. However, for the 120p footage, it ignored that it's 120p and just created a bunch of 60p footage, so when I turn on the proxy, it jumps to different areas because the actual footage is 120p!!

    Obviously this is a problem since it means…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. Premier Pro is Crashing (PC overheating/Memory overflowing)

    What the **** is happening with Premiere Pro?
    Ive been using it for about 2 months, and until 3 weeks ago, it started to OVERHEATING AND MEMORY OVERFLOWING!!!!!
    WHY?
    FIX IT!!! IM PAYING FOR THE MOST USE APP IM USING IT!!!

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  6. playback

    playback lag in version 14.3.1 and 14.3.2
    all my projects were playing fine, but with this version, jkl playback often have a 4 seconds lag, even at 1/8 quality. Had to revert to previous version 14.3.0 and the playback is perfect with this version.
    rtx 2080
    64g ram

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  7. Link Media window not showing up

    This issue is hard to explain, so please bear with me. I'm running the lastest Premiere Pro CC on Windows and when my media gets disconnected and I right click that media in project window, my whole Premiere freezes (like it's waiting on some action). It took me a while to figure out, but if I press Esc everyting gets back to normal.

    It feels like Link Media window "opens" in the system, but I do not see it anywhere. Same issue with Attaching Proxies, I can't see that window pop up. After some research, nobody seems to have this…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  8. Mac Pro 2019 / Vega 32GB / 16 Core poor performance with mp4 /h264

    Its a misery / mystery how slow Premiere renders and feels while editing compared to other NLE Editing Softwares like Resolve or FCP X.
    I am using Premiere since + 10 years and it feels outdated to be honest.
    Adobe Please don´t add any more features just clean the code and concentrate on performance.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  9. Markers Apply Slower and Slower the More Markers are Applied

    I use the markers panel extensively and I'm noticing recently that as I place more markers, it takes more and more time for the marker window to pop up. I'm half way done typing my marker text before it pops up. The clips I work with are LONG so this delay gets unbearably long. Not sure if this is new with the latest version or if I'm just noticing it now, but I JUST upgraded my CPU to Ryzen 9 3900X 3.8GHz, partially to mitigate this issue, running on an SSD using Windows 10, so it's not a hardware issue.…

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  10. BUGS GALORE IN LATEST 2020 UPGRADE

    Just upgraded 2020 Premiere Pro CC.


    • Displays unset, opens project with "media offline" billboard. 4K ProRes (HQ) media is right there, green lined, in the timeline.

    Attempt to play yields only audio.

    Requires some massaging to get the main display back, in Preferences. I'll have to backtrack ot enumerate the steps. Someday when I have time.


    • Low level exception errors while rendering under Metal on 2013 Mac Pro D500's. Source is ProRes (HQ) 4K. Worked perfectly just before the upgrade.

    Any other surprises?

    PLEASE PLEASE TAKE TIME TO TEST YOUR ENGINEERING CHANGES THOROUGHLY, OR FIND OTHER WORK INSTEAD OF DISRUPTING…

    8 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  11. error message Frame substitution

    I was editing all day then I got an update to 14.4 ALL my video clips on the time line went black I got the error message Frame substitution. I am in the middle of a project for a client and can not afford any delays. I can not see any of the footage and any on the timeline . HOW DO I FIX THIS !!!???

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  12. New sequence dialogue box not fitting on my 14" laptop

    I am a student working on premiere pro from home. I have a 14" laptop and the dialog box for "new sequence" is to big for my screen i cannot click "ok" to confirm my changes.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  13. New sequence dialogue box not fitting on my 14" laptop

    I am a student working on premiere pro from home. I have a 14" laptop and the dialog box for "new sequence" is to big for my screen i cannot click "ok" to confirm my changes.

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  14. Please fix flickering play-head resulting in inactive timeline

    Still getting this flickering playhead issue. My interface basically become inactive when this happens. I've done everything: Update graphics card, updated Adobe Premiere and reworked my cache and ram. I've configured the graphics on the computer for Premiere and udated the C++ preview files. There is really no workaround for this? (Video of what is happening attached)

    Work Computer:

    Windows 10.0.18362

    Ryzen 7 2700 Eight-Core

    16 GB Ram

    AMD Radeon RX 580

    35 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    8 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  15. Insufficient Memory Error

    I have come across an error in Prem 14.3.0 (see attached)

    The insufficient memory error occurs when I'm trying to copy, move, or basically do anything in the project. This will usually happen after a couple hours of usage, or a shorter amount of time if im doing a lot of exporting/rendering/more intensive work.

    Once the error occurs i cannot copy/move or do much of anything in the project. Its almost as if it turns to "read only". Although I am on a solo PC and I do not use Team projects.

    To get rid of the error and continue…

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  16. Adobe Listen to feature requests

    My Feature request is for Adobe to Listen to feature requests and not ignore their users

    5 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  17. BUG and CULPRIT FOUND

    After Updating from PP 14.3.1 to 14.4.0 an big issue was happening to my system. Premiere pro was not using my graphics card at all. after clearing the cache and uninstalling and reinstalling and of course updating ot the latest studio driver for my 2080ti it still did not fix any of the issues with he sept 2020 update.

    so i downgraded back to 14.3.1 and kept all the other apps up to date and viola! the issue is resoleved!

    Please Adobe fix the issue!

    my render speeds are back to normal

    in my previous post you can see I…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  18. error message Frame substitution

    I was editing all day then I got an update to 14.4 ALL my video clips on the time line went black I got the error message Frame substitution. I am in the middle of a project for a client and can not afford any delays. I can not see any of the footage and any on the timeline . HOW DO I FIX THIS !!!???

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  19. Skip new features for next release and focus only on bug fixes and speed issues

    Focus only on bug fixes and performance will make a big announce to professional community !

    Not only it will help adobe to gain back the trust with all users, it will send a strong message to the industry.

    A lot of people are switching to other software, the time that took dev teams to fixes all the bugs is too long. On Premiere working on a advanced project that is longer than 8/10 minutes seems impossible now...

    Many influencer and creative people are switching to Resolve as it gets better and better... as Phillip Bloom and others...

    I think…

    10 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  20. Adobe Premiere Pro 14.3.1 crashes Windows 10

    After the upgrade to 14.3.1, opening Premiere Pro, and adding any media to the editor results in my whole Windows system crashing. Checking Task Manager, it looks like Premiere Pro was running up memory usage out of control. Downgrading to 14.3.0 fixed the issue.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 19 20
  • Don't see your idea?

Feedback and Knowledge Base