Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. There is a problem with built in 1440x1080p settings

    I created a new sequence in HDV 1080p 30 fps settings.
    its frame size is 1440x1080.

    But its playing in 1920x1080 resolution.

    I exported the video and checked the details. Even then, its details are showing as 1440x1080.
    But when i open it, its playing in 1920x1080.

    But when i create a custom sequence with 1440x1080, there is no problem. The problem is only with built in settings.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  2. There is a problem with built in 1440x1080p settings

    I created a new sequence in HDV 1080p 30 fps settings.
    its frame size is 1440x1080.

    But its playing in 1920x1080 resolution.

    I exported the video and checked the details. Even then, its details are showing as 1440x1080.
    But when i open it, its playing in 1920x1080.

    But when i create a custom sequence with 1440x1080, there is no problem. The problem is only with built in settings.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  3. Bug PP 2020 Interpret Frame Rate results in scrubbing errors

    On files where I change frame rate via "modify/interpret footage" resulting clips have errors while scrubbing on the timeline (skipping back and forth in file). If I simply change the speed via the speed setting on the timeline, the file scrubs fine. Any ideas? I made a video where I tried to show this happening:

    https://youtu.be/MjEDyjPbZUg

    Windows 10

    CC2020 14.1.0

    RTX2070 super 442.92 studio driver

    21 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    9 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  4. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  5. Bug - after making a cut in timeline, audio cuts out, can undo the cut and audio is back but what's the point of this editing software then

    It's just happening to this project so far but it's very frustrating. I make a cut and everything ahead of the cut loses audio. I can undo the cut and audio is back (but then I can't edit forward without matching frame, dragging clip into new sequence and continuing that was which is annoying). I spent a long time trying a dozen things with the adobe chat customer service thing and nothing worked. Interestingly, I can export the section that's lost audio and the export has audio, so I guess it's a playback issue or something. I've attached screenshots just…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  6. IPlayback (preview) performance is unuseable.

    I am trying to make the swith from Vegas Pro to Premiere Pro CC 2021. My very first sequence with hi-res photos and the Ken Burns effect is virtually unplayable in the preview window.

    Device name DESKTOP-V621RQK
    Processor Intel(R) Core(TM) i9-10980XE CPU @ 3.00GHz 3.00 GHz
    Installed RAM 64.0 GB (63.7 GB usable)
    Device ID 3BBEC8D6-F7CE-46D9-B582-6E26736E84BB
    Product ID 00391-50000-91260-AAOEM
    System type 64-bit operating system, x64-based processor
    Pen and touch No pen or touch input is available for this display

    NVIDIA Quattro RX 4000

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  7. time remapping

    When I adjust time remapping on a clip it shows a different clip in playback ... I am only able to see the clip if I nest it and then time remap it ...

    I am up to date on my Mac and my adobe ... please fix this!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  8. Fix the issue with the Renderer

    Since downloading PP 2021, I am forced to use 'Software only' Renderer... If I use the GPU accelerated (which worked fine in previous version) then the Monitor screen goes entirely black occasionally, plus every time I try to export it will get stuck. This now means I cannot even export my video because it uses GPU requiring effects.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  9. Bug fix for choppy playback in V15.2.0 Build 35

    I haven't been able to edit anything 4k H.265 since the new update last week.

    Not even using proxies.

    My setup is:
    Microsoft Windows 10 Home
    Version 10.0.19041 Build 19041

    Processor AMD FX(tm)-4300 Quad-Core Processor, 3800 Mhz, 2 Core(s), 4 Logical Processor(s)

    Installed Physical Memory (RAM) 32.0 GB

    GPU 1: NVIDIA Quadro M2000 (Primary)

    GPU 2: NVIDIA Quadro K2000 (Secondary)

    Adobe Premiere Pro V15.2.0 Build 35

    It meets the minimum specs so should work.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  10. Speedramp in Premiere Pro 2020 is a mess

    Speedramping in Premiere cc 2020 let my eyes bleed like ****.
    No smooth, but cruel lagging while playbacking the speedramped clip.
    The rendered file however is fine.

    Fix that as soon as possible, before I went out of blood.
    Thanks

    71 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    21 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  11. Add Chromecast to video output list

    Add Chromecast support so we can have Premiere send video/audio to devices on the network that aren't hardwired. I'd add it under Preferences>Playback>Video Devices, where you have NDI which would do the same thing, but with far fewer existing devices to attach to. Not looking for uncompressed, color accurate, professional streaming. Just want to be able to toss the output to the living room.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  12. 音声自動認識テキストについて

    アイデアではないですが、まず喋り始めの字幕が4〜5フレーム程ずれてて、誤字はどうしてもAIなのでしょうがないかなと感じました。
    音声自動認識でテキストが文字起こしされるのは良いですが、範囲制限やレガシータイトルとの連携が出来ないとかなり使いづらいです。
    初めの字幕ズレだけ改善して頂ければ今後作業の効率化に役立てて良いと感じました。

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  13. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  14. Mercury Playback screen not updating when opening new sequence

    I am running an external display off my 16" Macbook Pro and using the MBP display for Mercury Playback. I have a key command set up to toggle Mercury Playback on and off. When Mercury Playback is on and I double-click a sequence in a bin to open it in the timeline, the screen doesn't update - it stays frozen on the last frame of the previous sequence. I have to toggle Mercury Playback off and on again or click another timeline tab. This issue started with version 14 but having the same problem with 15.1 on Mac OS 10.15.7

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  15. Bug in Premiere 15.0: Canon R5 8K RAW files crash Premiere

    With Premiere 15.0 playing back Canon R5 8K RAW files results in a crash. It was working pretty good in Premiere 14.9, but after Premiere 15.0 update a total disaster. And now even after installing Premiere 14.9 problem persists. Before the update I was able to playback 8K raw files in full resolution with minimal dropped frames. Only selecting High quality playback usually resulted in a freeze or a crash.

    My PC specs:

    AMD 3960X
    64GB
    Nvidia 2080 TI

    On my HTPC that has AMD 3900X, 64GB and Nvidia 3090 playback is fine, although it can only play in 1/2…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  16. Add real-time rendering

    There needs to be an option added to have background real-time rendering enabled for Videos and Effects. It is very annoying to manually render each item, or the whole timeline and wait long minutes (hours) for things to render on high end PC's. Apple's Final Cut Pro offers real-time rendering and makes workflow and playback MUCH easier.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  17. BUG - Premiere Pro 14.6.0 FREEZE

    It's happening more often than usual. To reproduce the error you must be working for a couple of hours within a file (large or small it doesn't matter). After a while it will freeze the entire software (including the mouse cursor) if you just hit playback - EVEN if you already pre-rendered that part (green bar is up).

    Never had this problem before this update 14.6.0.

    Also, Premiere just freezes when you hit playback, so if you manage to stop the playback you will be able to save your work and exit the program (which will not solve the issue).…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  18. Scrubbing issues - Showing incorrect portion of footage

    I am having series scrubbing issues after interpreting footage.

    When I interpret 8bit .mov 60fps clips to 24fps from the GH5, the footage becomes completely useless. I can no longer scrub the footage and see the actual portion of the clip. The viewfinder shows the incorrect frame. Also, speed ramping interpreted footage completely breaks the clip and it no longer plays back successfully. I have to delete and then reimport the clip.

    16 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  19. Losing Render Files PLEASE FIX I'm not sure why this has been deemed not actionable!

    Losing Render Files PLEASE FIX I'm not sure why this has been deemed not actionable!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  20. Playhead won't move when selecting markers

    When going through my markers and selecting different ones in the markers panel the played won't move through the timeline to where the markers are. I've tried restarting premiere and still nothing.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base