Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Bug report: Blackmagic Desktop Video 10.11.4+ break Premiere Pro playback

    I've just recognized an issue we have with Adobe Premiere Pro (tested on all versions from 12.1.2 up to current) where playback in a timeline gets paused randomly after anywhere between 2-5 seconds of playback. I tested with ProRes 422 and 422 HQ files and R3D files.

    We have a Blackmagic Intensity Pro card installed into this Mac Pro. So when I uninstalled the Blackmagic Desktop Video drivers, Premiere Pro ran flawlessly once again. When I reinstalled Desktop Video, I got the following results:

    11.1: issue persists
    11.0: issue persists
    10.11.4: issue persists
    10.11.2: issue FIXED

    So something broke somewhere…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Bug report: Blackmagic Desktop Video 10.11.4+ break Premiere Pro playback

    I've just recognized an issue we have with Adobe Premiere Pro (tested on all versions from 12.1.2 up to current) where playback in a timeline gets paused randomly after anywhere between 2-5 seconds of playback. I tested with ProRes 422 and 422 HQ files and R3D files.

    We have a Blackmagic Intensity Pro card installed into this Mac Pro. So when I uninstalled the Blackmagic Desktop Video drivers, Premiere Pro ran flawlessly once again. When I reinstalled Desktop Video, I got the following results:

    11.1: issue persists
    11.0: issue persists
    10.11.4: issue persists
    10.11.2: issue FIXED

    So something broke somewhere…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Update damaged playback

    Since update video does not play correctly. Audio plays properly.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. color shift when paused

    Density shifts when paused vs playing.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Comparision View should recognize if the reference timecode is in audio samples

    In Comparison View, inputting a timecode in audio-sample format into the reference side will move the playhead to the very end of the project because it interprets (for example) "00:00:00:47999" as "33:21:57:14".

    Comparison View should follow whatever timecode format the active timeline is displaying.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Adding a hotkey for 'playing a selected clip in the project panel to the source window' (rather than double clicking)

    In my current workflow on smaller video projects I generally prefer to assemble the edit straight to the timeline, which is a process that I can almost exclusively do on the keyboard (my preferred way of working), except for when I want to play a new clip from the project panel (in list view) in the 'source window', then I have to double click.

    Is there any way you could add the option to hotkey, so that when I 'shift+1' into the project panel, I could simply press another key to add the selected clip to the 'source window' (rather…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Play in to out

    Neither the button nor the keyboard shortcut for "Play In to Out" works in the Source monitor. This function is broken. This is a bug that needs to be fixed.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Correcting a play bug

    I've been working on a project that stops when I press the play button or space bar. I can do almost anything else but go back to playing the video. Luckily I can save the project and press the close button and it then tells me premier stopped working. I close it program and restart and it works. but only for a few minutes at a time. I've clicked on the button to notify adobe of the problem every time I turn it off.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Problems with playback of file from Blackmagic Duplicator 4K

    We have stage shows recorded using the Blackmagic Duplicator 4K unit and I edit in Adobe Premiere Pro CC 2019 (13.0.2). The files recorded by the Blackmagic Duplicator are H.264 1080 with a data rate of 7.09 Mbit/s.

    Playback in PP 2019 is glitchy (see screen shot). The file plays back with no problems in QuickTime. I did not have this problem until I upgraded to PP 2019. When I open the exact same files in PP 2018 (still installed on the same system), I have no problem.

    When I open files recorded a year ago on the same Blackmagic…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. playback noise from a nested no audio clip

    A segment of nested time-lapse clip has high pitch ringing sound overboard.
    but it's a silent clip originally, doesn't even have audio track
    Playback in the nested sequence / original is totally fine.
    but the parent sequence have noise while all the audio filters were removed / all attributes were reset,
    a certain part keeps ringing. I cannot even understand how can this happen when you have a no audio clip to start with.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. There is an issue with video playback

    There is an issue with playback in the Program window where the video "jumps" around. The source file does not have this issue and the sequence settings match the native video. This seems to be a bug. Nothing I've done fixes the issue and this is not the first video I've edited.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Fix playback issue with older mac book pro models and v13.0.2.

    Current Build and older macbook pros will not playback. Playback stops and audio continues whild program becomes very slow. Editing off a samsung T3. Disk speeds are 390+mbs read and 444+mbs write speeds. Plenty fast for 1080 footage. Never had a problem with previous build but now its dead in water.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. H264 HD Scrubbing problem, inter frame issue?

    Hi
    I have a major issue when i m scrubbing an H264 HD video (40mbit, Total file size 30GB).
    i tried on a PC with quat core 2,6 Ghz ram, 16MB ram, nvme hard disk.Quatro P2000 GFX

    And also 10core 2,4GHZ 32GB ram,ssd hard disk. Nvidia 1060 6GB.

    When i export the same file into mpg 2 30mbit I frame i have a smooth scrubbing.

    Is it a way to work with H264 HD on Premiere with smooth (frame accurate) scrubbing?

    P.s I work with Broadcast Quality and i want also a broadcast Quality with efficiency and fast paced workflow.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Audio (song) Displayed and appears to be playing with playback however no sound

    The audio seemed to have disappeared when i accidentally deleted a sequence from an old project. Unfortunately i've tried everything to get and audio whether it be a song or audio from a clip. I know the audio on my PC works as i can watch clips and songs. I also know the correct output driver has been selected for audio play back. This only became an issue when i accidentally button bashed on the sequence tab.

    Please help, i have spend literally 5.5 hours trying to fix this issue. I

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Fix Playback bug when using titles/graphics.

    When I am playing the video, once I run over some MOGRTS or graphics the screen turns black and when I pause it shows the image again. If I restart PP it will fix it for a couple minutes but then come back again. Very annoying.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. Premiere pro cc 2019 and 2018 have serious playback issues

    Almost immediately timeline and preview screen for clips do not playback AT ALL. Premiere pro becomes unusable AND IT DOES NOT PROPERLY CLOSE DOWN. I HAVE TO FORCE CLOSE EVERY SINGLE TIME. This is driving me insane and it all started happening when I got my Surface Book 2 i7/16/512 NVIDIA 1060. My old Lenovo with PPCC 2018 worked perfect. Both versions of PP have been totally unstable. PLEASE FIX IT IN SOME WAY!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. Track matte bug still there even after Adobe replicated the bug several years ago

    Track matte bug has been there for years. It might be easier to just rewrite the program and include Prelude, After effects and Audition in one program.

    https://youtu.be/7KzjlsKGX7E

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Track matte bug still there even after Adobe replicated the bug several years ago

    Track matte bug has been there for years. It might be easier to just rewrite the program and include Prelude, After effects and Audition in the program. https://youtu.be/7KzjlsKGX7E

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. 1

    Buenos días para reportar un bug en el Software Premier Pro Cc 2019 en el cual la previsualización tiene desface en el audio aún generando el render y en algunos clips el video no continua su reproducción normal si no que se repite generando un loop.
    Que solución pueden darme para este problema?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base