Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Scroll timeline, not jump

    I think it would be much more useful if the timeline would scroll during playback, keeping the currently displayed frame in the center of the panel rather than having the timeline jump. It becomes very annoying when trying to edit video or audio when zoomed in all the way and the current frame jumps off the screen when you play back. Also the sliders are not very good. I think it would be more useful to have a zoom and a scrub slider. If the timeline is zoomed in all the way, and the project is more than a minute,…

    11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Trim mode viewer doesn't display correctly in broadcast output

    When using trim mode or making slip and slide edits mercery transmit doesn't properly scale the image to my external monitor.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Main state of program monitor after restart

    PP 2018 loses the state of the program Monitor after a restart. e.g. Multi camera view resets to Composite monitor.

    As PP is not THAT stable and requires all-too-frequent restarts, it should at least maintain state over a clean application close and open.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Bug Report

    Serious Bug Report:

    For both Premiere Pro and After Effects I have found the same bug which has made it very difficult to use both programs. The Program monitor does not display the content it should be displaying unless it is set to a very large size (a larger size than I normally would set it to). What this has meant for me is that in order to accurately see what I am editing I need to use dual monitors and give the program monitor its own monitor and make it full screen. If I make it any smaller it…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Allow Proxies to Ignore Proxies Sound / Play Original Sound

    Ran into trouble using proxies that were generated without the same number of audio channels as the original source. Developed a number of workarounds to compensate, BUTl..

    ...if it's technically possible would it not make more sense to play only picture from the proxies and sound from original sources. In the it's not sound that typically requires too much throughput. It's picture. So the idea here would be to kill several birds with one stone:

    Eliminate the requirement for Proxy audio track counts to match those of the original -- in fact Proxies could be picture-only and save a bit…

    18 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. It takes 10 seconds to playback anything on OSX and iMac Pro

    I'm editing 4K footage in a 1080p timeline, with a $10,000 brand new iMac Pro, and every single time I hit the "play" button, it take about 10 seconds to actually play the footage. I'm using one of the fastest SSD's on the planet too (The Samsung T5's) and this is not an issue with Final Cut X. Please fix this and optimize your software for Mac's with the new OSX and AMD processors.

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. playback does not work

    Hallo everybody!

    The Playback does not start. I press the Playback button and the Icon changes (please see Attach file)but then nothing happens.

    13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. BUG: Weird anti-alizing on titles during play

    When using Essential Graphics Titles on any sequence, if I hit play, titles become bolder and have a really bad anti-alizing. If I pause or scrub, titles seem to have the correct size and anti-alizing.
    To overcome this I have to enable High Quality Playback which really makes editing difficult since it requires a very high-end machine.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. The audio in the timeline in P.P. CC cuts out randomly. My video file is small, with only 1 audio track. This just started recently.

    The audio in the timeline in P.P. CC cuts out randomly. My video file is small, with only 1 audio track. This just started recently. I have been editing with previous versions of P.P. and never had a problem. Is this issue being resolved?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Bug Report: Solo Tracks

    Hey sometimes Ppro is randomly soloing one Soundtrack without showing and is also exporting the solo track also in Media encoder

    My workaround is to mute and demute one track and evrything is fine :D

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. 8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Please make sure that, the premiere pro 2018 keeps on responding without any technical errors.

    It will have the benefit of editing more efficiently and smoothly, without any technical errors. I have recently purchased the bundle of the softwares , and only premiere pro is not responding, consistently when I open the app. I do hope that you fix this technical error and provide the best efficient way to resolve this issue.

    Thanks

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. In the latest update, 12.1.1, audio playback has become unreliable

    Often, audio tracks will not play as video plays.

    The issue can be solved by muting and then unmuting or soloing and then unsoloing channels. The problem is only present on playback, not on export.

    13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. Intermittent buzzing noise at audio cuts on playback

    On playback, I will sometimes get an extremely loud buzzing tone at audio cuts. It is intermittent as you will see in the attached clip. Current effects on the clip are a tube molded compressor, isotope RX5 dialog denoiser and a parametric eq. The same problem also occurs with no effects on the clip. The source footage is a mix of 4K prores 422 and 4K mpeg. Both are 24fps. The edit sequence is 24fps 1080. In the attached clip, you'll see the playback works correctly until around the :50 mark.

    System Version: macOS 10.13.5 (17F77)
    Kernel Version: Darwin 17.6.0…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Bug - Adding a layer with transparency requires sequence render

    Adding a clip with transparency (eg: An exported graphic from AE) onto track 2 (or 3, 4, etc), above a footage item, requires the timeline to be rendered before the transparency is visible. Without a sequence render, the graphic appears on a black background, as though an alpha channel is not present.

    Alternatively, you can use the Screen transfer mode as a temporary workaround.

    This is with the standard Lossless with Alpha export from AE (ie: Animation with alpha).

    1) Render a graphic from AE (with alpha channel)
    2) Add rendered graphic above a footage layer in Premiere
    3) Admire…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Auto scroll and Smooth scroll for Audio in source monitor.

    When you are cutting in a voice over from the source monitor down to the timeline, it is handy to use the keyboard only (i.e. 'i' to set in, 'o' to set out and ',' to insert into timeline, then 'spacebar' to play to continue playing. So, if i'm listening to a voice over, I like to see the wave form on screen to know when a gap in the Vo is approaching to set my our point before inserting the clip into timeline. If the waveform continues off the edge of the source monitor, the playhead disappears off as…

    20 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    13 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. In a multi-camera sequence, one "camera" can turn all black

    So basically one of the layers inside the multi-camera sequence just becomes black for some reason and stays that way unless you move the layer around. I've made a video showing this error here:
    https://youtu.be/vnK-PtWIYqY

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. Scrolling H264 4K (DJI, GH4, etc) in Finder is crazy fast but not in Premiere

    Playback and scrolling a 4K H264 video file in the finder is crazy fast. But import the same clip in Premiere and the scrolling is now painfully slow. Why?

    19 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Make render linking more efficient - or at least allow re-linking

    I've been having a lot of problems with render linking after closing and re-opening projects. I open a project and watched PPro build the render in the designated folder next to the project. Close the project and re-open it and it found the render fine. Close Premiere pro and re-open it and then the project - found some of the renders - but not all. Closed PP a second time and re-opened it - no renders at all. Tried this a couple of times with other projects saving all the time - same results.

    It's not a deal breaker, just…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Choose playback speed by default

    I would like my playback speed to be at x2 speed (for instance) , by default. I know the existence of the shortcut, but I'm sick of having to press the shortcut all the time. Similar to the preview option there is in AE.

    9 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base