Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. BUG: Playback and sequence editing breaks completely when 'Icon View' is used in media browsers

    Very simple, the entire sequence panel is rendered useless if 'Icon View' is used in the media browser. Using list view solves the issue. Video attached.

    I would consider this a major defect, as I've seen tons of forum posts which appear to be related, but no one seems to know what causes this or how to fix it. I only stumbled upon this fix by chance. Most people would not consider switching to list view.

    Specs:
    Software: Premiere Pro Version 12.1.2 (Build 69)
    Processor: Intel i7-6700k
    RAM: 32GB
    Graphics: AMD Radeon Vega 64
    Footage: 4K .mp4 files, using 720p…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Stop playback even while scrolling in timline

    Currently, hitting spacebar to stop playback is unresponsive while I'm scrolling (horizontally) in the timeline. It only stops playback if I'm sitting still (no scrolling). This seems an odd request, but I find myself in this situation a lot while trying to edit and scan quickly.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Smooth Scroll Playback Bug

    Win 10 Premiere Pro CC 12.2. When playback scroll settings are changed from page scroll to smooth scroll, playback becomes unresponsive. Cannot stop playback. Switching or minimizing application sometimes forces playback to stop but often will have to be force quit or wait out timeline playback to end. This issue has been unresolved since its implimentation at least on pc.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Allow lasso select to work while playing timeline

    While playing the timeline, I'd like to be able to lasso select different trims, by lassoing while holding CMD. This is great while the playhead is paused, however when doing this, it automatically moves the playhead to the selection, stopping playback. Would be great to be able to toggle that off so that I could make cuts during playback, lasso them and move them around, without having to have playback paused. Think about someone cutting a multicamera live show and working behind the playhead as it continues to move forward.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Bug - Now I can't play even two tracks of audio without massive dropouts.

    Only two tracks of audio, no effects. All audio matches project sample rate and is uncompressed. All video is rendered. Media is reading off an SSD.

    I've basically given premiere the easiest task it could ever have, but it can't play more than a minute without one or all tracks cutting out briefly or completely.

    Fully up to date Premiere. Mid 2015 MacBook Pro, so not brand new but should still be capable of basic edits. I tried changing my buffer size but it hasn't made any difference. Same with video playback quality.

    How has playback gotten this bad and…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. It takes 10 seconds to playback anything on OSX and iMac Pro

    I'm editing 4K footage in a 1080p timeline, with a $10,000 brand new iMac Pro, and every single time I hit the "play" button, it take about 10 seconds to actually play the footage. I'm using one of the fastest SSD's on the planet too (The Samsung T5's) and this is not an issue with Final Cut X. Please fix this and optimize your software for Mac's with the new OSX and AMD processors.

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Random color shifts in timeline

    There are random color shifts in the timeline without any effect on the video. When I delete the video previews files in the Adobe Premiere Pro Video Previews it fixes it briefly but it comes back even when that folder is empty. I've also deleted the render files and cleared out the media cache.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Random color shifts in timeline

    There are random color shifts in the timeline without any effect on the video. When I delete the video previews files in the Adobe Premiere Pro Video Previews it fixes it briefly but it comes back even when that folder is empty. I've also deleted the render files and cleared out the media cache.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Trim mode viewer doesn't display correctly in broadcast output

    When using trim mode or making slip and slide edits mercery transmit doesn't properly scale the image to my external monitor.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Main state of program monitor after restart

    PP 2018 loses the state of the program Monitor after a restart. e.g. Multi camera view resets to Composite monitor.

    As PP is not THAT stable and requires all-too-frequent restarts, it should at least maintain state over a clean application close and open.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. Bug Report

    Serious Bug Report:

    For both Premiere Pro and After Effects I have found the same bug which has made it very difficult to use both programs. The Program monitor does not display the content it should be displaying unless it is set to a very large size (a larger size than I normally would set it to). What this has meant for me is that in order to accurately see what I am editing I need to use dual monitors and give the program monitor its own monitor and make it full screen. If I make it any smaller it…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. BUG: Weird anti-alizing on titles during play

    When using Essential Graphics Titles on any sequence, if I hit play, titles become bolder and have a really bad anti-alizing. If I pause or scrub, titles seem to have the correct size and anti-alizing.
    To overcome this I have to enable High Quality Playback which really makes editing difficult since it requires a very high-end machine.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Bug Report: Solo Tracks

    Hey sometimes Ppro is randomly soloing one Soundtrack without showing and is also exporting the solo track also in Media encoder

    My workaround is to mute and demute one track and evrything is fine :D

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. The audio in the timeline in P.P. CC cuts out randomly. My video file is small, with only 1 audio track. This just started recently.

    The audio in the timeline in P.P. CC cuts out randomly. My video file is small, with only 1 audio track. This just started recently. I have been editing with previous versions of P.P. and never had a problem. Is this issue being resolved?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Intermittent buzzing noise at audio cuts on playback

    On playback, I will sometimes get an extremely loud buzzing tone at audio cuts. It is intermittent as you will see in the attached clip. Current effects on the clip are a tube molded compressor, isotope RX5 dialog denoiser and a parametric eq. The same problem also occurs with no effects on the clip. The source footage is a mix of 4K prores 422 and 4K mpeg. Both are 24fps. The edit sequence is 24fps 1080. In the attached clip, you'll see the playback works correctly until around the :50 mark.

    System Version: macOS 10.13.5 (17F77)
    Kernel Version: Darwin 17.6.0…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Bug - Adding a layer with transparency requires sequence render

    Adding a clip with transparency (eg: An exported graphic from AE) onto track 2 (or 3, 4, etc), above a footage item, requires the timeline to be rendered before the transparency is visible. Without a sequence render, the graphic appears on a black background, as though an alpha channel is not present.

    Alternatively, you can use the Screen transfer mode as a temporary workaround.

    This is with the standard Lossless with Alpha export from AE (ie: Animation with alpha).

    1) Render a graphic from AE (with alpha channel)
    2) Add rendered graphic above a footage layer in Premiere
    3) Admire…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. In a multi-camera sequence, one "camera" can turn all black

    So basically one of the layers inside the multi-camera sequence just becomes black for some reason and stays that way unless you move the layer around. I've made a video showing this error here:
    https://youtu.be/vnK-PtWIYqY

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Make render linking more efficient - or at least allow re-linking

    I've been having a lot of problems with render linking after closing and re-opening projects. I open a project and watched PPro build the render in the designated folder next to the project. Close the project and re-open it and it found the render fine. Close Premiere pro and re-open it and then the project - found some of the renders - but not all. Closed PP a second time and re-opened it - no renders at all. Tried this a couple of times with other projects saving all the time - same results.

    It's not a deal breaker, just…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Premiere Pro 12.1.1 on Windows 10 April 2018 Update causes video from Nikon D810 to appear pink

    When I import an .mov file straight from a Nikon D810, or open an existing project with a file as such, the program monitor shows the video with purple and green lines. The video plays back, but with the lines over the entirety. Audio is unaffected. The .mov files play normally in outside programs.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base