Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. bug premiere pro 2020

    bug report on premiere pro 2020: playback stop while playing on timeline and then display message: "A low-level excerption occurred in: Adobe Player (Player:11)" - then Premiere crash, and i have to force quit from force quit application. i'm working on a MacBook Pro (13-inch, 2017, Four Thunderbolt 3 Ports), 3,5 GHz Intel Core i7,

    109 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Under Review  ·  65 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  2. Bug Report: Speed Issues in Premiere 2020

    Any speed change that brings a clip over 100% speed results in choppy playback.

    26 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    27 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  3. Speedramp in Premiere Pro 2020 is a mess

    Speedramping in Premiere cc 2020 let my eyes bleed like ****.
    No smooth, but cruel lagging while playbacking the speedramped clip.
    The rendered file however is fine.

    Fix that as soon as possible, before I went out of blood.
    Thanks

    15 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  4. Latest 2020 Update results choppy playback

    Since I updated the latest version, playback has been very choppy even for a 1080p footage and timeline. I'm using a 8 core i9 9900k CPU with 64GB RAM.

    I have never faced this issues even with 4k footages for a 2 hours feature film timeline editing. It's very frustrating that Adobe did not provide 'Save As' to previous versions to at least be able to open the projects and 2019 or other previous versions.

    In addition, the Lumetri Colour panels are also showing errors 'AEFilter:14' very frequently. I have never run to such issues. I am not experiencing this…

    11 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  5. Premere 14.0 BUG: Distorted Videos during playback

    I'm having this strange problem with the newest release of premiere pro.
    Im usiging a 2080ti and AMD Ryzen 1800x with 32Gb ram.

    You can see that one image is distorted this happens only in playback but is pretty annoying since i can't edit with accurate results. Please Fix this

    You can clearly see the bad shadow in "Hello4" photo

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  6. Having a Multiview window for Video Tracks without having to create a Multicamera Sequence

    I think there should be a window for monitoring whats going on on your different Video tracks without disabling them or having to create a Multicam Sequence.

    6 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  7. Major Bug With Speed Ramping

    There is a major issue with Speed Ramping in the latest version of Premiere Pro 2020. I am unable to play back a simple clip that has a speed ramp applied to it in real time without pre-rendering it. When trying to playback a clip that is speed ramped, it turns into a glitchy mess, and the remaining clips that follow never start playing as they should unless I pause and restart the playback. This was never an issue in Premiere Pro 2019. I have re-downloaded PP2019 where the issue is no longer present.

    I have found that it seems…

    1 vote
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  8. Better Threadripper Support

    I have 2 PCs, 1 with an I7 6900x and 1 with the Threadripper 1950x and opening the same project , the Threadripper struggles in playback. Cant play 1080 footage (without effects) without dropping frames. CPU utilization is 30% max and GPU is 5% max. Both machines have a GTX 1080 ti

    154 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    87 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  9. PP 2020 poor high speed playback and export frame issue

    My updated Premiere Pro 2020 has poor juddery playback at high speed (over 100%)
    Also my main issue is the export frame function delivers a totally different grade and lightness to the original

    6 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  10. 2020 Multicam stuttering

    Bug Report - When playing back a multicam in the timeline at double speed there is awful stuttering present after about 5 or 10 seconds of playback. I am using proxies and the same exact workflow as the 2019 version and this was not present in that version. This makes double speed editing a hassle when it it used to be seamless and efficient. Please fix.
    Windows 10, 32gb RAM, GTX1060, latest Nvidia Studio Drivers.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  11. Bug - Playback Completely Glitchy

    Playback is totally screwy on this newest update. I noticed the issue becomes increasingly worse the more I shuttle using J-K-L to scrub through my footage. This is a huge issue since that is the primary way I have learned to quickly scrub. Upon a restart the issue goes away until I shuttle again at which point the playback goes kind of nuts and while the audio plays like normal, the video seems to be completely lost and switches between where it should be and some other random part of the video. Stopping playback doesn't even resolve the issue. Sometimes…

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  12. J-K-L Bug

    Playback fails as soon as I press J/K/L at double play speed, it locks in play position and I get "A low-level exception occurred: Adobe Player" error message. The timeline continues to play even after I close the project! I cannot recover until force quitting and restarting. Very time consuming and frustrating. Please help.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  13. IO hardware causes playback and pause delay

    This has been an issue for years. Please fix it!!

    When using Blackmagic or AJA hardware for mercury transmit output, the spacebar sort of lags for 8-9 frames. I.e. when you pause, the playhead goes on for another 8-9 frames. Avid does not have this issue with the same hardware. I guess you are never going to fix this because your development team sucks big time.....Seriously...fix it. I have been reading about this issue since 2010.......

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  14. Fix playback for imported iPhone video on desktop

    Even when using the exact settings as the original clip, the playback for footage taken from iphones will not sync correctly. Audio will be fine but the video will jump all over the place.

    I'm working in the most current version now, it also didn't work in the 2019 version.

    a simple .MOV file with 29.97 FPS.

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  15. Bug-Premiere Pro 13.1 Having an issue playing .mp4 files that played fine in 13.03

    Bug-Premiere Pro 13.1 Having an issue playing .mp4 files that played fine in 13.03

    20 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    10 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  16. Premiere Pro 2020 Mercury Transmit glitching (with Blackmagic Design hardware, SDI)

    There seems to be a mismatch between the latest 14.0 version of Premiere and the drivers for the BMD mini monitor (Blackmagic Desktop Video v11.4.1) which feeds into my Flanders Scientific reference monitor.

    When trying to playback footage in the timeline the monitor will glitch showing green frames and intermittent frames, also has trouble keeping up sync. The CTI also lags and stops with a delay in the timeline when transmitting through blackmagic hardware. This does not happen when transmitting to a regular external monitor. This is on a complete fresh install, already trashed preferences, trashed media cache, etc.

    Can…

    4 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  17. Waveform disappearing in the Timeline

    The audio Waveform is constantly disappearing and reappearing from the Timeline with this latest update v13.1.4 build 2. When I scroll left to right or zoom into the timeline, the waveform disappears and reappears without logic. As a result I am unable to visually edit to the audio piece and have to scrub through it to hear the audio instead.

    Please fix!

    9 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  18. [Bug] Premiere 14.0.0 No longer plays back Photoshop files with animated timelines.

    PSD files that are composed of PNG sequences, or animations that make use of the timeline function within Photoshop no longer play back properly within Premiere Pro 2020 v14.0.0

    3 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  19. BUG: Premiere Pro cc2020 (v14.0) - Audio Device Playback settings not working correctly

    Preferences/Playback/Audio Device:
    Select something other than "Adobe Desktop Audio", such as Blackmagic Playback, and hit OK to leave settings. Playback via Blackmagic then doesn't work and returning to Preferences has "Adobe Desktop Audio" selected again. This means that you can't use 'offsets' in the same panel to make your monitoring in sync.

    Tested with several Blackmagic drivers - always the same result.
    Re-tested with cc2019 and everything works fine.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
  20. [Workflow Breaking Bug] 14.0.1 - Animated Photoshop PNG sequences Do Not Play

    PSD files which contain animation data do not playback in the new playback engine whatsoever. This is across the board in all 2020 versions of Adobe software, including the latest update from today 14.0.1.

    This is a MAJOR bug, and we will not be able to use the 2020 versions of the software until it is fixed.

    2 votes
    Sign in Sign in with Adobe ID
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Playback  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 13 14
  • Don't see your idea?

Feedback and Knowledge Base