Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. DirectX 12 Support

    With windows 11, please add support to directX 12.
    The openCL in AMD GPU is obsolete

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  2. Premiere Pro 2021 taking several minutes to load media

    Prior to the Ver 15 release, my project would load very quickly. After the update, my project takes several minutes to load. I have tried two different iMacs, a brand new Mac Mini, and two different hard drives for the media. I have created a new project from scratch with new media. I suspect the issue involves the closed caption tracks and the new closed caption workflow. I capture my footage live and it has embedded closed captions that I need. Each show is between 1 minute and 5 minutes so nothing huge. After the project loads, it works fine.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  3. Check both Premiere and Media Encoder render times and performance compared to 14.3.2

    Many users realised that render times both in Pemiere and Media encoder changed due to the new render system implemented in versions newer than 14.3.2.

    In fact, this is the version in which everything works fine for me in render times. Even proxies render much slower than before (the format doesn't matter).

    I have tried every new version (even 14.5) and the problem is not solved. I use Premiere for years and I have checked every file in my system, formated, and so on... and nothing!

    It is not a hardware nor drivers issue. It is a new render system…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  4. my application freeze everytime I scroll in the timeline, and stop to freeze when the little pictures in the timeline appears

    my application freeze everytime I scroll in the timeline, and stop to freeze when the little pictures in the timeline appears.
    It's so hard to find somethink we looking for in the timeline with this issue...

    My PC :
    Ryzen 7 2700
    msi b450 gaming plus max
    32 Go 32000Mhz
    1660 super OC
    W10
    EDIT on CRUXIAL X8 SSD

    Thanks !

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  5. BUG: Sequence with nested sequence "visible in timeline" gives multiple problems

    Premiere 15.1.0 Windows 10 pro

    Whenever I have a nested sequence visible in my timeline PPro just doesn't react for a while. It seems that it is fully calculating what is in the nested sequence, even if the playhead isn't over the nested sequence.
    When I zoom in far enough in the timeline so the nested sequence is not visible, the problem goes away.
    When the nested sequence is visible in the timeline, scrubbing thumbnails in the project panel is not possible anymore. Also, rearranging clips in the timeline is a horror unless you zoom in really close in the…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  6. Thumbnails glitching in Project Window

    At the moment, creating a new bin while viewing files as large thumbnails I am unable to rename / name the bin at all. Additionally, I cannot re-order them other than clicking them to a grid. It would be nice for them to fill the size of the window in which I'm viewing them. Lastly, files are associating with differently named files and file types. I have deleted a jpeg that has somehow become associated with a mov file.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  7. Replace with after effects composition issue

    Different final (transparency object) opacity in Premiere Pro, when using "replace with after effects composition" function. e.g. 80% opacity in After Effects looks like 60% or even 40% in Premiere Pro. A bug that has been around for years.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  8. Slow timeline performance with essential graphics

    There seems to be a significant amount of dropped frames when playing back a timeline that has essential graphics overlays. Drops down to maybe 1-5 FPS, and doesn't recover until you pause and play the timeline again (even after the graphics have ended)

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  9. "Legendas" não esta funcionando, eu clico e fecha tudo.

    "Legendas" não esta funcionando, eu clico e fecha tudo. Queria usar a nova versão de transcrever a legenda automatica..porém nem no Beta e nem no Premiere PRO ta funcionando.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  10. Captions improvements

    I like how the captions has its own section, and it has a lot more features that make it easy to adjust and look just they you wanted. It works great when importing SRT files.

    I do however have some issues when do it within premiere pro. When you add captions the playhead moves to the start of the caption, and then you have to move the playhead to create a new caption. When creating 15-20 captions that becomes time consuming.

    There also seem to be some problems when you have the last caption. It is almost impossible to edit.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  11. Renders MIA after 24hrs

    Something always baffles me.
    Why is it I can render something (e.g. Render in to out) and my timeline indicates green. And the payback is fine. And the export is great (and fast). But the next day after I power-up and open the project my timeline is once again dappled with red & yellow sections?

    Why does PP lose track of the renders?
    In an Avid MC system once I render it, it’s done forever - unless I change a parameter or delete the media myself.
    So I find the unprovoked disappearance of rendered files not annoy annoying but terrifying.…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  12. Premiere Pro Corrupts Audio Waypoints After Saving and Reopening Project

    When I have a keyframed audio mix with handles, the handles are all skewed out after saving the project and opening later to resume work. This is most annoying.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  13. audio in nested clips cause issues 15.2 w10

    Audio in nested clips makes the UI partly unusable. Such as not being able to twirl down properties in the Effect Controls. Not being able to switch workspaces. Moving clips around.
    Delete audio and all is well again.
    I have encountered this issue and some reports of these issues seen on the main forum

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  14. Updated to 14.5.0.... LAG

    I updated to 14.5.0 and now my projects playback are super stuttery/laggy. CPU usage use to be 100% and now I get maximum 19/20%.

    All settings are the same and even reopened projects from months ago and it runs laggy and low CPU usage. I'm paying for a service which just had "upgrades" but ends up being unusable.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  15. Performance Issue with RED Files over Network and Mercury with CUDA

    Dear Adobe Community,
    we have a problem in our company with the playback of RED material. In the following I describe the behavior of Premiere Pro when playing back 8K r3d data. But this also affects footage from 5/6K.

    First of all about hardware and infrastructure. We have a server with a raid controller (Adaptec 81605zq) which provides 16x4TB Samsung Evo 860 in RAID6. This is connected to the switch by means of 4x10GbE bundled over fiber optics. From here our workstations are connected via 10GbE copper cable. The server runs with MS Server 2016, the workstations with Win 10…

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  16. Creating Proxies for 120p footage creates 60p proxies?!

    I have footage filmed at 120p, 60p and 24p in a sequence. They are all HEVC 10 bit 422 so naturally, the computer is having trouble playing them back, so I waited all night for Premiere to create proxies. It worked fine for the 24p, did that automatically. Did fine for the 60p, did that automatically. However, for the 120p footage, it ignored that it's 120p and just created a bunch of 60p footage, so when I turn on the proxy, it jumps to different areas because the actual footage is 120p!!

    Obviously this is a problem since it means…

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  17. Possible Bug? - Audio corrupted after auto-converting project file post upgrade v14.x>v15.x - Tested/verified on two machines/OS's

    Issue: Opened original, previously edited/arranged project file (created September 2020, v14.x) to add graphics. Using Mojave on a late-2015 iMac, PrPro is up to date, v15.2 and prompts to auto-convert the project file. Upon completion, the audio tracks for all clips are corrupted, only outputting noise pinned to around -3dB. The audio waveforms looked as expected, however. I tested and verified this issue again on my Win10 machine.

    Workaround: First I attempted a "Save As" and copy over the sequence etc. but no luck. So, I rolled back the install, or rather installed an older version (v14.9 LT Support) alongside…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  18. Bug: Premiere Pro 2020, copy/paste clip from one timeline to another crashes program

    Created new project in 2020 (14.6), imported bins and timelines from 2019 project via Media Browser. Copy paste clip from one timeline into another (with same settings - 1080p 23.976 Pro Res) crashes program. As you might imagine, this renders PP 2020 useless for me. Working in 2019 for now.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  19. Non Responsive App using Dynamic Link

    When I press replace composition with after effects the application will open AE and become non-responsive until forced quit. Even when I created a project in AE premiere pro still stayed non-responsive. Even after I finished my edit, saved, premiere pro is still non-responsive making the dynamic link currently useless.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  20. Delayed or unresponsive

    Whenever I'm in a project, everything (except the editor and probably the file storage space) will either delay its task(s) or become completely unresponsive.

    Computer: ASUS TUF
    Maximum pixels: 64-bit
    Processor: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx (2.10 GHz)
    RAM: 32 GB

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Performance  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base