Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Nvidia quadro K4100M fails - fix it or we are leaving

    Uses that edit on Pr can't get to use the App anymore. My Nvidia Quadro K4100M, fails to be seen.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. GPU Bug on Version 14.7 / 14.8

    Pr Pro running on Windows 10 Pro - Version 14.7 + 14.8
    Ryzen 3600 + GTX 1650 Super 4GB + 64GB 3000MHz + Everything Premiere-related on different Sata SSDs / M2 NVMe SSDs

    Overusage of the GPU: Extending clips or elements on the timeline creates lag of the whole computer due to GPU being used at 100% - Mainly on 14.7, no solution found.
    GPU freezes every now and then during playback (black screen but audio still plays back) - Solution: restart premiere.

    Edit: these problems occur mostly when working with 8bit and 10bit H264 footage. No issue when editing…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Premiere Pro 14 (2020) constant crashes when using GPU, Lumetri Bugs

    Premiere pro 14 (all versions) are unusable when mercury OpenCL acceleration is being used as it crashes the application. I'm stuck with version 2019. HW acceleration works albeit some functions such as applying LUT's and changing highlights, matching colors, contrast are unusable with real-time acceleration, leading to a black screen. I have to switch between software and OpenCL, giving me 7 hours of render times for a 5 minute color correction using Lumetri. Please help.
    GTX 470, High Sierra 10.13.6,

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Possible Bug with Exporting Mogrts Using Latest P6000 Video Card Driver

    I’m flagging up a problem with a recent NVIDIA update for anyone that is experiencing export problems.

    1. I’m using PPr/ Me 14.7 and Ae 17.5, running on an Intel Xenon w-2123 (3.60GHz) CPU and a Quadro P6000.

    2. I updated my Quadro driver from 460.89 to v 461.09 at the start of the week. Editing after on PPr was untroubled. I also made a couple of basic new Mogrts in Ae.

    3. All was fine for a day or so until I exported a project via Me that included one of the new mogrts made since updating my Quadro. The export hung…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Bug: video and audio are not synchronized

    when using AMD GPU with the latest ME & PR version 14.5
    update: the problem is still in the new 14.7 version. plz compare the two videos I uploaded.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Rolling Title GPU Acceleration Broken

    After spending all day testing and troubleshooting I have finally determined that the GPU Acceleration for Rolling titles is broken.

    I have 10 machines with 24 cores, 128GB ram and RTX 2080TI video cards running windows 10, latest premiere version with latest Nvidia studio drivers., SSD drives and 16GB fibre channel storage.

    I finally narrowed things down to a simple test and shot a little video of my screen so there would be no conflict with any screen capture software.

    If you make a 9 line rolling text everything works just fine, but when you add the 10th line the…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. how about premiere use both my GPUs not just one and less Processors. Media encoder uses both.

    how about premiere use both my GPU and less Processors. Media encoder uses both

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Please add support for NVidia GeForce 870M

    Razer, a popular brand of gaming laptops, marketed their Blade laptops as designed for video editing. It worked great until fairly recent updates of Premiere in CC. I now also receive a notice that the NVidia GeForce 870M is not supported. I have two editing machines that rely on that. Please add support. Thank you!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Bug Nvidia Quadro 2000

    Hi. I need a support for a problem detected on my Nvidia Quadro 2000. I was had Premiere version 2018 and not it happened this problem. Please help me! I already installed the old version of the NVIDIA driver and last version, but nothing happen. How can I fixed it?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Bug use Multi Display.

    英語が分からないので、動画を添付します。
    Premiereでマルチディスプレイ使用時、Premiereを最小化すると
    サブディスプレイに写していた画像がメインに表示され、
    その後、windows自体正常に操作できなくなります。
    再度Premiereウィンドウを最大化すると元に戻りますが不便です。

    ①Multi Display

    ②【PremierePro】minimize a window

    ③Bug Display

    https://photos.app.goo.gl/vtUEPgboGGMymNxPA
    (↑Google Photo)

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. Giving up

    I'm giving up with premiere. AMD 3900x, RTX2080 SUPER OC, 2 1TB
    NvMe SSD, 64GB RAM. A brand new editing beast and I cant playback a 1080x1080 one layer sequence without coloring or effects, nothing just the video played at 1/8 quality. my PC is good enough for that all settings are as they should to maximize the GPU and Cache. but is jumping 5 secs or 10 or 20 without displaying a single frame. I takes me a good 1 min just to get 1 frame in a sequence that comes from AE. Useless I tried Davinci and it…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Driver NVIDIA for two or plus GPU

    Hi, I'm trying out the DEMO version of Premiere 14.3. hardware acceleration does not work properly with 2 RTX 2080 cards with the latest drivers provided by NVIDIA. it works best with version 442.74. NVIDIA support therefore told me to write to you and report this to you, so that future updates to Premiere will fix this problem.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. ALLOW Older GPU to be utilized to increase performance of PREMIERE

    Is it impossible to use my GPU for my premiere pro? I have INTEL R HD Graphics 4000 and NVIDIA NVS 5400M ive already updated al drivers &CUDA

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. When the AMD Radeon Pro 5500m card will be supported? (MacBookPro-16)

    When the AMD Radeon Pro 5500m card will be supported? (MacBookPro-16)

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Sequence panel unresponsive

    Sequence panel goes completely unresponsive.

    I also correctly select the right gpu and then everything goes to ****. Took 4 hours to export what usually take 40 minutes. Making my workspace nearly unusable with this program

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. NVIDIA k3100m

    Unsupported video driver for NVIDIA K3100M

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. BUG: Mercury Engine GPU Acceleration Metal or Deprecated does NOT render imported transparencies correctly!

    Whether you bring in a QT w/ straight alpha (Animation Codec), or a dynamic link to the exact same After Effects comp, any colored transparency is totally wrong, and can only be remedied by using Software Only Renderer.
    I tested this on a MacBook Pro, iMacPro, and two Hackintoshes (using discreet graphics cards) in APP 2020 AND 2019. Same results. All systems were running Mac OS Mojave 10.14.3-.5.
    FIX THIS IMMEDIATELY!!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. compatiabilty with all drivers for windows integraded graphics

    its stupid that when i try tto install your drivers for your system that "your computer doesnt meet the minimum requirements" idk why but i didnt have this problem in 2019 and dont want it in 2020

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Scribbles

    hey guys, how are you guys guys my video he sometimes glitches, if he goes down just while editing it okay, but when I export these little scribbles go to the video.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. cuda related frame error

    I have a reasonably big project that include 4 documentary of 30 min each shot on multiple camera 2K and 4K with low resolution graphics.
    To be able to handle the 600Go rush and assembly of each movie, I had to split the master ppro project into one project for each movie. (otherwise I had crash and hours of lag like "media database" rebuilding or so.
    my problem is that due to the different size of footage, I have a lot of nested sequence in each movie, (to be able to apply properly some effect , lumetri warp etc...) but…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base