Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. BUG: Ever since version 12.1.x, crashes on open unless Nvidia support is disabled in favor of Intel graphics.

    This problem has been around since the introduction of 12.1 (12.0.1 worked fine) and has still not been fixed even though it's been many months.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. BUG: CUDA

    This was driving me nuts. Premiere throws a "This effect requires GPU acceleration", even though I have a sweet graphics card and Mercury is ON. Turns out it's when you add an effect to an ADJUSTMENT LAYER.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. GTX TITAN X

    Add GTX TITAN X (MAXWELL) TO SUPPORTED CARDS

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. GTX TITAN X

    Add GTX TITAN X (MAXWELL) TO SUPPORTED CARDS

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Certification for new Quadro mobile GPUs

    Please add support for and certify the new Quadro for Mobile Workstation GPUs - see attached.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. support gtx 660 sli

    Support for Nvidia GTX 660 in SLI

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. OpenCL renderer on Dell XPS 13 9360 is broken

    When previewing source or program using the OpenCL renderer on a Dell XPS 13 9360 (Intel Core i5 8550U, 8GB RAM, Intel Graphics HD 620) with Lumetri applied either directly to the clip or in an adjustment layer, only the green channel is passed through to the user. When switching the project settings to use Mercury Playback Engine (software only), it displays colors correctly. Additionally, when using a more powerful desktop computer (Intel Core i7 6850K, 32GB RAM, Quadro K4000, Tesla K10), OpenCL sometimes exhibits the same behavior. I have isolated the issue to Premiere Pro. All drivers are up…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Fix Error interactions between wave warp and vr effects.

    Fix Error interactions between wave warp and vr effects.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Bug of Prores Raw Decoding on AMD Laptops

    I'm using an AMD laptop made by ASUS which features Ryzen 5900 HS(with integrated GPU) & RTX 3070 GPU. I've installed the apple prores raw codec. Even if I tried to set Premiere Pro to only run on the RTX 3070 and I set the project to render on Mercury Engine CUDA, it still refuses to decode my Prores Raw footage.

    The only work around is to DISABLE the iGPU manually in device manager, and after the project is loaded in PR, we can enable iGPU again. This work around proves that the laptop is actually capable of playing and…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. I am having terrible problems trying to use Premier Pro with my new HP Spectre with Intel (R) Xe Graphics. Obviously compatibility issues.

    Please fix this compatibility issue with Intel (R) Xe Graphics! It makes it almost impossible to edit.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. Premiere Pro freezes when using GPU Accelerated renderer

    Premiere Pro occasionally freezes when exporting a sequence using the GPU Accelerated renderer, on Lenovo ThinkPad X1 Carbon (9th gen). It never recovers (need to terminate the process). This has been going on since approximately version 21. How can we troubleshoot this?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. NVLink causing GPU crashes with Premiere Pro

    Hey,

    I installed an NVLink connector for my 2x 3090s to use in my 3D workloads. I noticed a very consistent GPU crash "only" when using Premiere Pro with the attached setting turned on.

    I now have to disable it each time I'm using Premiere Pro, which is very unintuitive imo since I use it for other work.

    The crash makes my GPU fans stop spinning, and basically shut off my screens for several minutes.... then kicks me back to where I left off with a black preview window in my Premiere Pro.

    I'm not asking for Premiere Pro to…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Hi could you do an update to use all possibilities of 3090 EVGA FTW 24 go graphic card on premier pro? It will be help user to work better

    Hi could you do an update to use all possibilities of 3090 EVGA FTW
    24 go graphic card on premier pro? It will be help user to work better when we use plugs

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. GPU hardware acceleration fix of black source & program viewer.

    For years, there's the issue, of black source and program-monitor, when using CUDA. Mostly with added effecs like lumetri-color or when using a browser at the same time. A second and third screen which is connected to the USB-C output of the nvidia card, could be an issue as well. There is no fix. Updating drivers and Premiere versions won't solve the problem. For years! So please make this a priority. Higher data-rates demand stronger hardware, but it's useless, if the software cannot handle it.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. GPU

    GPU acceleration randomly disappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. GPU

    GPU acceleration randomly diappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. GPU

    GPU acceleration randomly diappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base