Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Mercury Playback Engine - CUDA Failed Renders - Quadro M1000M

    Until recently CUDA accelerated exports were no problem. Now they are. Every time I attempt to export with GPU acceleration turned on, the export fails. The drivers are up to date, exactly as prompted by the Premiere compatibility check. The only way to export without failure is to switch to "Software Only" and not utilize all the power of the HP ZBook Studio. Older drivers are not accepted (compatibility warning), the latest one (recommended) doesn't fix this issue either.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. NVIDIA GeForce GTX 1070 is not supported

    please support this powerful GPU

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Premiere must recover properly following display driver crash and recovery

    My display driver crashes but then instantly recovers. This probably happens more than it should and probably because I am a Windows Insider running the future version of Windows 10. The rest of the system recovers from this except for Premiere that now doesn't render the "monitor" and "program" outputs.

    Yes, the display driver should not crash; however, Premiere should handle such a case and recover when the driver recovers, especially now that we have hot-pluggable display adapters.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Bug with Intel HD Graphics 520 driver

    Premiere Pro CC 2019 has a bug with Intel HD Graphics 520 driver (v25.20.100.6326). Whether it is the ellipse mask, 4-point polygon mask, or free draw Bezier mask, the path does not show in the Program Monitor Window. Toggling on/off the Mercury Playback Engine will temporary show the path but only once. Then have to toggle again.
    Please fix it.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Premier do not recognize my Nvidia Quadro 4200

    I have two HP workstations with Nvidia Quadro 4200 and After Effects recognizes it and uses it with the ray trace 3d, but Premier and its Mercury Playback like Media Encoder do not recognize it in this 2019 version, you have one solution for this ????

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Illustrator accepts the Card for GPU Usage - Indesign does not ????

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Keep GPU (CUDA) Support for OS 10.12.6 in Premiere Pro. Please. I have a TITAN X 12 GB VRam and cant use it anymore with OS 10.12.6.

    Illustrator accepts the Card for GPU Usage - Indesign does not ????

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Cannot preview/ play real time after upgraded my GPU

    My new GPU is GeForce® GTX 1050 OC 3G
    preview cache shows none
    Is Premiere pro not support it?

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. 50 fps clips on 25 fps timeline slow motion (CUDA)

    Windows 10 x64. 1607 ltsb.
    Premiere Pro 12.1.2.
    50 fps GH5 clips on 25 fps timeline.

    When I use GPU (CUDA) in project settings and If I change clip speed to 50%, I don't get a slo mo. When I change GPU to Software only everything is fine.

    DNxHR files are fine in both situations. This issue is only with GH5 clips.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. No GPU acceleration on 2019 Mac Book Pro

    No GPU acceleration on 2019 Mac Book Pro using ADM Radeon Pro 5500 M . This worked on Monterey until recent upgrade to 12.3.1 Please fix this pronto.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. CUDA problem

    RP2022,RTX2070(GTX760 before),studio drive,win11(win10 before)
    defferent environment same problem.
    When i make movie whith cuda,computer stuck in sometimes,then the view window be black,i can't see the view but can heard sound.
    If i want to fix it,i can change the cuda to software render or restart pr.
    At same time,when i choose h264,i can't choose hardware,only software,i only use ame.that's a big problem for me.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Photos thumbnails don't appear when using GPU accelerated colors

    When enabling the "Display Color Management (Requires GPU Acceleration)" setting, photo thumbnails do not render/appear in the project/bin panels.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. GPU Management

    For users who have high end towers with multiple GPUs, it is not uncommon to run our main monitors off lower end GPUs, and drive other display devices with a high end GPU; it would be very helpful if we could select which GPU in the system to render with across all adobe apps.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. BUG: Input LUT Broken on GPU Render

    The input LUT function (interpret footage->color management->input lut dropdown) Doesn't do anything if you have GPU rendering enabled. If you switch to mercury software playback the LUT loads but it is not loading if you use mercury playback GPU.

    Steps for bug:

    1. Input log or really any footage
    2. Set input lut
    3. Footage remains unchanged. ..Tested an XAVC and an h.264 file with no luck. ..
    4. Switch to CPU render and the input lut works!

    It's a bug....

    Specs:

    Latest Stable Premiere Pro (v 22.0.0 build 169)
    Windows 11

    Nvidia GTX 2080ti 11GB Driver 472.39
    3960x Threadripper
    128GB RAM
    RAID storage.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. GPU

    Improve GPU Support.

    GPU acceleration randomly disappears since updating to Premiere Pro 15 (now on 15.4.1) from 14.9. When switching to another Premiere Project GPU Acceleration sometimes is not available anymore and grayed out. Restart of Premiere makes no effect. Only restarting of the PC helps but cannot be the solution. With 14.9. everything was ok - never had a problem. NVidia Driver is updated. Adobe Suite completely uninstalled an reinstalled.

    Unsing Windows 10 with the latest Update. Nvidia 1080Ti

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. black screen preview, from overflown RAM

    so, I know many many many users have the same issue in different variations with different GPU's.
    I have computers with 2080 Ti and RTX 3090. two very capable GPU's. However they both suffer from premiere totally overloading the RAM when working with 8K footage or 4K footage with effects. once the RAM is overflown, the preview image goes black and only a computer reset is fixing it.
    this issue has gone on for YEARS. it simply must be possible to fix this behavior once and for all?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. Fix graphic card support and working with pictures

    When I work with photos playback is horribly choppy, changing graphic cards ruins placement of pretty much every element.
    Fix premier pro! Its unstable and unreliable and honestly a pain to work with. redoing every step takes so much time atm that learning davinci resolve is actually quicker! Thinking about quitting my adobe account all together

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Make all effects including the basic ones support gpu acceleration

    I would like to have all effects including basic ones, because i dont like a that adobe has made lost of marketing on gpu acceleration yet not all of the effects have gpu acceleration support.. particularlly the blur effets like "Bevel Edges" for example. I still think that all effects including the basic ones should take advantage of gpus

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Metal Engine always renders 8 Bit

    have a MacPro 2019 (7,1) with two Vega II graphics with Premiere 14.5 on a Catalina 10.15.7
    I have 10 bit video files and while working with these files I see a lot of banding on the sky.
    I have tried different configs to understand the issue.
    My sequence settings use Maximum Bit Depth.
    When the Metal engine is ON, there is no diffrence with the OFF state at the Program Monitor.
    And when I render with the Maximum Depth / 16bpc the output is same, a lot of banding.
    But When I swicth my project settings to openCL. I…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base