Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. GTX 1080

    Frequent Cuda / black screens when trying to edit Sony XAVC / ProRes footage on a GTX 1080. Premiere you make it really hard to like you sometimes.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Integrated GPU problem

    Why does internal GPU working in 100% while nvidia gtx 970(in my case) is sleeping? - while rendering. I am using newest and updated premiere. Why noone is solving this?

    9 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  3. Please give us option to chose the GPU we want to route to.

    My internal GPU cannot not be used for Premiere, which is insane that I have an Nvidia 1060 in my laptop that can't be used.

    23 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  4. 1080p > 4K sequence Drastically improves GPU playback!?!

    BUG:
    Slow timeline playback (Non-optimised GPU Mercury playback)

    SOLUTION:
    Converting 1080p sequence to 4k sequence (in project setting)
    drastically improves playback of 1080p files!?!?! (and applying "Scale to Frame Size")

    I suspect that Mercury GPU is badly optimised, and once i up-res the sequence setting to 4k, the GPU is better optimised.

    Playback performance drastically improve (but playing reverse speed is still not smooth)

    Hardware:
    Asus GL502VS
    i7-6700HQ
    Nvidia 1070
    Latest drivers

    Premiere 2018 12.1.2

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  5. Add to the recommended video adapters to accelerate the GPU -> GTX1080

    Add to the recommended video adapters to accelerate the GPU -> GTX1080. A lot of users use these cards. Forums are overwhelmed with this problem.

    21 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  6. Premiere / Media Encoder lack luster performance on Macpro i9 VEGA 20

    It would be great if this could work properly - I'm not convinced it's using the the GPU to it's fullest potential - thread here https://forums.adobe.com/thread/2588266

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  7. NVIDIA GeForce GTX 1070 is not supported

    please support this powerful GPU

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  8. Premiere 13.0.1 Lumetri GPU Bug (Windows + Mac)

    There is a GPU glitch on Windows & Mac while using Lumetri with the latest version that is extremely annoying.

    You cannot color correct anything unless turning off CUDA acceleration.
    It seems to affect many people as well.

    To illustrate the problem I've captured it on video:
    https://vimeo.com/300699996

    My system specs:
    Windows 10 Build 1083
    Intel i9 7960X CPU
    Nvidia GTX 1080 Ti GPU
    Premiere 13.0.1

    Things I've tried:
    Reinstall everything
    Install the latest NVIDIA drivers
    Rollback to official supported drivers (411.63) with CUDA 9.2 for 13.0.1
    Clear Premiere settings & Cache
    The only thing that worked is to change…

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Sistem Comptability Report

    Good day. Today, when I tried to enter Premiere, I received a message stating that the wrong driver for the video card was installed on my laptop. My Xiaomi Mi Notebook Pro 15.6 "laptop. It has a discrete video card MX150 and integrated Intel UHD 620. The automatic driver search said that I had the correct driver installed. And I didn’t offer me to update it. I was scanned on Intel’s website and it’s so I didn’t specify what I need to update the drivers for the video card, although the driver for the Intel UHD 620 is specified in…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Nvidia drivers after 399 causing the 'black screen on pause' bug

    CUDA issues causing black screen on pause bug. I've tried every driver from 417.xx up to 425.xx with same results. GTX 770 WIN10.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Support NVIDIA GeForce

    I'm unsure if this is an Adobe issue or an apple issue, but I got this warning screen when I open the new premiere pro

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  12. Bug: Unable to engage GPU acceleration with AMD Radeon Vega 64 GPU

    When selecting options for playback and rendering in settings, Premiere/Media Encoder do not recognize the Vega 64 as an option for Open CL GPU accelerated rendering; forcing me to use the Mercury Playback Software in the application. (Drop-down menu is grayed out)
    All software, firmware, drivers, and the BIOS build have been updated to the most current versions. Projects have crashed on export/rendering even on minimal intensity export settings. Is there a solution for GPU detection in Adobe software or perhaps an alternative way to engage the GPU as the primary rendering system for Adobe applications?

    Workstation Specs:
    AMD Ryzen…

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  13. Why does Apple Metal not work properly?

    Metal is supposed to make rendering faster. So why is that when i turn it on, Premiere actually goes slower??? Would be nice if things actually worked the way they're supposed to.

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Premiere must recover properly following display driver crash and recovery

    My display driver crashes but then instantly recovers. This probably happens more than it should and probably because I am a Windows Insider running the future version of Windows 10. The rest of the system recovers from this except for Premiere that now doesn't render the "monitor" and "program" outputs.

    Yes, the display driver should not crash; however, Premiere should handle such a case and recover when the driver recovers, especially now that we have hot-pluggable display adapters.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  15. premiere pro cc 2019 not opening "could not find any capable video play modules. Please update your video display drivers and start again."

    premiere pro cc 2019 not opening and display the error: "could not find any capable video play modules. Please update your video display drivers and start again."
    My drivers are up to date and I tried everything listed on the forum.
    Installed cuda drivers too.

    Premiere 2018 opens fine. I uninstalled everything and intalled again but it's still not working.

    Desktop windows 10 pro with nvidia geforce GTX 1070 graphics card

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  16. Please Add Back Support for 2GB Ram GPU's.

    I have a 1050 2Gb in my editing laptop that can no longer utilize the GPU, this is Bottlenecking my workflow.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Problem with enabling a video card to a Premier Pro CC 2019

    I have ALIENWARE 15 R4 with GTX 1070 from a few days, but I can't enable my Graphics card to work with Premiere Pro CC 2019. I installed CUDA drivers but I have troubles with them.
    I check it in the task manager and see that when I'm in the Premiere Pro CC 2019, the laptop uses Intel HD Graphics card rather than GTX. The NVIDIA GTX is only used at 2-3 percent
    PREMIERE gives me an option to use the Mercury Playback Engine GPU Acceleration (CUDA), but although the option enabled, the premier continues to use the Intel Graphics…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  18. My NVIDIA GPU does not appear in Project settings (Only Mercury Playback Engine GPU!)

    My GPU is working but I can not select it in the Project Setting menu. Only Mercury Playback Engine GPU appears. I have run a GPUSniffer in the PremierPro directory, and NVIDIA GPU is seen.

    I have seen many threads on the same issue. Please fix urgently.

    9 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  19. better multi gpu suport , network farm rendering ,make more stuff run on gpu power ,

    when rendering my 2 gpu are working only at 10-30% and cpu at 100% make more stuff utilize and render faster and a

    16 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Errors with Mercury Graphics Engine (OpenCL) and RX Vega M

    I'm testing out a new Dell XPS 2-in-1 with the new Intel AMD RX Vega M graphics card, and I was getting some very bizarre results with exports. One particular export resulted in a zero byte file size and I had to switch the render to Software rendering, then render the sequence, and I was finally able to export it.

    Is there something inherently weird about the support for OpenCL and the Mercury Graphics Engine?

    PS. Don't ask me to update my drivers because I've done that.

    Thanks,
    Andrew.

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base