Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Premiere Pro 14.0.3 time remapping preview does not work if CUDA enabled and speed over 800%

    Premiere Pro 14.0.3 time remapping preview does not work if CUDA enabled and speed over 800%. In preview, the video play position jumps back and editing is practically impossible. If Video is exported, the problem does not exist. If CUDA turned off and software only used, the problem does not exist. If speed less than 800%, the problem does not exist. Using latest NVIDIA Studio Driver with GTX1080 and GTX1650. Please fix this problem.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  2. NVIDIA k3100m

    Unsupported video driver for NVIDIA K3100M

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  3. Fix Mercury Transmit

    Ever since updating to latest version of windows, Premiere Pro 2020 and latest stable nvidia drivers, mercury transmit is constantly crashing premiere pro. There is no warning... all of a sudden I get the windows spinning cursor and then Premiere shuts down. I am happy to discuss this problem with any tech or engineer at adobe. I have posted this several times in the user forums with no avail.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Please support CUDA under High Sierra for CC2020

    Please bring back CUDA support in AE, Pr, and AME 2020 for users who still are running these apps in High Sierra with NVIDA hardware and web drivers.

    It makes no sense to keep Open CL and remove CUDA. Both are deprecated but for many of us remaining on High Sierra until the new Mac Pro becomes available or AMD releases Big Navi, CUDA is still viable. Please return CUDA support for CC 2020 media apps during this interim period. Thanks!

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  5. Fix CUDA support (because currently, switching it on/off renders very differently)

    This has been plaguing me for years in Premiere.

    Enabling CUDA screws up various aspects of rendering.
    Here, you can see how enabling CUDA dramatically changes how text fades in:

    https://drive.google.com/file/d/1HaCqejvb2y7bRzDKZGrwdsMIVsf5wyhY/view

    10 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  6. INCONSISTENT PERFORMANCE & USAGE OF EGPU

    Premiere (14.1), of course, has the worst utilization of EGPUs. Sometimes it works, some times it doesn't, sometimes it uses 1/2 the power, sometimes it uses zero. Resolve works 100%, and maximizes usage always. Please update it so it utilizes hardware appropriately.

    Currently using MBP 2018, 2.6, 32G, Radeon 580 + EGPU with RX Vega 56 8GB

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  7. Sequence panel unresponsive

    Sequence panel goes completely unresponsive.

    I also correctly select the right gpu and then everything goes to ****. Took 4 hours to export what usually take 40 minutes. Making my workspace nearly unusable with this program

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  8. Black Video Bug returnsss

    I have a huge issue with Premiere Pro, the black video bug. i am trying to make a showreel, but like half of the previously rendered videos dont show, i can still hear the audio, but the videos just display as black... unless i turn off the CUDA GPU render option... but to render everything purely relying on the software aint an option.

    HELP PLEASE

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Continue to support Nvidia CUDA

    Please continue to support CUDA. There are hundets of thousend worstations out there running Nvidia CUDA cards and all of them can not use your up to date software. You abo is way to expensive to just lett all Nvidia users be unable to continue working with those almost new and very expensive Nvidia GPU´s.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  10. RTX 2070 (CUDA) Rendering Error in Versions 13.1.3 or Newer

    I'm using the latest Nvidia Studio Driver (Version 431.86) and videos will not render if graphics acceleration (CUDA) is turned on. Previews also often appear black. This anomaly does not occur in Premiere versions 13.0.3 or before. We tried reinstalling my GPU driver, transcoding my asset files, moving the project into a new sequence, and reinstalling Premiere 13.1.5...and nothing fixed the issue. We also tried to use the Nvidia Game Ready driver to no avail. Please address this issue in the next iteration of Premiere 13.1.6. Thank you

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  11. BUG: Mercury Engine GPU Acceleration Metal or Deprecated does NOT render imported transparencies correctly!

    Whether you bring in a QT w/ straight alpha (Animation Codec), or a dynamic link to the exact same After Effects comp, any colored transparency is totally wrong, and can only be remedied by using Software Only Renderer.
    I tested this on a MacBook Pro, iMacPro, and two Hackintoshes (using discreet graphics cards) in APP 2020 AND 2019. Same results. All systems were running Mac OS Mojave 10.14.3-.5.
    FIX THIS IMMEDIATELY!!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  12. compatiabilty with all drivers for windows integraded graphics

    its stupid that when i try tto install your drivers for your system that "your computer doesnt meet the minimum requirements" idk why but i didnt have this problem in 2019 and dont want it in 2020

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  13. Fix ISSUE with P.Pro 2019 NVIDIA GPU usage locking up entire system

    I'm running a GTX 980 and a 4790k. Prior to 2019 update, GPU usage was never an issue.

    Post-2019 update, Task Manager Shows 100% usage of GPU when just moving 1 slider in Lumetri Color. System Monitor also shows heavy GPU Memory usage.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Premiere 2019 still refuses to utilize dedicated GPUS on dual-GPU laptops

    I'm running a Surface Book 2 equipped with a GTX 1060 and Intel integrated graphics. While I have had no issues forcing Premiere Pro 2018 to utilize my GTX 1060, Premiere Pro 2019 simply will not do so, regardless of the actions I take to try and force it to do so. Some users seem to have been able to resolve the issue on desktops, but I have had no such luck on my laptop

    The options to enable hardware acceleration and CUDA rendering in Premiere 2019 DO appear, and all the boxes are checked--but Premiere 2019 still defaults to…

    10 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  15. better use of GPU for more effects

    Many sequences don't need anything off the GPU Accelerated Effects list, so the GPU just sits there unused while the CPU is chugging away.

    Please add things to the workload of the GPU so that the CPU doesn't carry the load if GPU resources are available.

    34 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  16. Mercury engine GPU Acceleration is not working on a pc with 2 GPU cards

    Mercury engine GPU Acceleration is not working on a pc with 2 GPU cards

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Fix CUDA support (because currently, switching it on/off renders very differently)

    This has been plaguing me for years in Premiere.

    Enabling CUDA screws up various aspects of rendering.
    Here, you can see how enabling CUDA dramatically changes how text fades in:

    https://drive.google.com/file/d/1HaCqejvb2y7bRzDKZGrwdsMIVsf5wyhY/view

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  18. eGPU is no longer used in recent update to Premiere

    Ever since installing Premiere 13.1.2, I get 0 eGPU utilization and dramatically increased render times because of this.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  19. Add Discrette GPU Decoding and Encoding

    Dear Adobe team !
    The most important in video editing software is perfomance and speed.
    I think if You add discrete NVIDIA hardware accelerated decoding of h264 and h265 files, it will really improve the playback in PP.
    Also if You add NVENC support for encode h264 - h265 it will really speed up the render procedure.
    This what is done by Your competitors and this is one of the most big reasons why editors swith to Davinci Resolve etc.
    I think this is time to do it.
    I know that you working hard tgo bring a new functionality to…

    20 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Bug - Video wird im Programmfenster beim abspielen nicht angezeigt. Elemente und Text wird angezeigt.

    Das Video wird im Programmfenster nur angezeigt, wenn es abgespielt wird! Stoppe ich das Video, dann sind zwar alle anderen Elemente wie Text oder Farbfläche zu sehen aber das Video selber nicht mehr.

    Stelle ich auf"...nur Software" dann wird das Video immer angezeigt!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base