Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Metal Engine always renders 8 Bit

    have a MacPro 2019 (7,1) with two Vega II graphics with Premiere 14.5 on a Catalina 10.15.7
    I have 10 bit video files and while working with these files I see a lot of banding on the sky.
    I have tried different configs to understand the issue.
    My sequence settings use Maximum Bit Depth.
    When the Metal engine is ON, there is no diffrence with the OFF state at the Program Monitor.
    And when I render with the Maximum Depth / 16bpc the output is same, a lot of banding.
    But When I swicth my project settings to openCL. I…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Bug: video and audio are not synchronized

    when using AMD GPU with the latest ME & PR version 14.5
    update: the problem is still in the new 14.7 version. plz compare the two videos I uploaded.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. Include GPU in more calculations.

    When cutting videos in 4K, I can't watch the video smoothly because the CPU does all the rendering work and the GPU does nothing. And I want Adobe to improve that the GPU does more with rendering and cutting.

    10 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Composite In Linear Color nvidia update

    The most recent Nvidia driver update has affected the way my alpha channels were rendered where anything has a glow. Everything was fine the other day and then I updated my graphics card to 456.71 and suddenly the glows are very obtrusive and in places they shouldn't be. I had to turn off Composite In Linear Color to fix it.

    The only thing that has changed between opening the project last time was the Nvidia driver. I suspect a conflict has arisen.

    You can see in the screenshots before and after toggling off Composite In Linear Color.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. Rolling Title GPU Acceleration Broken

    After spending all day testing and troubleshooting I have finally determined that the GPU Acceleration for Rolling titles is broken.

    I have 10 machines with 24 cores, 128GB ram and RTX 2080TI video cards running windows 10, latest premiere version with latest Nvidia studio drivers., SSD drives and 16GB fibre channel storage.

    I finally narrowed things down to a simple test and shot a little video of my screen so there would be no conflict with any screen capture software.

    If you make a 9 line rolling text everything works just fine, but when you add the 10th line the…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. hardware acceleration

    enable hardware acceleration on GTX 1660 or offer another hardware acceleration system than CUDA that doesn't support all graphics cards

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Support MacBook Pro 2020 GPUs

    Why does Premiere Pro not support the actually used GPUs of the 2020 MacBooks like the AMD Radeon 5300M?

    I really don’t get it.
    I mean, the monthly fee for using the program is fair enough, but than I‘d expect to be able to use the full potential of an up to date MacBook Pro.

    For me, if Adobe will not include the actual GPUs, it would be a reason to switch over to Final Cut or Avid.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. CUDA Acceleration Displaying INCORRECT FRAMES

    Hello,

    I've now realized how many problems related to premiere have stemmed from GPU CUDA Acceleration, one of which being premiere displaying incorrect frames with both playback and scrubbing. In fact, it even shows the wrong portion of the entire clip, so all of my masking effects are out of place and make no sense. When I turn on Software Encoding, everything works fine but it's all at a snail-paced editing speed. I'm editing a music video and I have a lot of effects that require GPU Acceleration (along with a lot of speed ramping), so please please PLEASE Adobe…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. A low-level exeption occurred in: Adobe Player <Player:5) after todays update in Win 10.

    A low-level exeption occurred in: Adobe Player <Player:5) win10 - now no preview!

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Premiere Lumetri curves is hugely corrupted with new nvidia driver, my gpu is 1070 ti

    pretty much the title, it's not a idea, it's just that when using curves in Lumetri in my footage the result gets fully corrupted and broken, with some weird white squares.

    When rendering only in CPU this is solved, but preview time gets hugeeely slower

    when downgrading the driver the issue is also solved, but this isn't a optimal solution since it's best for every other application and even premiere to have the most updated drives. I attached a image file showing how this glitch looks

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. eGPU Support is Poor

    Out of all the major video editors, Pr Pro has the poorest support for eGPUs on Mac. Please enable your users with support your competition has. It is almost as if there are no added bonuses.

    26 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. OpenCL mishandles jpg files with embedded ICC profile

    When using OpenCL to help generate video in Premiere Pro and Encoder, jpg images with embedded ICC profiles display distorted, both in preview and in the final render. Generating the same jpg without the ICC profile with Photoshop ensures it's rendered correctly.

    System: AMD Ryzen 3700X, RX 5700 XT (latest drivers as of 26.11.19)
    OS: Windows 10 Pro, 10.0.18.362
    Adobe software: Media Encoder 14.0, Premiere Pro 14.0

    13 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. Make Premiere Pro use the GPU when playing back Canon CRM files

    Premiere Pro 14.3 and older do not use the GPU when playing back Canon CRM files on Mac OS. I have to reduce the resolution to 1/4th to get fluid playback.
    Canon RAW Developer and Davinci Resolve have no problem playing back the footage at full resolution on my Macs, so the hardware should be fast enough.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. Hardware coding MXF

    Hello, currently there is no hardware coding for video in format MXF.

    Will such functionality implemented in the future and when?
    Can you offer some alternative workflow for us?

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. BUG with Hardware Accelerated Encoding & Decoding

    When I enable Hardware Accelerated Encoding & Decoding my exported videos get distorted whenever the footage is altered with an effect, adjustment layer, or text, etc.

    Specifically, the color of the footage is automatically adjusted and distorted (usually it's more bland and "washed out".)

    For example, this is what the video should look like:
    https://youtu.be/x-CjxcvlKQY

    But, when I export with Hardware Encoding enabled, this is the result:
    https://youtu.be/G_-NLqxSDsU

    Does anyone know how to fix this? When I disable Hardware Encoding the video exports normally and there are no color distortions. However, I'd really like to enable it because it greatly…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. how about premiere use both my GPUs not just one and less Processors. Media encoder uses both.

    how about premiere use both my GPU and less Processors. Media encoder uses both

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. 3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. i mac Ritna 5k Hardware compatibility problem with the premier colors

    When import any type of video files in the premier the video's colors turns contrasty and darker than the original video file.
    so i can't color grade any video which is a big problem

    it's a hardware compatibility problem as i understand from my search on the internet and as i understand from the adobe support team that adobe didn't solve this problem yet for the specific version of the i mac ritna 5k

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Please add support for NVidia GeForce 870M

    Razer, a popular brand of gaming laptops, marketed their Blade laptops as designed for video editing. It worked great until fairly recent updates of Premiere in CC. I now also receive a notice that the NVidia GeForce 870M is not supported. I have two editing machines that rely on that. Please add support. Thank you!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. Bug Nvidia Quadro 2000

    Hi. I need a support for a problem detected on my Nvidia Quadro 2000. I was had Premiere version 2018 and not it happened this problem. Please help me! I already installed the old version of the NVIDIA driver and last version, but nothing happen. How can I fixed it?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base