Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Radeon 5500 XT 8 Go GDDR6 on iMac 27'' 2020

    Hi, could check if the new iMac 27" will work fine with GPU Radeon Pro 5500 XT 8 Go ? It's not in the recommended graphic cards tested by ADOBE, but it's on the latest iMac 27 top level. Thanks.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  2. Premiere fill my GPU memory and cause black screen preview

    Premiere fill my GPU memory and cause black screen preview, i see in the task manager, sadly my GPU GTX 750 have only 2GB of RAM.

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  3. GPU Bug on Version 14.7 / 14.8

    Pr Pro running on Windows 10 Pro - Version 14.7 + 14.8
    Ryzen 3600 + GTX 1650 Super 4GB + 64GB 3000MHz + Everything Premiere-related on different Sata SSDs / M2 NVMe SSDs

    Overusage of the GPU: Extending clips or elements on the timeline creates lag of the whole computer due to GPU being used at 100% - Mainly on 14.7, no solution found.
    GPU freezes every now and then during playback (black screen but audio still plays back) - Solution: restart premiere.

    Edit: these problems occur mostly when working with 8bit and 10bit H264 footage. No issue when editing…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  4. Premiere Pro 14 (2020) constant crashes when using GPU, Lumetri Bugs

    Premiere pro 14 (all versions) are unusable when mercury OpenCL acceleration is being used as it crashes the application. I'm stuck with version 2019. HW acceleration works albeit some functions such as applying LUT's and changing highlights, matching colors, contrast are unusable with real-time acceleration, leading to a black screen. I have to switch between software and OpenCL, giving me 7 hours of render times for a 5 minute color correction using Lumetri. Please help.
    GTX 470, High Sierra 10.13.6,

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  5. 8 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  6. Possible Bug with Exporting Mogrts Using Latest P6000 Video Card Driver

    I’m flagging up a problem with a recent NVIDIA update for anyone that is experiencing export problems.

    1. I’m using PPr/ Me 14.7 and Ae 17.5, running on an Intel Xenon w-2123 (3.60GHz) CPU and a Quadro P6000.

    2. I updated my Quadro driver from 460.89 to v 461.09 at the start of the week. Editing after on PPr was untroubled. I also made a couple of basic new Mogrts in Ae.

    3. All was fine for a day or so until I exported a project via Me that included one of the new mogrts made since updating my Quadro. The export hung…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  7. Metal Engine always renders 8 Bit

    have a MacPro 2019 (7,1) with two Vega II graphics with Premiere 14.5 on a Catalina 10.15.7
    I have 10 bit video files and while working with these files I see a lot of banding on the sky.
    I have tried different configs to understand the issue.
    My sequence settings use Maximum Bit Depth.
    When the Metal engine is ON, there is no diffrence with the OFF state at the Program Monitor.
    And when I render with the Maximum Depth / 16bpc the output is same, a lot of banding.
    But When I swicth my project settings to openCL. I…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  8. Support ProRes RAW on AMD GPUs

    Hi Team,

    I think it would be fair to all Premiere Pro users (and buyers) whom own AMD graphic cards to get support for ProRes RAW on Windows as it's now supported only on NVIDIA cards in Windows.

    Thanks

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  9. Bug: video and audio are not synchronized

    when using AMD GPU with the latest ME & PR version 14.5
    update: the problem is still in the new 14.7 version. plz compare the two videos I uploaded.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  10. Rolling Title GPU Acceleration Broken

    After spending all day testing and troubleshooting I have finally determined that the GPU Acceleration for Rolling titles is broken.

    I have 10 machines with 24 cores, 128GB ram and RTX 2080TI video cards running windows 10, latest premiere version with latest Nvidia studio drivers., SSD drives and 16GB fibre channel storage.

    I finally narrowed things down to a simple test and shot a little video of my screen so there would be no conflict with any screen capture software.

    If you make a 9 line rolling text everything works just fine, but when you add the 10th line the…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  11. Please Improve Metal Support in macOS

    Metal support in Premiere Pro 2020 is currently very bad. On a Radeon VII under macOS Catalina, I'm seeing encode times from a ProRes 4444 timeline to ProRes HQ output taking 45-50 minutes for a 4-minute piece. That same piece encoded in under 10-minutes using OpenCL. Additionally, native Adobe plugins that work fine in OpenCL give a red banner CPU warning under Metal. There is no RED SDK support either. Clearly Metal render support needs work, especially if OpenCL is being deprecated. Please improve Metal support under macOS in Premiere Pro and across all professional media creation applications. Thanks.

    19 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  12. Composite In Linear Color nvidia update

    The most recent Nvidia driver update has affected the way my alpha channels were rendered where anything has a glow. Everything was fine the other day and then I updated my graphics card to 456.71 and suddenly the glows are very obtrusive and in places they shouldn't be. I had to turn off Composite In Linear Color to fix it.

    The only thing that has changed between opening the project last time was the Nvidia driver. I suspect a conflict has arisen.

    You can see in the screenshots before and after toggling off Composite In Linear Color.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  13. CUDA Acceleration Displaying INCORRECT FRAMES

    Hello,

    I've now realized how many problems related to premiere have stemmed from GPU CUDA Acceleration, one of which being premiere displaying incorrect frames with both playback and scrubbing. In fact, it even shows the wrong portion of the entire clip, so all of my masking effects are out of place and make no sense. When I turn on Software Encoding, everything works fine but it's all at a snail-paced editing speed. I'm editing a music video and I have a lot of effects that require GPU Acceleration (along with a lot of speed ramping), so please please PLEASE Adobe…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  14. hardware acceleration

    enable hardware acceleration on GTX 1660 or offer another hardware acceleration system than CUDA that doesn't support all graphics cards

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  15. Support MacBook Pro 2020 GPUs

    Why does Premiere Pro not support the actually used GPUs of the 2020 MacBooks like the AMD Radeon 5300M?

    I really don’t get it.
    I mean, the monthly fee for using the program is fair enough, but than I‘d expect to be able to use the full potential of an up to date MacBook Pro.

    For me, if Adobe will not include the actual GPUs, it would be a reason to switch over to Final Cut or Avid.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  16. Include GPU in more calculations.

    When cutting videos in 4K, I can't watch the video smoothly because the CPU does all the rendering work and the GPU does nothing. And I want Adobe to improve that the GPU does more with rendering and cutting.

    11 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  17. Premiere Lumetri curves is hugely corrupted with new nvidia driver, my gpu is 1070 ti

    pretty much the title, it's not a idea, it's just that when using curves in Lumetri in my footage the result gets fully corrupted and broken, with some weird white squares.

    When rendering only in CPU this is solved, but preview time gets hugeeely slower

    when downgrading the driver the issue is also solved, but this isn't a optimal solution since it's best for every other application and even premiere to have the most updated drives. I attached a image file showing how this glitch looks

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  18. A low-level exeption occurred in: Adobe Player <Player:5) after todays update in Win 10.

    A low-level exeption occurred in: Adobe Player <Player:5) win10 - now no preview!

    6 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  19. Hardware coding MXF

    Hello, currently there is no hardware coding for video in format MXF.

    Will such functionality implemented in the future and when?
    Can you offer some alternative workflow for us?

    7 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  20. eGPU Support is Poor

    Out of all the major video editors, Pr Pro has the poorest support for eGPUs on Mac. Please enable your users with support your competition has. It is almost as if there are no added bonuses.

    27 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    7 comments  ·  GPUs  ·  Flag idea as inappropriate…  ·  Admin →

    How important is this to you?

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
  • Don't see your idea?

Feedback and Knowledge Base