Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Bug when attempting to edit Essential Graphics elements attached to a clip

    -----DESCRIPTION-----
    Attempting to modify/edit an Essential Graphics (hereafter abbreviated EG) element attached to a clip of any sort from the Effect Controls panel(!) causes a serious bug.
    This bug didn’t affect the 2017 version of Premiere Pro and was introduced with the 2018 update.
    To demonstrate this, I’ve included a link to the same project for both 2017 and 2018 versions of Premiere Pro:
    https://goo.gl/vx5YSy

    -----AFFECTED ITEM TYPES-----
    Basically any item type that can have EG elements attached to it is affected. These are:
    * Footage (video, vector/raster images)
    * Sequences
    * Solids (Adjustment Layer, Black Video, Color Matte, Transparent…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Essential Graphics  ·  Flag idea as inappropriate…  ·  Admin →

    Arthurs, thank you for posting those test projects up front. That is very helpful and saves us both time.

    Arthur and I have been able to get to the bottom of this. There was an unintentional piece of workflow that was allowing this to happen. That will be fixed, so there should be no way to paste Graphics Layers into non-Graphics items. There are other ways to keep media, shapes, and text together inside a single trimmable item. Arthur and I have discussed some of those ways. If others are wanting to do what Arthur has been doing, please add a new post explaining what your intended workflow is and we will help you find a way to work with the feature set as designed.

    I’m closing this request as Completed now because the root problem is known and slated to be be fixed as soon as possible.

  2. Selecting a graphic in the timeline should open the edit properties for the graphic within the EG Panel

    When I click a graphic in the timeline, I then need to also select it in the Essential Graphics Panel to access its properties. It would be much better if the properties were open automatically, since I might need to change multiple graphics it would save a lot of mousing

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Completed  ·  3 comments  ·  Essential Graphics  ·  Flag idea as inappropriate…  ·  Admin →
  3. Easier editing of captions in Essential Graphics

    Easier editing of captions in Essential Graphics

    There is currently no way of changing the font of multiple graphics together at once, I hope to see an update to support certain attributes in Essential Graphics to be copied and pasted over.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Completed  ·  2 comments  ·  Essential Graphics  ·  Flag idea as inappropriate…  ·  Admin →
  4. Fix source text bug when keyframing text

    I'm trying to create a typewriter effect using the type tool with source text to keyframe each character. However, when I add a new keyframe, the text starts writing backwards.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    Completed  ·  3 comments  ·  Essential Graphics  ·  Flag idea as inappropriate…  ·  Admin →
2 Next →
  • Don't see your idea?

Feedback and Knowledge Base