Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Default transitions issue and color problem in 2021

    I am tired and ****** off by Premiere default transition not working as expected. And this issue has not been solved for 9 years. You can see this issue when you do this:
    1) Create some text on top of some video
    2) Apply default transitions on text layer
    Now go on timeline in the middle of this transition on text layer. Transparency should be there 50 percent, but it isn't. Default transitions in Premiere appear ugly and fast and making them longer doesn't help. With white text I have found that I can use screen transparency mode to fix…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  2. Default transitions issue for about 9 years and color problem in 2021

    I am tired and ****** off by Premiere default transition not working as expected. And this issue has not been solved for 9 years. You can see this issue when you do this:
    1) Create some text on top of some video
    2) Apply default transitions on text layer
    Now go on timeline in the middle of this transition on text layer. Transparency should be there 50 percent, but it isn't. Default transitions in Premiere appear ugly and fast and making them longer doesn't help. With white text I have found that I can use screen transparency mode to fix…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  3. Problems with opacity when using different speedramps in one clip

    if you do some different speedramps (all about 100% - 400%) in one clip with several keyframs and if you want to put the opacity to 0% nearly at the end (also with 2 keyframes) the picture disapears much earlyer as the keyframes are set!

    Ist there a solution?
    If an tchnican from adobe needs the file i can send it!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  4. Premiere Pro needs an "FX Chain"

    I'd like to be able to save a chain of FX that I use on both video and audio and then be able to apply that in a completely separate project without having to have both projects open at the same time. That way I can just add the chain rather than each individual effect and preset per each effect.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  5. Linear Wipe effect not working on Frame Hold clips in Premiere V15.0.0

    I just installed V15.0.0 on Mac OS10.15.7. Linear Wipe effect works on a linked AE comp but not on a clip that has Add Frame Hold applied. The Transition Completion slider works but I'm unable to keyframe it.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  6. Keyboard Shortcut mappings for Blend Modes

    One of the things I REALLY miss about Final Cut Pro 7.0 was the ability to map Blend Modes to keyboard shortcuts.

    As a finishing editor & colorist, I spend a LOT of time conforming editor's timelines for color correction in Davinci Resolve, and eventual roundtrip back into Premiere. This task constantly requires that I be able to compare stacked clips with each other using "Difference" mode on the top clip, which makes it really quick to slip and slide clips into alignment with each other.

    In FCP 7.0, I would just map "Difference" to a keyboard shortcut, and another…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  7. Transition Visibility toggle in Effect Controls panel (so we can always see the result of keyframe adjustments in the Program Monitor!)

    PROBLEM:
    A clip has Motion keyframes set at its first and last frame. The clip also has an outgoing cross dissolve applied to it. The user wants to adjust the position, scale and/or rotation keyframes at the end of the clip, but cannot see the clip in the Program Monitor because of the cross dissolve which gives the clip an opacity of 0% on its last frame.

    WORKAROUNDS:
    a) Drag keyframes to be adjusted outside the range of the transition, adjust them, and then drag them back to the clip's last frame. A side effect of this workaround is the…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  8. Rounded corners in video for Picture in Picture tutorials.

    Please add radius control for corners of a video. Using it for Picture in Picture. Currently possible with a few steps but corner radius control would help speed up workflow. See attached file for example.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  9. Premiere's Morph cut is not as good as Avid's

    Says it all in the title. Avid Media Composer's morph cut is about three times as fast as Premiere's, and gives better, more naturalistic results. That's the comment.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  10. ENABLE Masterclip Effects

    There really needs to be functionality to enable Masterclip effects for multiple clips. Working with LUTs is a must for offline but I regularly use workflows that lead me to export un-modified timelines as prores for Grade. Batch disabling masterclip effects is useful for this. I am aware of the global fx mute but that can interfere with other timeline effects that I may still want to render. Besides that, batch LUT management should be far easier in that regard

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  11. Warp stabilizer bug

    Warp stabilizer needs to analyze the video every time I move the clip on my timeline or even one of its neighbor clips. It is veeery annoying!!!
    I never had this problem before. This happens after the new update 14.9.0 Build 52

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  12. Audio Effects not working after sending file to co-worker.

    After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of "L" and "R" on the audio effect. The only way to fix this appears to be to remove all audio effects and re-apply them manually. On some projects this can take hours to days to do.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  13. Audio Effects not working after sending file to co-worker.

    After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of "L" and "R" on the audio effect. The only way to fix this appears to be to remove all audio effects and re-apply them manually. On some projects this can take hours to days to do.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  14. After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of L and R on the audio effect.

    After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of "L" and "R" on the audio effect. The only way to fix this appears to be to remove all audio effects and re-apply them manually. On some projects this can take hours to days to do.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  15. After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of L and R on the audio effect.

    After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of "L" and "R" on the audio effect. The only way to fix this appears to be to remove all audio effects and re-apply them manually. On some projects this can take hours to days to do.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  16. After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of L and R on the audio effect.

    After opening a project sent by a co-worker, all audio clip's effects are not working. Shows " _ " instead of "L" and "R" on the audio effect. The only way to fix this appears to be to remove all audio effects and re-apply them manually. On some projects this can take hours to days to do.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  17. Enable Baseline Snapping for Scale Graphs and Value Graph for Position Keyframes

    It is really essential to have a baseline enabled for both value and speed graphs of the Scale motion property that we can snap to in the effect controls panel.
    Also necessary to have a value graph added to Position motion property in addition to the speed graph.
    In other words, value and speed graphs for properties inside the effect controls panel should work exactly like they do in after effects

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  18. Please correct error with new version 14.9 disabling use of Ultra Key

    Ultra Key green screen removal worked with previous 13.1.5 version, is now not working after update. So far no update after 13.1.5 is without problems of some kind. Please run software through QC before releasing.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  19. Warp stabilizer needs to be fixed

    I have warp stabilizer applied to many clips on timeline. But the effect is not staying applied in many cases. When the playhead is later placed over a previously stabilized clip, or an export is started, I find the clip needs to be analyzed again. This is under 14.9.0 Build 52. Extremely annoying.

    I've also noticed that sections of the sequence I previously rendered are no longer rendered, and nothing has been changed on the timeline there since last rendering. I haven't had time to chase this down at all.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  20. copy and paste effects

    Hey,

    I know we have the sophisticated copy and paste.

    But sometimes when working its convenient to just copy and past one or 2 or 3 effects from one clip in the timeline to a second on.

    Can we pls have the ability to do so?

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Effects & Transitions  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base