Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Update turned all my video blue

    Updated to Premiere Pro 15.0 build 41, and it turned all of my canon.mxf files blue! The original footage is not blue of course, only when I am in premiere. Old projects, and also when I create new ones. HELP!!!!!! Say no to the smurfs!

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  2. QT Gamma Compensation LUT bug in newest M1 Beta

    Whenever I try to apply the compensation LUT, it turns the whole video black. I can apply any other LUT just fine. But that one LUT just bugs out the whole video.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  3. Wrong colours with Canon C300 Mark II/III footage

    XF-AVC footage from Canon C300 Mark II & Mark III are displayed with weird colours in the Premiere Pro M1 beta. The specs of the footage are: 2048 x 1080 RGB444 (12 bit/225Mbps Intra).

    The correct colour is the bottom left clip in the Source monitor.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  4. Add color charts PLEASE!!

    The last post regarding this has over 600 upvotes!!! When are we going to see this in Premiere? Resolve and FCP X have both had this for years.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  5. Masterclip LUTs intermittently stop displaying

    We use a lot of Amira footage and normally the LogC-to-Rec709 camera LUT is automatically applied by Premiere Pro as a masterclip effect by default. Problem is when I reopen the project the LUTs do not show up - I can see them in the masterclip lumetri effect has the embeded Amira LUT in the creative tab , but the effect doesn't do anything if i turn it on or off - and there isnt a way to get access to that embeded LUT any other way.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  6. Bug in 15.0

    I am getting a glitch with Lumertri color when applied to source clips and then using a cross dissolve on that clip.
    I have to remove the Lumetri color on the source clips and just apply it on an individual clips to prevent this from happening.
    This started with PPRo 15.0.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  7. Add more LUTS to the Basic Correction Pane, Input LUT drop down

    I use several LUTs that don't come supplied with Premiere (from Sony, Alister Chapman, etc.). To use them I have to browse to my LUTS directory every time I go to the Lumetri panel's Input LUT dropdown. It would be nice to be able to add them to the drop down or remove some of the supplied LUTS that I never use.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  8. RAW to LOG conversions for ProRes RAW

    ProRes RAW has been implemented inside of Premiere now but it is cumbersome. My workflow remains the same as before support has been added where I need to conform my footage to LOG inside of FCPX and then import that to Premiere. This makes all the work that went into implementing ProRes RAW into Premiere useless to me because I still have the same workflow as before.

    I am suggesting taking an approach like FCPX where in the clip options there be a selector for “RAW to LOG Conversion” that allows you to conform the linear footage that ProRes RAW…

    15 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  9. It changes the color of my video when I drag It in Premiere Pro

    whenever I drag any video to my timeline, it always changes the color and it makes it a hassle to color correct every time

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  10. BUG: Sony A7SIII H.265 HLG doesn't display correctly in Premiere and After Effects

    Premiere and After Effects seem to be misinterpreting some specific A7SIII footage.

    When recording in XAVC-S (H.264, 422, 10-Bit), with an HLG picture profile everything works as expected. In all three programs the clip looks the same.

    Premiere: Looks correct in timeline and export
    After Effects: Looks correct in timeline and export
    DaVinci Resolve: Looks correct in timeline and export

    When recording in XAVC-HS (H.265, 422, 10-Bit) in an HLG picture profile...

    Premiere: gamma is abnormal with raised shadows and pronounced grain in both timeline and export
    After Effects: same as Premiere
    DaVinci Resolve: Same clip looks correct
    Exported from…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  11. hlg footage looks darker

    HLG Videos: When you play it on windows, it looks over-exposed, and you drop it to the premiere pro timeline, it looks under-exposed. I don't get it. Does anyone know how and why? Thanks

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  12. LUT playback problem

    When i use a 64 grid ponits LUT in versions 14.3.2 and 14.4, the playback is laggy. For a smooth playback in these versions, i must convert all my LUTs from 64 to 32 grid points.

    Please fix this bug.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  13. ACES colour space PLEEEEAAAASSSSEEEEEE!!!! :)

    Please include ACES as an option for colour workflow. Would also be very nice to have the metadata for Sony FX series cameras usable in Pr. Stabalisation and ISO EI would be great!!!

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  14. Color Match not working on Master tracks

    When I try to use Color Match on a Lumetri Color under the "Masted" tab, it doesn't work.

    The workaround I use is to apply the Color Match on a specific clip and then Copy + Paste it on the Master tab.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  15. Bring compatibility for Avid Artist Color control surface vía Eucon

    Please let us use the Avid Artist Color with Lumetri

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  16. Have an alternative option for the effects/LUTs preview image

    Have an alternative option for the effects/LTs preview image. Please.
    That kid is tiresome.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  17. BUG: Lumetri White Balance Picker is broken

    The Lumetri white balance picker is fundamentally broken. - it doesn't do what it should be doing as far as I can tell.

    When I use it to balance a video to something that should be white in a scene - it completely shifts the color to something that is not white in any way shape or form - it shifts the temperature and tint sliders seemingly at random and makes turns things into colors that clearly aren't white. If I have something that I know is white (like a wall) with a slight tinge of color and I click…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  18. BUG: Lumetri White Balance Picker is broken

    The Lumetri white balance picker is fundamentally broken. - it doesn't do what it should be doing as far as I can tell.

    When I use it to balance a video to something that should be white in a scene - it completely shifts the color to something that is not white in any way shape or form - it shifts the temperature and tint sliders seemingly at random and makes turns things into colors that clearly aren't white. If I have something that I know is white (like a wall) with a slight tinge of color and I click…

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  19. It changes the color of my video when I drag It in Premiere Pro

    whenever I drag any video to my timeline, it always changes the color and it makes it a hassle to color correct every time

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  20. Masks cause playback issues

    Adding masks to Lumetri creates playback issues where media will not play back in real time, even if the Global FX Mute button is engaged. The only solution has been to turn off the Lumetri Effect with the mask on it. Makes working with power windows rather difficult.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 17 18
  • Don't see your idea?

Feedback and Knowledge Base