Premiere Pro

Welcome to the Adobe Premiere Pro feedback page. Submit feature requests and bug reports to the Premiere Pro team via this UserVoice page and see what ideas or issues other users have shared.

  • Type into the idea field to search for submissions or choose from the categories in the sidebar
  • Check out other submissions and vote for the ideas you like
  • If your feature idea or issue is not listed, post it

The UserVoice feedback pages are for feature requests and bug reports only. Upload only content that you have permission to use and refrain from posting personal information (e.g. address, phone number, email, or credit card) or abusive content (spam, phishing links, vulgar language, etc.). Tips for submitting useful feedback

UserVoice is a third-party platform for product feedback. Please note that feedback is voluntary, and you give Adobe a right to use feedback you provide without restrictions.

For all other questions and discussions, visit the Premiere Pro community forum.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Update turned all my video blue

    Updated to Premiere Pro 15.0 build 41, and it turned all of my canon.mxf files blue! The original footage is not blue of course, only when I am in premiere. Old projects, and also when I create new ones. HELP!!!!!! Say no to the smurfs!

    5 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  2. Issue applying effects (warp stabiliser or lumetri color)

    When applying effects to clips it causes the color to blow out and appear overexposed. This doesn't happen for every clip and can sometimes be avoided by nesting but this is very frustrating.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  3. User choice to import RED R3D Files as log or rec709 rather than have a default behavir

    Give us the option to have RED R3d files be imported in as either Log or Rec709 rather than have it chosen for us by the program. Having it default to LOG really impacts the speed of our workflow on shorter, less color sensitive projects. Granted we grade from log for a lot of our work but some projects just need to be pushed out the door with a minimum of clicks and time and having to open the master clips to make changes takes a lot of time on a quick turnaround. It would be great to be able…

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  4. Export Frame JPEG "looks darker" (embedded sRGB color profile should be Rec.709)

    Since 14.4.0, when using Export Frame to export a JPEG, it is darker than a PNG or TIFF export, while they used to be consistent.

    This can easily be reproduced by adding a HD Bars and Tone in a fresh project/sequence and using Export Frame to export a JPEG and PNG still, and comparing them in Photoshop.

    That "darker" output is exactly the difference between sRGB IEC61966-2.1 and Rec.709 Gamma 2.4, for example if you open the "good" PNG in Photoshop assign it a Rec.709 Gamma 2.4 profile (Edit => Assign Profile) it now looks like the JPEG. But Premiere…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  5. QT Gamma Compensation LUT bug in newest M1 Beta

    Whenever I try to apply the compensation LUT, it turns the whole video black. I can apply any other LUT just fine. But that one LUT just bugs out the whole video.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  6. Provide area to post BUGS, do not release APP with bugs

    Lumetri Color Corrector in inoperable in newer versions of Premiere Pro
    MTS HD video file placed on timeline.
    Apply Lumetri Color to video file
    Adjust Exposure in Basic Correction

    NOTHING HAPPENS
    

    This works and doesn't work in the following versions of Adobe Premiere Pro
    Version 14.7.0 (Build 23) does not work
    Version 15.1.0 (Build 48) does not work
    Version 13.1.5 (Build 47) works just fine

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  7. Bring compatibility for Avid Artist Color control surface vía Eucon

    Please let us use the Avid Artist Color with Lumetri

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  8. Add color charts PLEASE!!

    The last post regarding this has over 600 upvotes!!! When are we going to see this in Premiere? Resolve and FCP X have both had this for years.

    4 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  9. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  10. incorrect luminance levels introduced in v15.2

    In 15.0 and 15.1, 422-10-bit footage from the Canon EOS R6 appears to be correct. Superwhites at 110 IRE, and black between 0 and 10 IRE.

    Now in 15.2, the levels seem wrong. White is clipping at 100 IRE rather than 110, and the black level seems elevated above 10 IRE.

    Screenshot attached.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  11. Masterclip LUTs intermittently stop displaying

    We use a lot of Amira footage and normally the LogC-to-Rec709 camera LUT is automatically applied by Premiere Pro as a masterclip effect by default. Problem is when I reopen the project the LUTs do not show up - I can see them in the masterclip lumetri effect has the embeded Amira LUT in the creative tab , but the effect doesn't do anything if i turn it on or off - and there isnt a way to get access to that embeded LUT any other way.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  12. ACES colour space PLEEEEAAAASSSSEEEEEE!!!! :)

    Please include ACES as an option for colour workflow. Would also be very nice to have the metadata for Sony FX series cameras usable in Pr. Stabalisation and ISO EI would be great!!!

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  13. Bug in 15.0

    I am getting a glitch with Lumertri color when applied to source clips and then using a cross dissolve on that clip.
    I have to remove the Lumetri color on the source clips and just apply it on an individual clips to prevent this from happening.
    This started with PPRo 15.0.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  14. hlg footage looks darker

    HLG Videos: When you play it on windows, it looks over-exposed, and you drop it to the premiere pro timeline, it looks under-exposed. I don't get it. Does anyone know how and why? Thanks

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  15. Add more LUTS to the Basic Correction Pane, Input LUT drop down

    I use several LUTs that don't come supplied with Premiere (from Sony, Alister Chapman, etc.). To use them I have to browse to my LUTS directory every time I go to the Lumetri panel's Input LUT dropdown. It would be nice to be able to add them to the drop down or remove some of the supplied LUTS that I never use.

    3 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  16. RAW to LOG conversions for ProRes RAW

    ProRes RAW has been implemented inside of Premiere now but it is cumbersome. My workflow remains the same as before support has been added where I need to conform my footage to LOG inside of FCPX and then import that to Premiere. This makes all the work that went into implementing ProRes RAW into Premiere useless to me because I still have the same workflow as before.

    I am suggesting taking an approach like FCPX where in the clip options there be a selector for “RAW to LOG Conversion” that allows you to conform the linear footage that ProRes RAW…

    15 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    6 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  17. Lumetri effects lose editing scope in multicam sequences on any setting change

    This is a bug that has really annoyed me for years and I just got around to writing it up. So I use multicam sequences for all of my interviews (normally two HD or 4K cameras with synced audio, and a separate high quality wav file synced through pluraleyes and imported to premiere via XML). When I take the synced multicam sequence and cut pieces of them into another timeline to create a video with the multicam option enabled on each clip in the sequence - and then hop inside of the main multicam nested sequence to color my footage…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  18. It changes the color of my video when I drag It in Premiere Pro

    whenever I drag any video to my timeline, it always changes the color and it makes it a hassle to color correct every time

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  19. BUG: Sony A7SIII H.265 HLG doesn't display correctly in Premiere and After Effects

    Premiere and After Effects seem to be misinterpreting some specific A7SIII footage.

    When recording in XAVC-S (H.264, 422, 10-Bit), with an HLG picture profile everything works as expected. In all three programs the clip looks the same.

    Premiere: Looks correct in timeline and export
    After Effects: Looks correct in timeline and export
    DaVinci Resolve: Looks correct in timeline and export

    When recording in XAVC-HS (H.265, 422, 10-Bit) in an HLG picture profile...

    Premiere: gamma is abnormal with raised shadows and pronounced grain in both timeline and export
    After Effects: same as Premiere
    DaVinci Resolve: Same clip looks correct
    Exported from…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
  20. Lumetri Color white balance eyedropper causes freeze/crash

    When I use the lumetri color panel to pick a color from the footage, if I hold down my click and go outside of the footage box, to the bottom, it causes my cursor to freeze and not be able to click on anything, inside or outside of the program. Even after pressing ctrl+alt+delete, my mouse would not click on anything and I had to navigate to the task manager with my keyboard, and only after shutting down Premiere through there did it let me use my mouse again.
    The first time I did this, Premiere itself popped up and…

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Color/Lumetri  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 18 19
  • Don't see your idea?

Feedback and Knowledge Base